Forum général.cherche-logiciel Mettre en place un cluster avec des laptops pour Dolphin

Posté par (page perso) .
Tags : aucun
1
24
jan.
2011
Bonjour,

Je souhaite jouer avec l'émulateur Dolphin.
J'ai un laptop A avec une bonne carte graphique mais seulement 2 cœurs qui sont utilisés à 100%, j'ai donc régulièrement des lenteurs. J'ai un autre laptop B avec 4 cœurs qui supportent aisément la charge de Dolphin, mais avec une carte graphique intégrée pourrie donc impossible de jouer à des jeux en 3D. Les deux laptops utilisent du Ubuntu ou dérivé, et sont en 64 bits.

J'aimerais jouer avec le laptop A tout en profitant des cœurs du laptop B.

Après quelques recherches, apparemment je veux mettre en place un cluster. Cependant je trouve des solutions qui ne sont plus maintenues, ou qui ne correspondent pas vraiment à mon besoin, du coup je suis un peu perdu.
Existe-t-il une solution pour "partager" les cœurs du laptop B au service d'une application du laptop A ?
  • # gros reseau

    Posté par . Évalué à 7.

    si je ne me trompes pas,

    1°) installer dolphin sur la machine avec les 4cores
    2°) lancer une session XDMCP depuis la machine avec la grosse carte graphique

    ca devrait donc etre le proc de 1 et la video de 2 qui sert.
    • [^] # Re: gros reseau

      Posté par (page perso) . Évalué à 2.

      Je bloque au 2°).

      J'ai testé plusieurs pages, dont le tutoriel d'Ubuntu-fr. Je suis finalement allé sur le wiki d'Archlinux en passant par Xnest, et j'arrive à une fenêtre présentant un bel écran noir (de même avec des commandes équivalentes pour Xephyr). Pour résoudre cela, le wiki conseille de modifier le fichier /etc/inittab, mais celui-ci n'existe pas sur Ubuntu.

      D'après AskUbuntu, c'est parce que xdmcp ne fonctionne pas avec gdm pour les dernières versions d'Ubuntu. Le problème serait aussi présent dans Debian, et le patch proposé ne résout pas entièrement le problème.


      Je cherche une autre façon de procéder…

      Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

      • [^] # Re: gros reseau

        Posté par . Évalué à 3.

        coté serveur, il faut juste activé le remote TCP
        c'est dans les options du gestionnaire de login

        coté client, effectivement un petit Xnest et TSClient
        ensuite depuis TSClient, tu lui dis de se connecter à ton "serveur xdmcp"
        et ca te l'ouvre dans une fenetre sur ton bureau.

        si tu veux faire plus propre, il faut effectivement modifié GDM pour lancer le Client XDMCP en guise de fenetre de login
        • [^] # Re: gros reseau

          Posté par (page perso) . Évalué à 2.

          Pour ceux qui rechercheront comment activer le remote TCP avec gdm (Gnome), il faut plutôt chercher comment l'empêcher d'être désactivé. À l'heure de ce message, c'est dans /etc/gdm/gdm.schemas qu'on trouve l'option DisallowTCP, mais apparemment ça varie souvent.


          Côté client par contre j'ai toujours un problème :
          XIO: fatal IO error 11 (Resource temporarili unavailable) on X server ":0.0"
          after 187 requests (187 known processed) with 0 events remaining.


          Que ce soit avec Xnest ou par TSClient utilisant xdmcp, juste le nombre de requêtes envoyées qui varie.

          Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

        • [^] # Re: gros reseau

          Posté par (page perso) . Évalué à 2.

          Vu que je ne sais pas trop ce que je fais, j'ai configuré de la même façon l'ordinateur 4cœurs censé être le serveur, et l'ordinateur CarteGraphique censé être le client.

          Le problème intervient peu importe qui se connecte sur qui : Xnest génère un écran noir. Soit j'arrête plus tôt et j'obtiens le message précédent dans la console (s/temporarili/temporarily/), soit je fais trainer et le curseur prend une forme de croix avec un message d'erreur dans la console plus conséquent :
          XDM: too many retransmissions, declaring session dead
          5 XSELINUXs still allocated at reset
          SCREEN: 0 objects of 104 bytes = 0 total bytes 0 private allocs
          DEVICE: 4 objects of 32 bytes = 128 total bytes 0 private allocs
          CLIENT: 0 objects of 168 bytes = 0 total bytes 0 private allocs
          WINDOW: 0 objects of 64 bytes = 0 total bytes 0 private allocs
          PIXMAP: 1 objects of 24 bytes = 24 total bytes 0 private allocs
          GC: 0 objects of 32 bytes = 0 total bytes 0 private allocs
          CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          CURSOR_BITS: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
          TOTAL: 5 objects, 152 bytes, 0 allocs
          4 DEVICEs still allocated at reset
          DEVICE: 4 objects of 32 bytes = 128 total bytes 0 private allocs
          CLIENT: 0 objects of 168 bytes = 0 total bytes 0 private allocs
          WINDOW: 0 objects of 64 bytes = 0 total bytes 0 private allocs
          PIXMAP: 1 objects of 24 bytes = 24 total bytes 0 private allocs
          GC: 0 objects of 32 bytes = 0 total bytes 0 private allocs
          CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          CURSOR_BITS: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
          TOTAL: 5 objects, 152 bytes, 0 allocs
          1 PIXMAPs still allocated at reset
          PIXMAP: 1 objects of 24 bytes = 24 total bytes 0 private allocs
          GC: 0 objects of 32 bytes = 0 total bytes 0 private allocs
          CURSOR: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          CURSOR_BITS: 0 objects of 8 bytes = 0 total bytes 0 private allocs
          DBE_WINDOW: 0 objects of 24 bytes = 0 total bytes 0 private allocs
          TOTAL: 1 objects, 24 bytes, 0 allocs
          1 DAMAGEs still allocated at reset
          TOTAL: 0 objects, 0 bytes, 0 allocs

          Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

          • [^] # plutot que les messages d'erreurs

            Posté par . Évalué à 2.

            tu pourrais nous dire quel fichier tu as modifié sur le serveur et surtout, nous marquez ici, les modifs que tu as faites ?
            • [^] # Re: plutot que les messages d'erreurs

              Posté par (page perso) . Évalué à 2.

              Bonne idée.

              J'ai suivi les liens suivants :
              http://doc.ubuntu-fr.org/tutoriel/comment_creer_un_terminal_(...)
              https://wiki.archlinux.org/index.php/Xdmcp
              D'où les modifications ci-après.

              Il n'y a pas de /etc/gdm/custom.conf sur mon système. Par contre il y a le fichier /etc/gdm/gdm.schemas :


              security/DisallowTCP
              b
              false


              xdmcp/Enable
              b
              true


              xdmcp/DisplaysPerHost
              i
              2


              Il contient déjà les nouvelles valeurs. Les valeurs initiales étaient :
              security/DisallowTCP : true
              xdmcp/Enable : false
              xdmcp/DisplayPerHost : 1
              Le contenu par défaut de gdm.schemas se trouve dans cette page : http://ubuntuforums.org/showthread.php?t=1673323

              J'ai modifié le fichier /etc/hosts.allow qui ne contenait rien (enfin, que des commentaires), et qui contient maintenant :
              gdm 192.168.1.
              J'ai testé aussi en indiquant l'adresse ip locale au complet de la machine cliente.

              Au niveau des ports à ouvrir, j'ai sorti le tank et j'ai fait la commande :
              iptables -F


              J'ai installé les paquets xnest, tsclient, et xfonts-cyrillic.

              Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

              • [^] # Re: plutot que les messages d'erreurs

                Posté par (page perso) . Évalué à 2.

                Raah, le xml s'est perdu dans les balises code pour gdm.schemas…

                Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                • [^] # Re: plutot que les messages d'erreurs

                  Posté par . Évalué à 2.

                  te biles pas pour le xml, j'ai retrouvé mes petits la dedans.

                  J'ai testé aussi chez moi, et j'ai les memes symptomes que toi.
                  En theorie il faut juste modifier le gdm.schemas.

                  Du coup j'ai demandé à mon ami americain G. qui, à la question "enable xdmcp with ubuntu 10.10"

                  me dit en troisieme lien :
                  "Ubuntu 10.10 ne supporte pas le protocole XDMCP pour des logins graphiques à distance. Les utilisateurs qui ont besoin du support XDMCP"
                  et m'envoie sur la page
                  http://doc.ubuntu-fr.org/notes_version_maverick

                  qui dit que pour pouvoir faire du XDMCP, il faut degager gdm et utiliser wdm ou xdm :(

                  avec wdm, le fichier à modifier est /etc/X11/wdm/wdm-config
                  il y a une ligne à commenter qui est indiquée par un commentaire
                  attention, le clavier est en anglais, et il faut patienter un peu apres avoir valider le mot de passe (il reaffiche tout de suite la ligne login, alors qu'il est en train de valider le mot de passe)

                  avec xdm, le fichier est /etc/X11/xdm/xdm-config mais je n'y arrive pas (mais il se fait tard, j'oublie peut-etre une option)
                  • [^] # Re: plutot que les messages d'erreurs

                    Posté par . Évalué à 2.

                    en lisant le lien fournit plus haut, j'ai avancé un peu

                    il semblerait que gdm ecoute en IPV6 quand la machine propose ipv6
                    et que forcement ca pose souci si les deux machines ne cause pas ipv6 ou si xnest/tsclient ne le fait pas.

                    j'ai desactivé ipv6 sur mon serveur

                    en editant le fichier /etc/default/grub
                    est en ajoutant ipv6.disable=1
                    aux options de boot de grub

                    puis regenerer le grub (update-grub)
                    et redemarrer.

                    et j'obtiens bien la mire de login de mon serveur depuis mon client
                    • [^] # Re: plutot que les messages d'erreurs

                      Posté par (page perso) . Évalué à 3.

                      J'ai désactivé ipv6 via grub comme indiqué ici : http://www.webupd8.org/2009/11/how-to-disable-ipv6-in-ubuntu(...)

                      Je testerai quand je rentrerai chez moi.

                      Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                      • [^] # Re: plutot que les messages d'erreurs

                        Posté par . Évalué à 2.

                        il me semble bien que c'est ce que je proposais dans le post precedent,

                        mais c'est bien de ne pas croire aveuglement ce qu'on dit sur un forum et de chercher une confirmation de son coté
                        • [^] # Re: plutot que les messages d'erreurs

                          Posté par (page perso) . Évalué à 2.

                          Ou plutôt que j'ai rentré la commande comme un sagouin, alors qu'il y avait une place dédiée dans le fichier où elle était destinée :)


                          J'ai une bonne nouvelle : XDMCP marche !
                          Le son est reproduit sur l'ordinateur serveur, ce qui me convient.


                          Mauvaises nouvelles :
                          _L'affichage est lent. La connexion se fait par câbles ethernet reliés à la Livebox, ce sera peut-être plus rapide avec une connexion Ethernet direct, mais ce qui ferait du bien c'est de la compression d'image.
                          _Xnest et TSClient lâchent l'affaire assez facilement, seul Xephyr est stable. Dans la fenêtre obtenue par Xephyr, Dolphin indique que c'est la carte graphique pourrie du serveur qui est utilisée pour le rendu.

                          J'ai fait http://www.dedoimedo.com/computers/xephyr.html avec ssh.
                          J'ai plus de clavier donc je reboot.

                          Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                        • [^] # Re: plutot que les messages d'erreurs

                          Posté par (page perso) . Évalué à 2.

                          Donc, je reprends ce que je disais au-dessus. Quand on écrit sans son clavier, c'est chiant.

                          J'ai cherché à me connecter tout en compressant ce qui se balade à travers la connexion à distance, ceci afin d'accélérer le rendu graphique. J'ai dû mal chercher mais ni X, ni Xnest, ni Xephyr, ni tsclient ne proposent de compression des données. J'ai alors trouvé un lien qui parle de faire ça avec ssh : http://www.dedoimedo.com/computers/xephyr.html
                          En appliquant la commande :
                          ssh -XfC -c blowfish roger@roger-laptop
                          avec gnome-session, ça a "mis en commun" les Gnomes du client et du serveur, et en voulant arrêter ça j'ai perdu le contrôle du clavier. En lançant Dolphin, ça plante dès le lancement d'un jeu.

                          Xnest arrive à planter rien qu'en voulant afficher un dossier.

                          Ce qui m'embête avec Xephyr c'est que Dolphin fonctionne avec, mais c'est la carte graphique du serveur qui est utilisée.

                          Apparemment le protocole NX est plus performant, mais si c'est pour le même résultat (la carte graphique du client n'est pas utilisée), ce n'est pas la peine d'essayer.


                          En utilisant X directement :
                          sudo X -query <adresse ipv4 du serveur> :1
                          J'ai une connexion assez rapide qui s'ouvre en Ctrl+Alt+F8. Pour l'instant c'est autant fonctionnel que Xephyr… Ce message devient long, donc je vais le poster et continuer les tests.

                          Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

                        • [^] # Re: plutot que les messages d'erreurs

                          Posté par (page perso) . Évalué à 2.

                          J'avais oublié la source de "NX c'est plus rapide" : http://www.linuxjournal.com/article/6713 (dans les commentaires, faire Ctrl+F et chercher "Compressing protocols")

                          Conclusion de si je passe par X :
                          _C'est plus rapide que Xephyr, mais ça reste quand même plus lent qu'en natif
                          _Dolphin ne peut lancer aucun jeu.

                          Que ce soit par XDMCP ou par VNC, apparemment le serveur se charge de tout calculer et balance ensuite le rendu vers le client. Pas moyen de mettre la carte graphique du client à contribution pour les applications serveur de cette façon.



                          Cependant, j'ai beaucoup appris sur les connexions graphiques à distance avec cette expérience. Je t'en remercie.

                          Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

  • # une question me vient à l'esprit...

    Posté par . Évalué à 2.

    que peut faire un emulateur pour utiliser 2 CPU à 100% ?

    alors je me suis dit, pourquoi ne pas essayer ce fameux dolphin...

    je demande à mon ami americain aux jumelles, et il me trouve
    http://www.dolphin-emulator.com/

    qui apparemment ne propose que des binaires windows
    ce qui semble confirmé par la page suivante et malgré le fait que la page d'accueil disent (windows, linux, osx intel)
    http://www.dolphin-emulator.com/system-requirements.html

    alors me vient la question... comment fais-tu tourner un truc visiblement developpé pour windows, sur ton linux...

    j'imagine avec un WINE,
    du coup ca explique surement les lenteurs (empilage de couches)
    les soucis en passant au travers du reseau...
    etc
    • [^] # Re: une question me vient à l'esprit...

      Posté par (page perso) . Évalué à 2.

      Dolphin existe sous Linux, et il y a un mainteneur qui a son ppa sur Launchpad :
      https://launchpad.net/~glennric/+archive/dolphin-emu

      La dernière version en date chez moi est la version 2.0 - révision 6897, compilée pour Ubuntu 10.10. "Juste" 35 révisions de différence. (Si on était vendredi, j'aurais dit que svn sapuh.)


      Quant à utiliser 2 CPU à 100%… C'est un émulateur pour des consoles (la Gamecube, les bornes d'arcade Triforce, et la Wii) sur une architecture PowerPC, avec des jeux entre 2002 jusqu'à aujourd'hui. Apparemment, un recompilateur JIT ça prend 2 cœurs à temps plein.

      Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.