Forum général.général Fedora, Freebox 4k, Transmission : ouverture de port impossible

Posté par . Licence CC by-sa
Tags : aucun
0
15
nov.
2017

Bonjour,

J'ai un PC de salon à base d'Intel Apollo Lake qui me sert de HTPC/NAS sur lequel je viens d'installer la dernière mouture de Fedora (27) avec GNOME comme interface. Puisqu'il est allumé une bonne partie de la journée je souhaiterais en profiter pour partager des images ISO de différentes projets via BitTorrent. J'ai donc installé Transmission qui me permet de télécharger les ISO mais qui ne les partage pas en retour. Un rapide tour dans les paramètres me permet de voir que le port utilisé par défaut (51413) serait fermé…

J'ai commencé par revoir la configuration du pare-feu de Fedora. Après l'installation, j'avais changé la zone par défaut à "public" et supprimé tous les services activé par défaut. Pour notre problème, j'ajoute donc le service nommé "transmission-client" à la zone "public" de manière permanente :
# firewall-cmd --zone=public --add-service=transmission-client --permanent

L'application de la règle devrait être effectif mais dans le doute je recharge le pare-feu manuellement :
# firewall-cmd --reload

Je vérifie que la configuration est correcte :
# firewall-cmd --get-active-zone
public
interfaces: emp1s0

et :
# firewall-cmd --list-services
transmission-client

Le pare-feu me semble a priori bien configuré mais après avoir testé à nouveau le port dans Transmission celui-ci apparaît toujours fermé…
Dans le doute je suis allé regarder dans le fichier de configuration du service "transmission-client" pour voir si j'avais bien le bon port d'ouvert :
nano /usr/lib/firewalld/services/transmission-client.xml
qui me confirme :
[…]
<port protocol="tcp" port="51413/>
<port protocol="udp" port="51413/>
[…]

Donc le problème ne vient pas de là. Je m'oriente alors vers le routeur Freebox 4k.

Dans l'interface de gestion je vais dans "paramètres" > "mode avancé" > "gestion des ports".

Titre de l'image

Là j'ajoute deux règles de redirection pour le port 51413 tcp/udp vers le même port de mon HTPC (identifié par IP fixe via bail DHCP permanent).

Titre de l'image

J'enregistre les modifications. Je redémarre la box puis le PC. Je teste à nouveau le port. Toujours fermé…

Là je sèche. Je ne suis pas un expert ni un professionnel, mais il me semble avoir remonté la chaîne de l'application jusqu'à Internet et il me semble que tout est bien configuré. Je ne vois pas d'où vient le problème, d'où ma demande d'aide : Quel élément est à revoir ? Ai-je omis une étape ? Comment rendre ce port visible dans Transmission ?

Merci d'avance pour vos idées ! ;)

  • # Transmission

    Posté par (page perso) . Évalué à 2 (+0/-0).

    Même souci avec une freebox revolution et un autre port de Transmission. Free bloquerait tout ????

  • # Autre piste

    Posté par (page perso) . Évalué à 3 (+2/-0).

    Bonjour,

    ça n'a peut-être rien à voir, mais ça ne pourrait pas venir du fait que Free par manque d'IPv4 partage chaque IP entre 4 utilisateurs, qui du coup n'ont droit qu'à 1/4 des ports ?

    • [^] # Re: Autre piste

      Posté par . Évalué à 2 (+0/-0).

      c'est tres probable
      sur les freebox revolution on a le meme souci,
      dans les infos de la BOX il est possible de voir quels sont les ports disponibles

      sinon, tu peux changer dans ta console free, et demander à avoir une IP complete,
      attention, ca prend un moment pour s'activer, et ca change ton IP publique
      il faut alors refaire tes DNS, reparametrer ton freebox compagnon, etc

      • [^] # Re: Autre piste

        Posté par . Évalué à 1 (+0/-0).

        sinon, tu peux changer dans ta console free, et demander à avoir une IP complete,
        attention, ca prend un moment pour s'activer, et ca change ton IP publique
        il faut alors refaire tes DNS, reparametrer ton freebox compagnon, etc

        J'ai vérifié dans mon comte Free et je n'ai l'option "ipv4 full-stack" pour avoir une IP complète. Il y a une manip' spécifique ou une demande à faire ?

        En tout cas c'est pas terrible Free sur ce coup..

        • [^] # Re: Autre piste

          Posté par . Évalué à 2 (+0/-0). Dernière modification le 16/11/17 à 18:11.

          l'option full-stack n'est peut-etre dispo que pour les clients Revolution et pas les 4K

          du coup, soit tu passes à la freebox revolution pour avoir l'option full-stack
          soit, à defaut, tu peux regarder les ports qui correspondent à ta connexion,
          puis configurer ton logiciel transmission et la redirection de port sur des ports qui sont à toi.

          • [^] # Re: Autre piste

            Posté par . Évalué à 1 (+0/-0).

            Je ne me sers pas de la box TV, juste du routeur et de l'accès Internet. Passer à la Freebox Révolution ne m'apporterait rien et me coûterait plus cher pour un motif finalement peu important.

            Je préfère fouiller l'option 2, mais comment je peux "regarder les ports qui correspondent à ma connexion" ?

            • [^] # Re: Autre piste

              Posté par . Évalué à 2 (+0/-0).

              Je préfère fouiller l'option 2, mais comment je peux "regarder les ports qui correspondent à ma connexion" ?

              sur ta page "compte client" chez free
              ou … sur le boitier TV, dans les parametres de connexion (je ne sais pas ou c'est dans la 4K)

              • [^] # Re: Autre piste

                Posté par . Évalué à 1 (+0/-0).

                Merci pour tes indications !

                Je suis allé dans la page de configuration de Freebox OS > "État de la Freebox" > onglet "État Internet"

                Il est indiqué : Adresse IP : XX.XXX.XXX.XXX (Ports 0 à 65535)

                Donc je bénéficie des ports entre 0 et 65535, mais celui de Transmission est le 51413 qui est donc compris la plage des ports qui me sont alloués par Free…

                Pourquoi cela ne fonctionne-t-il pas ? Le mystère reste entier.

                • [^] # Re: Autre piste

                  Posté par . Évalué à 2 (+0/-0).

                  et ton HTPC n'a pas changé d'IP entre la creation de la regle et tes tests ?
                  il est en IP fixe ?

                  vu qu'il est deja derriere le firewall de la freebox., tu as essayé en desactivant completement le firewall du ton "serveur" ?

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.