Forum général.général Firefox et logiciel associé aux fichiers

Posté par .
Tags : aucun
1
24
mar.
2011

Bonsoir,
je suis sous Firefox 4 et je me demande s'il y a un moyen pour qu'il utilise les logiciels du système associés aux types de fichiers pour l'ouverture. En effet, par exemple okular est associé sur KDE au pdf mais...pas de base sur Firefox (le mien en tout cas), il ne trouve pas le logiciel associé (il dit qu'il n'en connait pas). Du coup je sauvegarde le fichier et le lance en dehors de Firefox.
Pourtant ce n'est pas compliqué d'appeler l'application associée à tel ou tel type de fichier. Pourquoi firefox ne le fait pas ? J'avais déjà vu cette remarque il y a des années mais je n'arrive pas à la retrouver. Merci et bonne soirée

  • # s'il ne sait pas il faut lui apprendre

    Posté par . Évalué à 1.

    dans la fenetre qui te propose l'enregistrement, tu as aussi "ouvrir avec..."
    qui te permet alors de choisir le logiciel qui va bien

    et tu as une option "se souvenir"

    CQFD

    • [^] # Re: s'il ne sait pas il faut lui apprendre

      Posté par . Évalué à 2.

      Perso, je ne sais pas pourquoi, l'option "se souvenir" ne fonctionne jamais.

      J'ai même refait un profil tout neuf et rien à faire.
      Peut être un conflit avec une extension.
      Du coup j'édite le mimeTypes.rdf à la main.

      Donc je profite de ce post ...si quelqu'un a eu le même soucis et à trouvé le truc.

  • # Oui mais...

    Posté par . Évalué à 2.

    Merci, Oui sauf que...je suis sous linux et que je dois alors chercher dans l'arborescence ou se trouve le fichier binaire de mon application. Alors que ce serait plus simple d'utiliser les associations prévues par le système (wxWidgets, Qt le font...pas GTK+ ?)

    • [^] # Re: Oui mais...

      Posté par . Évalué à 2.

      probablement pas GTK quand tu es dans un environnement QT
      toujours le meme probleme dans la guerre du desktop, il y a bien des standards (freedesktop), mais il y a aussi des reliquats historiques

  • # Ce serait étrange

    Posté par . Évalué à 1.

    Puisque Qt le fait sous KDE et GNOME. GTK+ existe aussi sous windows, donc il a du l'implémenter aussi. Enfin bref je ne vais pas rentrer dans un troll dès le jeudi mais si c'est ça je crois que je vais rester sous Chromium alors ;-) (est ce un troll ;-)

  • # Moi j'ai jamais réussi

    Posté par . Évalué à 2.

    Après m'être longuement battu pour avoir les mêmes associations de fichier avec KDE, j'ai du me résoudre à utiliser le package patché par opensuse pour KDE. Je sais qu'il est dispo sous Archlinux dans AUR, mais je ne sais pas si il existe une version binaire dans tes dépots. Bon courage mais je ne suis pas sûr que changer de distribution soit une solution acceptable !

    Nom du package : firefox-kde-opensuse sous archlinux

  • # /usr/bin/xdg-open

    Posté par (page perso) . Évalué à 7.

    il faut associé l'ouverture des fichiers à /usr/bin/xdg-open ca fait parti de LSB, et ca s'adapte à l'environnement.

  • # Bug sempiternel

    Posté par . Évalué à 4.

    Voir https://bugzilla.mozilla.org/show_bug.cgi?id=397700 et tous les bugs associés. C'est le genre de bugs qui semble sans arrêt fixé et qui revient toujours. Apparemment les devs sont pour la plupart sous Windows, et les incohérences des normes et de l'implémentation des normes sous les différents bureaux dispo sous Linux, associées au peu de cas qu'ils font de ce problème, sont l'explication principale du fait que ça ne fonctionne toujours pas.

    Perso, je trouve ça aussi insupportable. Probablement pour des raisons historiques ou pragmatiques, FF arrive avec (1) son propre système de gestion des applications tierces et pire (2) son propre sélecteur d'applications, chose totalement inutile dans la plupart des environnements. Il semble difficile de demander aux devs de supprimer ce truc, il fait partie de FF et ils semble être utile sous Windows (je ne sais pas, je ne pratique pas).

  • # Ils n'ont pas pris le bon framework

    Posté par . Évalué à -2.

    Bonjour,
    aller c'est vendredi, fallait pas prendre GTK. En C++ avec wxWidgets ou mieux Qt (je sais ça troll sec) ça aurait permis d'avoir un truc fonctionnel.
    Merci Bonne fin de journée

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.