Forum général.général problème postfix et gmail

Posté par .
Tags : aucun
1
26
mai
2010
Bonjour à tous
J'ai configuré Postfix (Squeeze) afin d’utiliser le smtp de gmail en relayhost. Postfix marche
correctement en local mais il est impossible d'envoyer un mail à l'extérieur.
Mon fai est orange.fr
Merci d'avance pour toute aide.
M

mail maderios@gmail.com -s test

tail -f /var/log/mail.info

May 26 17:34:09 salix postfix/smtp[22814]: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out
May 26 17:34:09 salix postfix/smtp[22815]: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out
May 26 17:34:09 salix postfix/smtp[22814]: 2B8185B12C: to=, relay=none, delay=1589, delays=1484/0.01/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)
May 26 17:34:09 salix postfix/smtp[22815]: 58230274D18: to=, relay=none, delay=782, delays=677/0.01/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)
May 26 17:34:09 salix postfix/smtp[22816]: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out
May 26 17:34:09 salix postfix/smtp[22816]: 8B65F274D15: to=, relay=none, delay=847, delays=742/0.02/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)
May 26 17:34:39 salix postfix/pickup[22746]: 54089271232: uid=0 from=
May 26 17:34:39 salix postfix/cleanup[22824]: 54089271232: message-id=
May 26 17:34:39 salix postfix/qmgr[22747]: 54089271232: from=, size=293, nrcpt=1 (queue active)
May 26 17:34:39 salix postfix/error[22826]: 54089271232: to=, relay=none, delay=0.04, delays=0.02/0.01/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)

Problèmes:
port :25
normal que cela bloque
relay=none
Bizarre, alors que tout est paramétré pour que le relay soit le smtp de gmail
root@salix.localdomain ne risque pas d'être accepté par gmail. J'ai donc un mis 'smtp_generic_maps = hash:/etc/postfix/generic'
dans /etc/postfix/main.cf et édité un /etc/postfix/generic pour que mon
adresse mcmcpc@gmail.com qui sert à l'authentification soit envoyée par postfix à gmail.
Rien n'y fait, root@salix.localdomain est toujours là .....

Pour info
postconf -n

config_directory = /etc/postfix
myhostname = salix
myorigin = $myhostname
smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU) biff = no append_dot_mydomain = no alias_maps = hash:/etc/aliases alias_database = hash:/etc/aliases transport_maps = hash:/etc/postfix/transport mydestination = $myhostname, localhost, $mydomain disable_dns_lookups = yes relay_domains = relayhost = [smtp.gmail.com]:587 mynetworks = 127.0.0.0/8 mailbox_command = procmail -a "$EXTENSION" mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache smtp_tls_loglevel = 1 smtp_generic_maps = hash:/etc/postfix/generic smtp_tls_CAfile = /etc/postfix/cacert.pem smtp_tls_cert_file = /etc/postfix/gmail-cert.pem smtp_tls_key_file = /etc/postfix/gmail-key.pem smtp_tls_note_starttls_offer = yes smtp_tls_security_level = may smtpd_tls_CAfile = /etc/ssl/certs/cacert.pem smtpd_tls_cert_file = /etc/ssl/certs/gmail-cert.pem smtpd_tls_key_file = /etc/ssl/private/gmail-key.pem smtpd_tls_received_header = yes smtpd_use_tls = yes smtpd_enforce_tls = yes tls_random_source = dev:/dev/urandom smtpd_sasl_auth_enable = no smtp_sasl_auth_enable = yes smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd smtpd_sasl_local_domain = $myhostname smtp_sasl_security_options = noanonymous smtp_sasl_tls_security_options = noanonymous smtpd_sasl_application_name = smtpd

Avec TELNET
salix:/etc/postfix# telnet smtp.gmail.com 587
Trying 209.85.227.109...
Connected to gmail-smtp-msa.l.google.com.
Escape character is '^]'.
220 mx.google.com ESMTP l46sm195333wed.10
ehlo smtp.gmail.com
250-mx.google.com at your service, [90.22.118.203]
250-SIZE 35651584
250-8BITMIME
250-STARTTLS
250 ENHANCEDSTATUSCODES
starttls
220 2.0.0 Ready to start TLS
mail from:mcmcpc@gmail.com
Connection closed by foreign host.
  • # Problème réseau.

    Posté par . Évalué à 5.

    Fais un telnet vers n'importe quel autre SMTP que celui de Orange, sur le port 25, tu comprendras vite.

    Tu ne peux rien y faire, c'est le réseau de Orange qui est mal configuré.

    THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

    • [^] # Re: Problème réseau.

      Posté par . Évalué à 2.

      Et si je quitte Orange, existe-t-il d'autres réseaux mieux configurés ?

      "L'art est fait pour troubler. La science rassure" (Braque)

      • [^] # Re: Problème réseau.

        Posté par (page perso) . Évalué à 3.

      • [^] # Re: Problème réseau.

        Posté par . Évalué à 4.

        Ben.. chez les plus connus c'est pas brillant brillant, entre les ports bloqués, les protocoles bridés, les débits moisis vers certaines destination.

        Pour avoir du réseau de qualité faut te tourner vers des entreprises comme Nerim, ou des assos comme FDN.

        THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

        • [^] # Re: Problème réseau.

          Posté par (page perso) . Évalué à 4.

          Vous dramatisez un peu (même si je compte rejoindre FDN un jour) :

          je suis chez Dartybox, et je n'ai pas de problème pour mon serveur de mails perso. (j'ai "juste" une IP dynamique)

          Chez free, le port 25 est bloqué mais déblocable.

          Et chez Numericable, je n'ai pas eu de problème avec ça non plus.
  • # orange et la lutte anti-spam! \o/

    Posté par . Évalué à 2.

    bonjour

    j'ai le même problème chez orange, a l'étranger.
    comme j'ai quelques relations chez eux, ils m'ont expliqué que c'est leur facon de lutter contre le spam:
    on claque le port 25 uniquement chez nous, vu qu'on ne sait pas faire la relation entre une ip relevée sur un spam et la base de connexions ADSL....
    la solution officiellement proposée par ici, c'est de se démmerder avec du webmail (youpi) ou de passer par la case "achat d'une option IP fixe pour l'ADSL" (rien que cette option est 5x plus cher que l'abo ADSL 1024, au passage.....)

    pour contourner le problème vu que je n'ai hélas pas de filiale de FDN ici, il ne me reste plus qu'a passer sur un relayhost depuis un autre port, comme le 587 pour Gmail.

    par contre, votre conf postfix me parait un poil light:
    ici, j'ai un canonical_map qui fait le lien entre les comptes locaux et les comptes externes, par exemple:
    user1 user@gmail.com

    un fichier passwd avec les adresses mails et le login/pass a utiliser sur le relayhost:
    user@gmail.com login:pass

    et enfin un fichier relayhost_map pour refiler le bon relayhost en fonction de l'adresse mail:
    user@gmail.com gmail.com:587

    avec ces quelques fichiers, ca devrait faire la traduction des adresses locales vers les adresses du relayhost, puis se logguer sur le relayhost concerné avec les login/pass du user-qui-va-bien.
    • [^] # Re: orange et la lutte anti-spam! \o/

      Posté par . Évalué à 1.

      Bonjour
      J'ai reconfiguré. Bizarre que le port 587 n'apparaisse pas alors qu'il est dans la conf.
      Postfix essaie de passer par le port 25, et voilà:
      tail -f /var/log/mail.info
      May 27 14:34:49 salix postfix/qmgr[6570]: 2474E14721F: from=<mcmcpc@gmail.com>, size=276, nrcpt=1 (queue active)
      May 27 14:35:10 salix postfix/smtp[6629]: connect to gmail-smtp-in.l.google.com[209.85.229.27]:25: Connection timed out
      May 27 14:35:31 salix postfix/smtp[6629]: connect to alt1.gmail-smtp-in.l.google.com[209.85.219.55]:25: Connection timed out
      May 27 14:35:52 salix postfix/smtp[6629]: connect to alt2.gmail-smtp-in.l.google.com[72.14.221.27]:25: Connection timed out
      May 27 14:36:13 salix postfix/smtp[6629]: connect to alt3.gmail-smtp-in.l.google.com[72.14.213.27]:25: Connection timed out
      May 27 14:36:34 salix postfix/smtp[6629]: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out
      May 27 14:36:34 salix postfix/smtp[6629]: 2474E14721F: to=<maderios@gmail.com>, relay=none, delay=6867, delays=6762/0.01/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)
      May 27 14:37:43 salix postfix/pickup[6569]: 6312460C9: uid=0 from=
      May 27 14:37:43 salix postfix/cleanup[6659]: 6312460C9: message-id=<20100527123743.6312460C9@salix>
      May 27 14:37:43 salix postfix/qmgr[6570]: 6312460C9: from=<mcmcpc@gmail.com>, size=277, nrcpt=1 (queue active)
      May 27 14:38:04 salix postfix/smtp[6629]: connect to gmail-smtp-in.l.google.com[209.85.227.27]:25: Connection timed out
      May 27 14:38:25 salix postfix/smtp[6629]: connect to alt1.gmail-smtp-in.l.google.com[74.125.39.27]:25: Connection timed out
      May 27 14:38:46 salix postfix/smtp[6629]: connect to alt2.gmail-smtp-in.l.google.com[72.14.221.27]:25: Connection timed out
      May 27 14:39:07 salix postfix/smtp[6629]: connect to alt3.gmail-smtp-in.l.google.com[72.14.213.27]:25: Connection timed out
      May 27 14:39:28 salix postfix/smtp[6629]: connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out
      May 27 14:39:28 salix postfix/smtp[6629]: 6312460C9: to=<maderios@gmail.com>, relay=none, delay=105, delays=0.02/0/105/0, dsn=4.4.1, status=deferred (connect to alt4.gmail-smtp-in.l.google.com[74.125.95.27]:25: Connection timed out)
      May 27 14:39:49 salix postfix/qmgr[6570]: EEC8AA1D4: from=<mcmcpc@gmail.com>, size=272, nrcpt=1 (queue active)
      May 27 14:40:10 salix postfix/smtp[6629]: connect to gmail-smtp-in.l.google.com[209.85.227.27]:25: Connection timed out
      May 27 14:40:31 salix postfix/smtp[6629]: connect to alt1.gmail-smtp-in.l.google.com[74.125.39.27]:25: Connection timed out
      May 27 14:40:52 salix postfix/smtp[6629]: connect to alt2.gmail-smtp-in.l.google.com[72.14.221.27]:25: Connection timed out
      May 27 14:41:13 salix postfix/smtp[6629]: connect to alt3.gmail-smtp-in.l.google.com[72.14.213.27]:25: Connection timed out

      "L'art est fait pour troubler. La science rassure" (Braque)

      • [^] # Re: orange et la lutte anti-spam! \o/

        Posté par . Évalué à 1.

        si j'ai les yeux ouverts, il y a bien un relayhost = [smtp.gmail.com]:587 dans le main.cf, mais c'est un paramètre général, bypassé par les autres options en paramètre, comme un sender_dependent_relayhost_maps.

        il ne faut pas oublier de préciser le port surtout avec ce dernier paramètre, sinon on revient sur les mêmes travers, à savoir l'utilisation du port 25.
        'me suis fait avoir aussi à la config de mes relayhosts!
        • [^] # Re: orange et la lutte anti-spam! \o/

          Posté par . Évalué à 1.

          'bypassé par les autres options en paramètre, comme un sender_dependent_relayhost_maps'

          Cette option n'était pas dans ma conf. Je l'ai ajoutée aujourd'hui, histoire de voir.
          sender_dependent_relayhost_maps = hash:/etc/postfix/sender_relay

          utilisateur@gmail.com smtp.gmail.com:587
          postmap sender_relay

          Pas de changement, je tombe toujours sur le port 25

          "L'art est fait pour troubler. La science rassure" (Braque)

  • # un tuto en passant

    Posté par . Évalué à 1.

    bonjour

    en fouinant un peu sur le web, je suis tombe la dessus: http://blog.admin-linux.org/messagerie/ajouter-le-smtp-de-gm(...)

    en espérant que ça puisse servir d'inspiration pour la config de postfix...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.