Forum Linux.debian/ubuntu [Abandonné] Empêcher MATE de gérer les touches de rétroéclairage du clavier

Posté par . Licence CC by-sa
0
3
avr.
2017

EDIT : Je suis passé à Xfce pour le moment, du coup ce topic ne m'intéresse plus. De plus je crois que le bug qui l'a inspiré a été corrigé dans MATE upstream, donc ce n'est qu'une question de temps avant que Debian Stable intègre la version corrigée (elle est dans Stretch, mais je n'ai pas testé).

Bonjour,

Il y a un bug dans MATE sous Debian Jessie qui m'empêche de changer le rétroéclairage du clavier avec les touches dédiées (fn+F3/F4). Du coup, j'ai écrit un petit programme pour changer le rétroéclairage, je lui ai mis suid et je veux pouvoir le lancer depuis les mêmes touches.

Le problème, c'est que MATE s'approprie ces touches et mon programme n'est jamais lancé. J'aimerais empêcher MATE de faire ça et récupérer l'usage de ces touches fn pour mes propres raccourcis clavier.

Quelqu'un sait-il comment je peux faire ça ? Merci d'avance.

  • # doute

    Posté par . Évalué à 2.

    tu as verifié que c'est bien FN+F3 qu'il faut faire, et pas juste F3 ?
    je sais que suivant les claviers on est par defaut en mode "multimedia", et quand tu fais "FN+touche" tu fais en fait juste F3

    le F3 et F4 etant probablement utilisé dans les raccourcis claviers de ton gestionnaire de fenetre, tu as alors l'impression qu'il intercepte avant ton programme, mais c'est surtout parce que ton programme attend la touche clavier- ou clavier+ et pas F3/F4

    • [^] # Re: doute

      Posté par . Évalué à 1. Dernière modification le 04/04/17 à 09:03.

      C'est bien fn+F*. C'est ça sous Windows, et quand je fais fn+F3 dans le gestionnaire de raccourcis clavier de MATE, il détecte "XF86KbdBrightnessUp". Si j'appuie sur F3, il détecte F3. D'ailleurs il n'y a pas de "mode multimédia" sur mon clavier, ces raccourcis ne s'utilisent qu'avec fn.

      J'ai pas bien compris ton deuxième paragraphe, mon programme n'attend rien du tout… C'est un petit binaire codé en C que je veux faire appeler par MATE quand j'appuie sur les touches fn+F3/F4.

      Le problème est que MATE intercepte ce raccourci, ce qui m'empêche de l'utiliser dans un raccourci clavier perso, et ça n'a pas l'air d'être configurable. Ça n'apparaît dans aucun raccourci, comme les touches de luminosité.

      • [^] # Re: doute

        Posté par . Évalué à 2.

        et quand je fais fn+F3 dans le gestionnaire de raccourcis clavier de MATE, il détecte "XF86KbdBrightnessUp".

        ok donc le fn+F3 fait bien ce qu'on attend.
        et dans MATE, tu n'as pas une option de raccourci clavier pour lui dire augmenter/baisser la luminosité ?

        • [^] # Re: doute

          Posté par . Évalué à 1.

          Le raccourci n'est pas listé dans les Raccourcis clavier de MATE. Il n'a pas l'air configurable graphiquement.

          • [^] # Re: doute

            Posté par . Évalué à 2.

            J'ai laissé tomber et je suis passé à Xfce que je préfère, merci pour ton aide.

            • [^] # Re: doute

              Posté par . Évalué à 2.

              Xfce rulez ! <3

              "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.