Forum Linux.debian/ubuntu affichage illisible [résolu]

Posté par .
2
3
mai
2012

bonjour,

J'ai un bug d'affichage sur un vieux portable Dell Inspiron 2650 (hier, il marchait lentement sous xp mais je veux le migrer sous un OS plus léger)…
J'ai essayé lubuntu mais l'installation ne marche pas en mode « par défaut », j'ai donc essayé #! crunchbang.
L'installation se passe bien mais dès l'écran de login ça bug, il faut taper un peu dans le vide…
Le bureau s'affiche (la barre en haut, l'heure, les icônes réseau + batterie) mais toutes les fenêtres sont vides, il faut les draguer hors écran pour faire apparaitre leur contenu mais ce n'est pas efficace à 100%… Dans le terminal (en mode fenêtre) il faut glisser la souris pour réussir à lire les résultats).

Que dois-je faire ?
Précision : le menu en clic droit est lisible… et TTY aussi
J'ai branché un 2nd écran = c'est copie conforme des bugs.
En 800 x 600, idem… j'ai un taux de rafraichissement assez bas dans grandr je lis 1024 x 768 - 47 mhz (je ne sais plus l'unité exacte).
La carte graphique est une geForce 2 (je n'ai pas vérifié).

  • # Ctrl+Alt+F1

    Posté par (page perso) . Évalué à 2.

    hello,

    et sous la couche graphique c'est pareil ?

    C'est quel driver graphique qui est activé, le proprio Nvidia ?

    Nasty thoughts are like buses - you don't get one for ages and then a whole army arrive at once.

  • # interface 3D avec une carte sans support 3D

    Posté par . Évalué à 5.

    ca ressemble à la cause que j'ai cité en titre.

    essaie avec l'interface alternative (2D)

  • # suite

    Posté par . Évalué à 3.

    bonjour,

    Je n'ai pas beaucoup de connaissances en résolution de problèmes sous debian/linux, je sais lire, je veux bien apprendre…
    Pour répondre aux messages précédents :
    - ctrl alt F1 (le tty selon ce que j'ai lu) fonctionne très bien
    - je ne sais pas quel est le pilote graphique proposé (comment savoir ?)
    - je ne pense pas que #!crunchBang utilise la 3D par défaut (c'est plus léger que Lubuntu) et je n'ai pas vu cette option…

    • [^] # Re: suite

      Posté par (page perso) . Évalué à 4.

      Pour le connaître pilote vidéo, glxinfo | grep -i vendor

      « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

  • # glxinfo

    Posté par . Évalué à 2.

    En passant la souris sur le texte 20 fois, je peux lire ça :
    screen1
    Et en rentrant la fenêtre doucement, j'arrive à voir ça :
    screen2
    server glx vendor string : SGI
    client glx vendor string : Mesa Project and SGI
    OpenGL vendor string : Mesa Project

    $ glxinfo
    name of display : 0.0

    les 2 images

    • [^] # Re: glxinfo

      Posté par (page perso) . Évalué à 5.

      ça m'étonnerais qu'il y a des drivers poussé pour du SGI. Si j'étais toi, j'irais dans le menu "Compositing" qu'on voit sur ta deuxième image et j'essayerais de le désactiver.

      « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

  • # compositing

    Posté par . Évalué à 2.

    Dans Settings>compositing
    il me propose enable Compositing with xcompmgr + edit et enable with cairo-compmgr…

    J'ai testé le 1er, c'était pire ! et le second en googlant, ça sonne 3D render…

    • [^] # Re: compositing

      Posté par (page perso) . Évalué à 4.

      que donne un lspci|grep vga (tu peux le faire dans un tty, ça te simpliefera la tâche).

      « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: compositing

      Posté par . Évalué à 3.

      compositing -> disable
      ca n'irait pas mieux ?

  • # run

    Posté par . Évalué à 2.

    • [^] # Re: run

      Posté par . Évalué à 3.

      pourquoi, ca ne marchait pas avec les trucs par defaut :

      une vieille carte nvidia devrait fonctionner avec le pilote nv fournit avec xorg.
      sinon tu as le paquet nvidia-legacy
      ou plus recent nvidia-glx

      par contre comme le logiciel n'est pas libre, il faut ajouter le depot debian : non-free
      pour avoir acces à ces paquets.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.