Forum Linux.debian/ubuntu apt-install ?

Posté par (page perso) .
Tags : aucun
2
29
sept.
2010
Salut les gens...

Je n'arrive pas à installer la Squeeze à partir du weekly build sur mon nouveau laptop à cause d'un put... de bug qui empêche l'installe, et j'ai finalement posé la bonne vielle Lenny...Je peux bien évidemment mettre a jour le source.list, dist-upgrade et roulez jeunesse, mais ça ne fera pas avancer le projet debian einh !

J'ai isolé le bug dans le grub-installer 1.55, payé mon report de bug 598130 auquel il n'y a pour l'instant pas de réponse, et je coince pour aller encore plus loin sur le apt-install que je ne connais pas ! Rien dans man, pas grand chose sur le net (et beaucoup de apt-get install qui n'est pas ce que je cherche ) j'ai fais du grep sur le code de apt nada, fouillé dans anna rien.... Bref...

Qui peux me rencarder sur apt-install ?
  • # apt-install ?

    Posté par . Évalué à 2.

    t'es sûr?
    apparemment pas dans mes dépôts Squeeze
    • [^] # Re: apt-install ?

      Posté par (page perso) . Évalué à 3.

      Oui je suis certain : ligne 411 du script shell grub-installer ( et c'est pas la seule ligne ou il est ) !
      - C'est pas un package
      - C'est pas un binaire
      - C'est pas dans le fichier de fonctions du grub-installer !

      Mais c'est bien quelque part....A ce stade je penche pour une fonction dans le debian installer ou un truc du genre... J'ai déjà cherché dans anna... je fouille un peu partout sans succès...
      D'où mon appel à info si il y a un dev debian ou quelqu'un qui maîtrise l'installeur debian qui passe... :o)

      En attendant vais continuer de fouiller... :-P

      Fuse : j'en Use et Abuse !

      • [^] # Re: apt-install ?

        Posté par (page perso) . Évalué à 4.

        • [^] # Re: apt-install ?

          Posté par (page perso) . Évalué à 2.

          Yes yes yes ! Je plussois !
          J'ai trouvé en même temps ( cf mon post une minutes après ) en creusant dans les dépendances de grub....

          Merci pour ton aide / temps !

          Fuse : j'en Use et Abuse !

          • [^] # Re: apt-install ?

            Posté par (page perso) . Évalué à 1.

            A mon avis, la ligne important de l'erreur concerne le fait que le paquet grub-pc est introuvable sur le cd-rom. Il faudrait voir pourquoi.
            • [^] # Re: apt-install ?

              Posté par (page perso) . Évalué à 2.

              Nop il est sur le cdrom déjà vérifié... ( cf bug report original : 598062 )

              J'ai aussi failli me faire avoir par le fait qu'il est pas dans les packages installés pour le système de base dans /target, mais c'est le même comportement en Lenny, et le apt-install pousse grub legacy et grub sur /target en recupérant ce qui manque dans le cdrom ... ( bon je t'accorde que c'est pas idéal de pas le pousser avec les paquets de base )
              On peux grossomodo dire apt-install <=> apt-get install

              Le problème est vraiment que la lecture des info d'etat dans /target au moment où on invoque apt-utils foire.... et c'est la que j'ai besoin des source de apt-utils...

              Fuse : j'en Use et Abuse !

      • [^] # Re: apt-install ?

        Posté par . Évalué à 2.

        Salut,

        Et bien avec tes questions tu m'as obligé à chercher !!!

        apt-install est un shellscript qui n'est disponible que sur le système de fichiers monté en RAM au moment de l'installation : il n'existe dans aucun des paquets installables une fois que l'installation est finie.

        Mais bon, on peut tout de même le retrouver dans les debian-installer-utils (http://ftp.debian.org/debian/pool/main/d/debian-installer-ut(...) ), en particulier dans le paquet source debian-installer-utils_1.79.tar.gz et dans les paquets di-utils_1.79_archi.udeb

        A toi de chercher pour le reste,
        JJD
        • [^] # Re: apt-install ?

          Posté par . Évalué à 1.

          Trop lent !

          j'avais pourtant rafraichi la page avant de rédiger :-(
          • [^] # Re: apt-install ?

            Posté par (page perso) . Évalué à 2.

            Oui tu as un peu de retard on a matché le di-utils en dépendance...

            Mais merci pour ton temps / ta recherche !
            M'en vais continuer de dépouiller tout ça, j'ai un point de blocage de levé...

            Fuse : j'en Use et Abuse !

    • [^] # Re: apt-install ?

      Posté par (page perso) . Évalué à 2.

      Bien tenté quand même ! :o)

      En même temps je viens de penser que c'est pas spécifique à l'installeur debian, car en cas de passage du grub + grub-legacy à grub-pc ( alias grub2 ) c'est aussi appelé... donc ca doit être connu dans un environnement style aptitude / apt / dpkg...

      Fuse : j'en Use et Abuse !

  • # 1/ quel bug t'empêche d'installer squeeze ? 2/ quelle version de grub ?

    Posté par . Évalué à 3.

    1/ Si un problème t'empêche de dérouler l'installation de Squeeze, merci de suivre http://d-i.alioth.debian.org/manual/fr.i386/ch05s04.html#sub(...) (sauf si tu sais que le bug auquel tu es confronté existe déjà)

    2/ Par rapport au bug de grub sous Lenny (est-bien ça ?)
    http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598130

    Sans version soft ni infos précises de configuration, cela risque d'être difficile d'avoir une réponse. Il est recommandé d'utiliser reportbug depuis le système installé, comme cela la bonne version soft et remontée, ainsi que les infos utiles au devs.
    • [^] # Re: 1/ quel bug t'empêche d'installer squeeze ? 2/ quelle version de gr

      Posté par (page perso) . Évalué à 3.

      Oui monsieur c'est bien le bug 598130 !

      Comme indiqué au début du rapport ( 1 ère ligne ) il découle d'un autre rapport de bug : 598062 initialement sur le paquet cdrom car c'est l'install du cdrom qui foirait et je ne savait pas encore d'où cela venait exactement...
      - Mis en forme au début avec reportbug sous lenny, en expliquant que c'est l'install squeeze qui foirait mais comme j'avais pas envie de configurer exim qui a refusé l'envoi : forward blabla, filtrage provider blabla... j'ai recopié le mail dans gmail...
      - Avec un lshw attaché en mail
      - Avec les log d'install attaché dans le deuxième mail du dimanche...
      Et on peux suivre tout le déroulement de mon investigation de dimanche qui a résulté à incriminer grub-installer 1.55 à la ligne de code 411.... D'où le fait qu'à la fin j'ai envoyé un mail sur 598062 en disant : j'ai ouvert un bug grub-installer, vous pouvez linker..

      Tout ce que tu mentionnes a été fournis initialement ! S'il le veulent de nouveau suffit de demander.... Autre chose ? :o)

      Perso j'ai tendance à penser plutôt qu'ils se disent :
      "Oula, lui il est motivé à tout dépouiller comme ça ( ce qui est vrai ) , on va le laisser s'énerver et creuser car on dirait que ça lui plaît ( pas faux non plus ), avec un peu de chance il va faire un patch ( j'espère bien mon neveux ! ) et nous on se concentre sur les autres bugs car il y a déjà quelqu'un qui bosse sur celui là..."

      Fuse : j'en Use et Abuse !

      • [^] # Re: 1/ quel bug t'empêche d'installer squeeze ? 2/ quelle version de gr

        Posté par . Évalué à 2.

        Pour info, les explications sur le système de bugs est dispo à http://www.debian.org/Bugs/server-control

        Si un bug s'avère finalement venir d'un autre paquet que le rapport de bug initial, alors tu peux réassigner le bug à autre paquet:
        http://www.debian.org/Bugs/server-control#reassign

        Et sinon J'insiste, les deux rapports de bugs ont créés sans référence de version (pourtant reportbug doit l'indiquer).
        Si c'est la 1.55, alors : http://www.debian.org/Bugs/server-control#found

        Tout ce que tu mentionnes a été fournis initialement ! S'il le veulent de nouveau suffit de demander.... Autre chose ? :o)

        Ce n'est pas comme cela que ça marche, si tu veux augmenter les chances de voir ton bug traité, il est recommandé qu'il doit documenté en terme de version au moins (et au niveau BTS, pas caché dans le corps d'un des mails).

        Perso j'ai tendance à penser plutôt qu'ils se disent : ....on va le laisser s'énerver et creuser car on dirait que ça lui plaît

        Alors là tu fais des idées ... ton bug n'a que 3 jours.

        PS: il n'est pas nécessaire d'envoyer de mails en HTML au BTS
        • [^] # Re: 1/ quel bug t'empêche d'installer squeeze ? 2/ quelle version de gr

          Posté par (page perso) . Évalué à 2.

          Ok pour le reassign... J'ai plus pour habitude de faire du link de bug, et la fermeture du bug finale cascade la fermeture des autres mais si ils fonctionnent pas comme ca soit...

          Pour la version :
          - reportbug étant lancé d'une lenny il mettrait la version lenny ( 1.36) qui n'est pas celle posant problème.... non ?

          - je ne met pas la version du package de squeeze... peux il y avoir plusieurs version d'un même paquet sur un weekly build ? non... Vu la date du report de bug on connait la version !

          - Considérons le cas des itérations rapides qui pourrait prêter à confusion, grub-installer est en version 1.55 depuis fin août..... En septembre sur squeeze ça ne peux être que du 1.55 ! Mais bon il est vrai qu'il faut regarder la date du bug pour le savoir...

          Soit, tu as réussis à me convaincre de faire du ménage et jouer avec le serveur de contrôle !

          Fuse : j'en Use et Abuse !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.