Forum Linux.debian/ubuntu apt pinning sur plusieurs dépôts "stable"

Posté par .
Tags : aucun
1
28
nov.
2011

Salut

Sous squeeze, avec ses dépôts par défaut activés évidemment, je souhaite utiliser le dépot packages.dotdeb.org. Celui ci fournit php5 mais sans une extension dont j'ai besoin. J'ai donc reconstruit le paquet en activant la compilation de cette extension et j'ai déposé les .deb générés sur un dépôt perso.

Nous voici donc avec 3 dépôts, le dépot officiel, le dépot dotdeb et mon dépôt.

root@squeeze:~# aptitude versions php5
p   5.3.3-7+squeeze3           stable    990
p   5.3.8-1~dotdeb.2~custom.2  stable    990
p   5.3.8-1~dotdeb.2           stable    990

Et on trouve bien 3 versions du paquet php5. Le hic c'est que je n'arrive pas à configurer APT (via le fichier /etc/apt/preferences) pour que les paquets du dépôt local soient prioritaires par rapport au dépôt dotdeb, qui lui même est prioritaire par rapport au dépôt officiel.

Je ne suis pas sur que cela soit possible d'ailleurs, mais j'ai essayé pas mal de combinaisons, et sans résultat. Mon objectif étant que l'aptitude install php5 aille piocher dans mon dépôt local, aptitude install nginx dans le dépôt dotdeb, et les autres paquets dans le dépôt officiel.

Merci de votre aide.

  • # numerotation

    Posté par . Évalué à 1.

    numerote ton paquet 5.3.8.2
    il sera considere comme plus recent et sera donc installé

    au pire tu pourras forcer la version souhaitée par une option à apt
    pour les depedances je ne sais pas par contre

    chez moi je remplacerais le depot squeeze par le depot perso ou le depot dotdeb
    je ferais l'installation
    puis je remettrais le depot squeeze

  • # Soit versions, soit pinning

    Posté par (page perso) . Évalué à 3.

    Deux solutions :
    - soit tu t'arranges pour que ta version soit la plus récentes i.e. 5.3.8-1~dotdeb.2+custom.2 (la ~ veut dire "juste avant la version décrite dans ce qui la précède")
    - soit tu fais le bon pinning, par exemple un truc du genre de ce qui suit dans /etc/apt/preferences :

    Package: php5
    Pin: version 5.3.8-1~dotdeb.2~custom.2
    Pin-Priority: 991
    
    

    Voir aussi :
    - http://wiki.debian.org/AptPreferences
    - man apt_preferences

  • # le mot de la fin

    Posté par . Évalué à 3.

    Bien que je n'aie ajouté que des dépôts pour la version stable (squeeze), c'est la ligne APT::Default-Release "squeeze"; dans l'apt.conf qui empéchait les priorités d'être considérées...
    Par contre je ne me rappelle plus pourquoi j'avais voulu expliciter cette ligne de conf ha ha :D

    Merci pour vos réponses.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.