Forum Linux.debian/ubuntu Bind en local et servfail

Posté par (page perso) .
Tags : aucun
0
1
oct.
2007
Bonjour,

je me suis monté un petit serveur pour palier à un problème de mon routeur. Serveur sur lequel j'ai installé serveur web, sql, dns, fichiers... Tout marche bien, sauf bind.

J'ai ma zone locale qui fonctionne très bien, par contre, impossible de résoudre un nom extérieur.

# host linuxfr.org
Host linuxfr.org not found: 2(SERVFAIL)

# host 213.186.58.114
Host 114.58.186.213.in-addr.arpa not found: 2(SERVFAIL)

# host routeur.home
routeur.home has address 192.168.1.1

Si quelqu'un a une idée, je suis preneur.

Merci d'avance.
  • # dig

    Posté par . Évalué à 1.

    Que donne la commande:

    dig +trace linuxfr.org

    Soit tes fichiers de conf n'ont pas les bons serveurs bind renseignés (soit les root soit celui de ton FAI)
    Soit problème firewall.
  • # transfert ?

    Posté par . Évalué à 1.

    il faut preciser à bind ou chercher pour les noms qu'il ne connait pas.

    il me semble que c'est dans le "transfert de zone" ou "relay"
  • # Extérieur

    Posté par (page perso) . Évalué à 2.

    Ton serveur bind ne sait pas ou ne peut pas résoudre.

    Soit en mode autonome
    1- lui donner accès au monde entier sur le port 53 udp
    2- lui dire d'etre récursif "recursion yes;" dans les options

    Ou lié à ton fai
    1- lui donner accès au serveur dns du fai sur le port 53
    2- lui dire de demander au fai si besoin : "forwarders { 1.2.3.4; };" dans les options
  • # Comment je fais...

    Posté par . Évalué à 1.

    Dans les options pricipales de bind j'ai :

    options {
        directory "/etc/bind";
        
        [...]
        
        forward first;
        
        forwarders {
            80.10.246.2;
            80.10.246.129;
            80.10.246.3;
            80.10.246.130;
        };
    };


    Et dans les zones de mon LAN je fais :

    [...]

    zone "wifi.omk" {
        type master;
        file "db.wifi.omk";
        allow-update { 127.0.0.1; };
        allow-transfer { none; };
        forwarders { };
    };

    zone "2.168.192.in-addr.arpa" {
        type master;
        file "db.2.168.192";
        allow-update { 127.0.0.1; };
        allow-transfer { none; };
        forwarders { };
    };


    Ce qui evite de forwarder pour les requêtes DNS concernant mes réseaux privés.
  • # dig +trace

    Posté par (page perso) . Évalué à 1.

    Bonsoir,

    voilà le contenu du dig +trace :

    $ dig +trace linuxfr.org

    ; <<>> DiG 9.3.4 <<>> +trace linuxfr.org
    ;; global options: printcmd
    . 518400 IN NS I.ROOT-SERVERS.NET.
    . 518400 IN NS J.ROOT-SERVERS.NET.
    . 518400 IN NS K.ROOT-SERVERS.NET.
    . 518400 IN NS L.ROOT-SERVERS.NET.
    . 518400 IN NS M.ROOT-SERVERS.NET.
    . 518400 IN NS A.ROOT-SERVERS.NET.
    . 518400 IN NS B.ROOT-SERVERS.NET.
    . 518400 IN NS C.ROOT-SERVERS.NET.
    . 518400 IN NS D.ROOT-SERVERS.NET.
    . 518400 IN NS E.ROOT-SERVERS.NET.
    . 518400 IN NS F.ROOT-SERVERS.NET.
    . 518400 IN NS G.ROOT-SERVERS.NET.
    . 518400 IN NS H.ROOT-SERVERS.NET.
    ;; Received 228 bytes from 192.168.1.254#53(192.168.1.254) in 2 ms

    dig: couldn't get address for 'I.ROOT-SERVERS.NET': failure


    Dans ma configuration, ce que je veux, c'est que quand il ne connait pas une adresse, il aille demander aux serveurs roots, et non à mon FAI. J'ai bien le "recursion yes;" dans mes options.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.