Forum Linux.debian/ubuntu Comment forcer la resolution de l'écran au démarage avec Xrandr

Posté par .
Tags : aucun
0
16
nov.
2008

Bonsoir,
Je viens d'installer une debian testing sur ma machine d'expérimentation mais j'ai (évidemment) un problème avec l'affichage de l'interface graphique et xrandr qui détecte mal mon matériel, Je m'explique : lorsque Gdm se lance mon ecran m'indique "out of range", je tapotte quelques Ctrl+Alt++ afin d'obtenir une résolution acceptable, seulement mon bureau est plus large que mon écran : ça m'agace et je cherche à résoudre ce problème. lorsque je lance la commande xrandr --query voilà ce que j'obtient :

pc-de-philippe:/home/philippe# xrandr --query
Screen 0: minimum 320 x 200, current 1600 x 1200, maximum 1600 x 1200
default connected
1600x1200 0.0
1400x1050 0.0
1280x1024 0.0
1024x768 0.0
800x600 61.0
640x480 60.0
640x400 0.0
320x400 0.0
320x240 0.0
320x200 0.0

je précise que mon écran est un AOC 17" CRT et qu'il ne gère pas la résolution 1600x1200, ceci dit, lorsque je me trouve dans une résolution qui je l'estime à vu d'oeil est 1024x768 grace à mes Ctrl+Alt++, alors je tape cette commande :

pc-de-philippe:/home/philippe# xrandr --output default --mode 1024x768

et là par magie tout est impec, c'est la résolution que je veux et je n'ai plus le bureau plus grand que l'affichage.

Mon problème c'est que je suis obligé de faire ces manipulation à chaque que je redémarre le serveur X, j'aimerais pouvoir automatiser tout cela mais je ne sait pas dans quel fichier. peut-être xorg.conf ? mais je suis dérouté par le contenu de celui-ci qui a serieusement rétreci au lavage depuis l'implémentation de Randr dans X :

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"


EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection


Voilà, si une âme charitable voulait bien m'aider à résoudre mon problème je lui en serait reconnaissant.

Gorfou.
  • # (suite)

    Posté par . Évalué à 1.

    Je me suis aperçu que je n'avais pas indiqué le modèle de ma carte graphique dans le post précédent :
    pc-de-philippe:/home/philippe# lspci
    00:00.0 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:01.0 ISA bridge: nVidia Corporation MCP67 ISA Bridge (rev a2)
    00:01.1 SMBus: nVidia Corporation MCP67 SMBus (rev a2)
    00:01.2 RAM memory: nVidia Corporation MCP67 Memory Controller (rev a2)
    00:02.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:02.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:04.0 USB Controller: nVidia Corporation MCP67 OHCI USB 1.1 Controller (rev a2)
    00:04.1 USB Controller: nVidia Corporation MCP67 EHCI USB 2.0 Controller (rev a2)
    00:06.0 IDE interface: nVidia Corporation MCP67 IDE Controller (rev a1)
    00:07.0 Audio device: nVidia Corporation MCP67 High Definition Audio (rev a1)
    00:08.0 PCI bridge: nVidia Corporation MCP67 PCI Bridge (rev a2)
    00:09.0 IDE interface: nVidia Corporation MCP67 AHCI Controller (rev a2)
    00:0a.0 Ethernet controller: nVidia Corporation MCP67 Ethernet (rev a2)
    00:12.0 VGA compatible controller: nVidia Corporation GeForce 7025 (rev a2)
    00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
    00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
    00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
    00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
    
    Voilà qui est rectifié.
    • [^] # Re: (suite)

      Posté par . Évalué à 1.

      C'est toujours moi, décidement je vais faire l'apologie du answer yourself...
      J'ai réussi à conturner le problème en installant nvidia-settings et nvidia-xconfig, mais j'aimerais que quelqu'un m'explique le pourquoi du comment. merci d'avance.

      Gorfou
      • [^] # Re: (suite)

        Posté par . Évalué à 2.

        je dirais que comme il n'y pas de mode dans le fichier xorg.conf

        le driver interroge l'ecran qui lui pretend pouvoir faire 1600x1200.
        et ton gdm s'affiche sur cette resolution.

        avec ctrl alt - tu reduis la resolution, et là ca s'affiche.

        enfin avec nvidia-* tu as du mettre la taille souhaitée dans le fichier xorg.conf.
        ou changer de driver (nv -> nvidia)
        • [^] # Re: (suite)

          Posté par . Évalué à 1.

          Je crois que c'est bien ce qu'il s'est passé, la preuve en est : mon nouveau fichier xorg.conf :
          # nvidia-xconfig: X configuration file generated by nvidia-xconfig
          # nvidia-xconfig:  version 1.0  (buildd@ninsei)  Fri Sep  5 22:23:08 UTC 2008
          
          Section "ServerLayout"
              Identifier     "Layout0"
              Screen      0  "Screen0"
              InputDevice    "Keyboard0" "CoreKeyboard"
              InputDevice    "Mouse0" "CorePointer"
          EndSection
          
          Section "Files"
              RgbPath         "/usr/X11R6/lib/X11/rgb"
          EndSection
          
          Section "Module"
              Load           "dbe"
              Load           "extmod"
              Load           "type1"
              Load           "freetype"
              Load           "glx"
          EndSection
          
          Section "InputDevice"
              # generated from default
              Identifier     "Mouse0"
              Driver         "mouse"
              Option         "Protocol" "auto"
              Option         "Device" "/dev/psaux"
              Option         "Emulate3Buttons" "no"
              Option         "ZAxisMapping" "4 5"
          EndSection
          
          Section "InputDevice"
              # generated from default
              Identifier     "Keyboard0"
              Driver         "kbd"
              Option	   "XkbRules"	"xorg"
              Option	   "XkbModel"	"pc105"
              Option	   "XkbLayout"	"fr"
              Option	   "XkbVariant"	"latin9"
          EndSection
          
          Section "Monitor"
              Identifier     "Monitor0"
              VendorName     "Unknown"
              ModelName      "Unknown"
              HorizSync       30.0 - 110.0
              VertRefresh     50.0 - 150.0
              Option         "DPMS"
          EndSection
          
          Section "Device"
              Identifier     "Device0"
              Driver         "nvidia"
              VendorName     "NVIDIA Corporation"
          EndSection
          
          Section "Screen"
              Identifier     "Screen0"
              Device         "Device0"
              Monitor        "Monitor0"
              DefaultDepth    24
              SubSection     "Display"
                  Depth       24
              EndSubSection
          EndSection
          
          Merci et à bientôt pour de nouvelles aventures ! Gorfou

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.