Forum Linux.debian/ubuntu Installation Automatique via FAI

Posté par .
Tags : aucun
1
27
août
2010

Bonjour à tous,

Je souhaite mettre en place un serveur FAI ( http://www.informatik.uni-koeln.de/fai/ ) pour automatiser l'installation des mes nouveaux serveurs (kernel, partitionnement, utilisateurs, packages...).
Je pense avoir compris le fonctionnement général du logiciel, mais je bloque sur un point lors de l'installation. En gros, j'arrive à installer un système via FAI. Mes paramètres réseau, tftp... sont donc bons.
Par contre, une des puissance de FAI est de pouvoir créer des profils personnalisés en fonction du type de la machine. Voici le fichier d'exemple qui spécifie quelle(s) classe(s) utiliser en fonction du nom de la machine hôte:
#! /bin/bash

# assign classes hosts

# use a list of classes for our demo machine
case $HOSTNAME in
£spaces£    £/spaces£faiserver)
£spaces£        £/spaces£echo "FAIBASE DEMO FAISERVER" ;;
£spaces£    £/spaces£demohost)
£spaces£        £/spaces£echo "FAIBASE DHCPC DEMO" ;;
£spaces£    £/spaces£gnomehost)
£spaces£        £/spaces£echo "DHCPC DEMO XORG GNOME";;
£spaces£    £/spaces£atom*)
£spaces£        £/spaces£echo "FAIBASE DHCPC DEMO" ;;
£spaces£    £/spaces£*)
£spaces£        £/spaces£echo "FAIBASE DEMO" ;;
esac

(ifclass I386 || ifclass AMD64) && echo GRUB
exit 0

Pour tester l'installation de FAI, j'ai choisis de nommer mon client demohost et ainsi faire une installation de base par défaut. Cela me permet de valider le fonctionnement et donc de pouvoir créer les profils adaptés à mes besoins par la suite.

Seulement, je n'arrive pas à trouver où spécifier le hostname de l'hôte. Voici les fichiers que j'ai modifié:

/etc/dhcp3/dhcpd.conf
subnet 192.168.201.0 netmask 255.255.255.0 {
£spaces£ £/spaces£range 192.168.201.10 192.168.201.50;
£spaces£ £/spaces£option routers 192.168.201.1;
£spaces£ £/spaces£filename "pxelinux.0";
}
host demohost {
£spaces£ £/spaces£hardware ethernet 00:0C:29:2D:5C:90;
£spaces£ £/spaces£fixed-address 192.168.201.40;
}

/etc/hosts
127.0.0.1 localhost
192.168.201.20 clean-install-64
192.168.201.40 demohost

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

J'ai aussi modifier le fichier /etc/hostname du répertoire TFTP qui est monté lors du boot PXE.

Autre précision, à la fin de l'installation, avant de redémarrer le nouveau système, le fichier /etc/hostname contient bien "demohost".
Lorsque je reboot sur le nouveau système, il contient uniquement "host".
Avez une idée de l'endroit où il faut spécifier le hostname du client? Je n'ai personnellement pas réussis à trouver en lisant les quelques docs disponibles...

Cdt,
Anthony

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.