Forum Linux.debian/ubuntu Ma clé USB se remonte intempestivement

Posté par . Licence CC by-sa
Tags : aucun
1
28
déc.
2015

Hello,

J'ai une clé USB Kingston DataTraveler 3.0 (64 Go) qui, quand je demande à Debian de l'éjecter, est remontée immédiatement comme si je venais de l'insérer. Quelque soit le système de fichiers.

Donc, chronologiquement :
- j'insère la clé
- Debian monte la clé
- je clique sur "éjecter"
- Debian démonte la clé
- Debian remonte immédiatement la clé

…ce qui me paraît très bizarre et me gêne, puisque je ne peux jamais être sûr que mes données resteront intactes en retirant ma clé toujours montée de mon PC.

Je cherche à savoir si le problème vient de Kingston, de mon exemplaire défectueux ou de mon système. Sous Windows, tout fonctionne parfaitement.

Et accessoirement, comment que je résous ça ?

Merci.

Edit : après essai sur un live USB Ubuntu, le problème ne semble exister que sur ma Debian. Du coup, je me demande si ça pourrait être dû à Gnome Shell.

  • # continue tes essais

    Posté par . Évalué à 2.

    Edit : après essai sur un live USB Ubuntu, le problème ne semble exister que sur ma Debian. Du coup, je me demande si ça pourrait être dû à Gnome Shell.

    facile, installe un autre gestionnaire de bureau (gnome-fallback, mate, cinnamon, xfce…) et regarde si ca le fait toujours)
    tu peux aussi essayer sur le livecd ubuntu en mettant gnome-shell

    • [^] # Re: continue tes essais

      Posté par . Évalué à 1.

      J'ai le même problème en l'éjectant depuis Thunar, dans XFCE sur le même système.

      Je devrais peut-être signaler un bug à Debian ?

  • # usb

    Posté par . Évalué à 2.

    bonjour tu as ete voir du coté de udev ???

    • [^] # Re: usb

      Posté par . Évalué à 1.

      J'aimerais bien :P Je sais que ça a vaguement un truc à voir avec les périphériques branchés au PC, mais je ne vois pas comment chercher de ce côté sans savoir un peu plus comment ça marche. Je vais voir.

      • [^] # Re: usb

        Posté par . Évalué à 3.

        faut deja commencer par les logs.

        ex : tail /var/log/messages
        ou dmesg

        avant le branchement de la clef

        puis, tu branches la clef,
        tu refais les commandes.

        eventuellement tu fais un tail -f /var/log/messages | grep udev pour suivre ce qu'il se passe dans udev

        tu ejectes la clef…

        • [^] # Re: usb

          Posté par . Évalué à 1.

          Voici le log :

          je branche la clé

          [  198.356298] usb 2-2: new SuperSpeed USB device number 2 using xhci_hcd
          [  198.473935] usb 2-2: New USB device found, idVendor=0951, idProduct=1666
          [  198.473942] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
          [  198.473946] usb 2-2: Product: DataTraveler 3.0
          [  198.473949] usb 2-2: Manufacturer: Kingston
          [  198.473953] usb 2-2: SerialNumber: [...]
          [  198.550991] usb-storage 2-2:1.0: USB Mass Storage device detected
          [  198.551085] scsi4 : usb-storage 2-2:1.0
          [  198.551719] usbcore: registered new interface driver usb-storage
          [  199.617391] scsi 4:0:0:0: Direct-Access     Kingston DataTraveler 3.0 PMAP PQ: 0 ANSI: 6
          [  199.617651] sd 4:0:0:0: Attached scsi generic sg1 type 0
          [  201.124407] sd 4:0:0:0: [sdb] 122915328 512-byte logical blocks: (62.9 GB/58.6 GiB)
          [  201.124966] sd 4:0:0:0: [sdb] Write Protect is off
          [  201.124970] sd 4:0:0:0: [sdb] Mode Sense: 23 00 00 00
          [  201.125520] sd 4:0:0:0: [sdb] No Caching mode page found
          [  201.125523] sd 4:0:0:0: [sdb] Assuming drive cache: write through
          [  201.155560]  sdb: unknown partition table
          [  201.157477] sd 4:0:0:0: [sdb] Attached SCSI removable disk
          

          je demande à GNOME d'éjecter la clé

          [  222.427518]  sdb: unknown partition table
          [  222.434129] usb 2-2: USB disconnect, device number 2
          [  222.735971] usb 2-2: new SuperSpeed USB device number 3 using xhci_hcd
          [  222.761155] usb 2-2: New USB device found, idVendor=0951, idProduct=1666
          [  222.761160] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
          [  222.761162] usb 2-2: Product: DataTraveler 3.0
          [  222.761163] usb 2-2: Manufacturer: Kingston
          [  222.761165] usb 2-2: SerialNumber: [...]
          [  222.763190] usb-storage 2-2:1.0: USB Mass Storage device detected
          [  222.763311] scsi5 : usb-storage 2-2:1.0
          [  223.763536] scsi 5:0:0:0: Direct-Access     Kingston DataTraveler 3.0 PMAP PQ: 0 ANSI: 6
          [  223.763894] sd 5:0:0:0: Attached scsi generic sg1 type 0
          [  223.765615] sd 5:0:0:0: [sdb] 122915328 512-byte logical blocks: (62.9 GB/58.6 GiB)
          [  223.765726] sd 5:0:0:0: [sdb] Write Protect is off
          [  223.765729] sd 5:0:0:0: [sdb] Mode Sense: 23 00 00 00
          [  223.766182] sd 5:0:0:0: [sdb] No Caching mode page found
          [  223.766184] sd 5:0:0:0: [sdb] Assuming drive cache: write through
          [  223.772223]  sdb: unknown partition table
          [  223.774872] sd 5:0:0:0: [sdb] Attached SCSI removable disk
          

          Je comprends que le système redécouvre qu'une clé est branchée sans prendre en compte le fait qu'il vient de l'éjecter.

          • [^] # Re: usb

            Posté par . Évalué à 3.

            tu as quand meme un truc bizarre avec ta clé :

            [ 201.155560] sdb: unknown partition table

            du coup, il ne doit pas vraiment monter une partition mais le disque en lui meme,
            et l'ejection ne se passe pas correctement.

            sort les données qui sont dedans,
            creer une partition (sdb1) de la taille totale du disque,
            formate cette partition

            refait des inserts, attente, ejection

            • [^] # Re: usb

              Posté par . Évalué à 1.

              En fait, je n'y pensais pas, mais ma clé a une table de partitions GPT. C'est peut-être ça que Debian n'aime pas, je vais essayer de la passer en MBR.

              Va falloir que je refasse ma sauvegarde :/

              • [^] # Re: usb

                Posté par . Évalué à 1.

                Bon, c'était pas ça. J'ai créé une nouvelle partition NTFS sur MBR et le "unknown partition table" a disparu, mais la clé se remonte toute seule quand même.

  • # Balai

    Posté par . Évalué à 1.

    Votre titreHello, je dépoussière un peu ce fil parce que le bug n'a pas disparu, et ne sachant pas quoi faire pour m'en occuper moi-même, j'aimerais le signaler à quelqu’un qui pourra le corriger pour tout le monde.

    Comme je n'ai jamais signalé de bug à Debian, j'aimerais des conseils, et en particulier savoir pour quel paquet je devrais signaler ce bug. Pour l'instant, je n'ai aucune idée du programme responsable.

    Quelqu'un pourrait-il m'aider ? Comme ça, si vous achetez un jour une clé du même modèle, vous pourrez me remercier en voyant qu'elle se démonte sans problème. :P

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.