Forum Linux.debian/ubuntu problème au démarrage après une mise à jour

Posté par .
0
30
oct.
2012

Bonjour à tous;
Ma fille possède un acer aspire 7720Z sous ubuntu. Après mise à jour (passage de 11.10 à 12.04 ) problème.
L'écran de boot (plymouth ) s'affiche mais on a le message suivant :
Le disque support de / semble absent
Puis on retombe sur une console de secours.
En faisant un fdisk - l j'obtiens ceci :
ecran de la console

Je précise que j'essaie vainement de booter sur une clé usb ( j'ai systematiquement droit à un boot error ).

Merci de vos avis et conseils !

  • # fstab

    Posté par . Évalué à 1.

    ça ressemble à une option root= erronée donnée au noyau Linux.
    Quelle est la ligne de commande Linux ? Elle normalement affichée au démarrage (mais il faut lire très vite, je le crains).

    Exemple :
    Kernel command line: root=/dev/mmcblk0p1

    Ou alors il faudrait voir fstab de ta clé USB. Dans ta console :

    # mkdir /mnt/usb
    # mount -f vfat /dev/mmcblk0p1 /mnt/usb
    # cat /mnt/usb/etc/fstab

  • # Il n'y aurait pas une carte SD inseree ?

    Posté par . Évalué à 2.

    Le /dev/mmcblk0 m'y fait serieusement penser (D'autant plus qu'une cle usb apparaitrait en /dev/sdX)

    • [^] # Re: Il n'y aurait pas une carte SD inseree ?

      Posté par . Évalué à 2.

      effectivement. Il y avait une carte sd.
      Maintenant, cela peut il empêcher l'ordi de démarrer sur le disque dur ?
      En tous cas, merci de ton attention !

      • [^] # Re: Il n'y aurait pas une carte SD inseree ?

        Posté par . Évalué à 3.

        Je dois avouer que je suis loin d'en être sur, mais sachant que les partitions systèmes du n900 et de tablettes android (au moins la mienne) sont via /dev/mmcblk … Ça me paraissait être une piste.

        Je me suis encore récemment fait avoir par une carte sd dans le port USB de mon écran (via un tout petit dongle, le truc qui se remarque à peine, d'autant plus quand c'est branché sur le coté de l'écran). Il y avait une partition marquée bootable dans la MBR. Le pc ne bootait pas le noyau comme dans ton cas, mais j'ai quand même flippé que mon SSD ait rendu l'âme.

        • [^] # Re: Il n'y aurait pas une carte SD inseree ?

          Posté par . Évalué à 2.

          Merci mais malheureusement je flippe toujours car même en retirant la carte : a boute pô !

          • [^] # Re: Il n'y aurait pas une carte SD inseree ?

            Posté par . Évalué à 2.

            Dans ce cas, je suggere mise une jour du systeme avec passage de boot via UUID en lieu et place des hd(x,y) qui s'est mal passe. Tu trouveras de la doc sur le net. Ca resterait surprenant, parce que ca fais un bout de temps que ubuntu est passe au UUID…

            as tu essaye de faire un fsck, puis mount -o remount,rw / ? si ca se passe bien, passer au bon level d'init pour demarrer x, lancer un apt-get update && apt-get dist-upgrade (au cas ou des paquets soient mals installes)

            Desole, j'ai la flemme de corriger les problemes d'accents… Impardonnable, incorrigible!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.