Forum Linux.debian/ubuntu Problème de sortie de veille en RAM.

Posté par . Licence CC by-sa
Tags : aucun
1
8
sept.
2014

Bonjour ! :)

Sous Debian Wheezy, suite à une mise à jour sur mon ordinateur portable, celui-ci rencontre des problèmes sur des sorties de veille en RAM.
En cherchant un peu sur Internet, je me suis aperçu que je n'étais pas le seul à qui cela arrivait. Comme certains, c'est une mise à jour des paquets acpi qui m'a (semble-t-il), causé le problème. Tout fonctionnait parfaitement depuis la sortie de Wheezy, voilà plus d'un an.

Honnêtement, je ne sais pas vers quoi me tourner. Les logs ne sont pas vraiment efficaces puisque j'ai remarqué que le disque dur ne se lance pas à la sortie de veille de la machine (ou à peine).
D'ailleurs, en les consultant après une sortie de veille échouée, je m'aperçois que rien n'est écrit dedans (la mise en veille "performing suspend" est réussie, mais rien n'indique quelque chose sur la sortie de veille).

De temps en temps (1 fois sur 3), la sortie de veille fonctionne normalement.
Le reste du temps, l'écran est allumé et reste noir.
Je n'ai aucun problème avec un LiveUSB et un noyau plus récent corrige le problème mais en apporte d'autres.

Je ne sais pas vraiment vers quoi me tourner.

Le matériel n'est pas tout jeune (4 ans), un test smart ne signale aucun problème, mais je ne sais pas comment vous en dire plus.

Merci pour vos conseils, aiguillages, etc. :)

EDIT : Il s'agit bien de veille en RAM (suspend). :)

  • # sur ubuntu, j'ai eu également des problèmes

    Posté par . Évalué à 2.

    Par contre peux-tu préciser STP ? S'agit-il de sortie de veille en RAM ou sur disque (hibernation ou mise en veille prolongée ) ?

    LA mise en veille sur disque marche à peu près chez moi (avec encore un problème : il met en hibernation sur disque lorsque le couvercle de mon portable est dermé alors que je voulais que la mise en veille soit faite lorsque le couvercle est fermé ET que l'alimentation est débranchée).

    Pour l'hibernetion, et retour d'hibernation, toujours pas réglé, mais je n'ai pas eu le temps de m'y pencher.

    Ubuntu étant dérivé de Debian, je soupçonne que c'est le même problème.

    • [^] # Re: sur ubuntu, j'ai eu également des problèmes

      Posté par . Évalué à 1.

      C'est de la veille en RAM. Très rapide (2-3 secondes en entrée de veille ou sortie). Tout a parfaitement fonctionné pendant un an, et là, plus rien.

      Par contre, je n'ai pas testé l'hibernation. Ce ne serait pas un problème d'espace disque, te concernant ? :)

      • [^] # Re: sur ubuntu, j'ai eu également des problèmes

        Posté par . Évalué à 2.

        Par contre, je n'ai pas testé l'hibernation. Ce ne serait pas un problème d'espace disque, te concernant ? :)

        Tu parles de l'hibernation ? Si c'est le cas, ce n'est pas un pb d'espace disque : l'hibernation fonctionne en elle-même mais ne tiens pas compte des paramètres d'alimentation indiquant que je ne veux pas d'hibernation lorsque je ferme le couvercle.

        Sinon pour la mise en veille, en quoi l'espace disque pourrait-il poser problème ? C'est une vraie question : je cherche peut-être quelque chose qui est devant mon nez …

        • [^] # Re: sur ubuntu, j'ai eu également des problèmes

          Posté par . Évalué à 1.

          L'hibernation, c'est quand on écrit toutes les données sur le disque avant d'éteindre la machine. Au réveil, celles-ci sont "retransférées" dans la RAM.

          La mise en veille, c'est "tout est chargé dans la RAM" (d'où le réveil plus rapide).

          Du coup, des problèmes d'espace-disque peuvent gêner le réveil d'une hibernation.

        • [^] # Re: sur ubuntu, j'ai eu également des problèmes

          Posté par . Évalué à 1.

          Bonjour,

          Je ne crois pas que dans ton cas l'erreur soit a cause de l'espace disque. Il me semble de mémoire que lors d'un suspend to disk, c'est la partition swap qui est prise en compte pour décharger la RAM donc sauf si tu as fait des modifications, ton swap est de la même taille que ta RAM.

          • [^] # Re: sur ubuntu, j'ai eu également des problèmes

            Posté par . Évalué à 2.

            Pour info, mon swap est un peu plus grand que la RAM ( 2x) : ça me permettra de doubler celle-ci facilement lorsque le moment sera venu, sans avoir à me poser de question. Et pourquoi 2x et pas 4x ? Parce que ma machine n'acceptera probablement pas plus de RAM.

  • # Sur Archlinux, j'ai le même problème.

    Posté par . Évalué à 1.

    Depuis 1 ans environ je n’ai plus de mise en veille et d’hibernation sur mon X31,
    je vois que je ne suis pas le seul a avoir ce problème et sur une distrib différente.

    Il semblerait que le swap ni soit pour rien,
    je soupçonne systemd d’être à l’origine du problème, comment le savoir…

    Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

    • [^] # Re: Sur Archlinux, j'ai le même problème.

      Posté par . Évalué à 1. Dernière modification le 09/09/14 à 08:04.

      Quand j'ai eu ce problème (le SSD / disque dur ne se "lançait" pas au retour de veille/hibernation), c'était le kernel linux qui n'était plus compatible avec la config de mon BIOS (je cite ci-dessous la doc ubuntu sur l'ASUS X71SL) :

      Bios > Security > I/O interface security > option New card interface —> mettre en statut LOCKED au lieu de UNLOCKED
      Model de laptop cité dans le topic avec le même problème : ASUS-F81SE, ASUS-X71SLseries(le mien), ASUS F50S, ASUS N90

      Bref, faudrait fouiller dans ton BIOS pour voir (ça vaut aussi pour l'auteur du journal).

      Quant à systemd, je ne vois pas vraiment le rapport. C'est le kernel et le BIOS qui gèrent au final l'ACPI, pas systemd.

      Ce how-to, assez vieux, est quand même intéressant d'un point de vue technique je trouve :
      https://forums.gentoo.org/viewtopic.php?t=122145

      "Quand certains râlent contre systemd, d'autres s'attaquent aux vrais problèmes." (merci Sinma !)

      • [^] # Re: Sur Archlinux, j'ai le même problème.

        Posté par . Évalué à 1. Dernière modification le 10/09/14 à 17:46.

        c'était le kernel linux qui n'était plus compatible avec la config de mon BIOS

        Quand j’ai eu le problème, je suis revenu sur l’ancien kernel, ça na rien changé.
        Actuellement j'utilise le kernel 3.15.

        Bref, faudrait fouiller dans ton BIOS pour voir

        Déjà fait aussi, merci.

        Quant à systemd, je ne vois pas vraiment le rapport. C'est le kernel et le BIOS qui gèrent au final l'ACPI, pas systemd.

        Systemd a simplifié la gestion au démarrage mais pose encore d’autre problème.
        Il m’a déjà posé des problèmes avec le swap que j'ai du commenté dans le fstab et actuellement avec les password 1 fois sur 2 au reboot.

        Voila pourquoi je dis " je soupçonne systemd d’être à l’origine du problème, comment le savoir… "

        Pour la gestion de mise en veille et hibernation j’utilisais ca

        Ça fonctionnait très bien jusqu’en Novembre 2013, là le server X ne voulait plus démarrer,
        j’ai retiré nomodesete du grub et là le server X refonctionne, mais je n’ai plus de mise en veille et d’hibernation.

        Actuellement j’utilise Laptop-mode pour lui interdire la mise en veille et hibernation faute de mieux.

        Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

    • [^] # Re: Sur Archlinux, j'ai le même problème.

      Posté par . Évalué à 3.

      Alors, de ce que j'ai pu lire, il faudrait désactiver KMS. Tu as essayé ? :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.