Forum Linux.debian/ubuntu Retour d'expérience sur l'installation d'une debian sur Dell T3600

Posté par . Licence CC by-sa
Tags : aucun
3
4
jan.
2013

Bonjour à vous,

J'ai reçu de père Noël des pros une nouvelle machine au boulot le 24 décembre : un Dell T3600 tout clinquant, avec 4GiO de RAM et une carte video nvidia Quatro 600. Je n'ai pas réellement pu choisir le modèle, étant soumis à marché public, juste la gamme. Je suis développeur, je fait maintenant principalement du python / django, mais j'ai quelques applications plus anciennes à maintenir. Mon ancien Dell precision 390 commençait à être un peu asthmatique, surtout avec eclipse + Aptana.

J'ai réussi à convaincre mes responsables que je n'avais pas besoins de windows comme OS principal (depuis 3 ans environ, j'en suis très fier). J'ai juste une VM pour les anciens développement

Je souhaitais installer une LMDE dessus, comme ce que j'avais avant… J'ai gravé le DVD, et je le place dans le lecteur de la nouvelle machine : impossible de booter. En effet, le driver nouveau ne fonctionne pas avec cette machine, même pas en mode 'sans echec'.

Je me dis, pas de problème, je vais (enfin) passer à une vrai Debian de barbu, pure et dure.

Je re-grave un CD, je le met dans le lecteur… Ça boot en mode texte, je peux faire mon installation aux petits oignons.

Je trafique un peu la config pour quand même booter en mode graphique en Vesa, et après quelques essais, ça boot… en Vesa, avec une résolution pourrie, mais quand même en graphique. Je veux installer mes paquets nvidia : le mot de passe root ne fonctionne pas. (J'ai déja eu le problème avec la debian, je n'ai pas compris pourquoi quand je tape le mot de passe root à l'installation, il ne fonctionne plus ensuite, et pourtant je fais attention à ce que je tape)

Redémarrage avec le CD debian, mode sans echec, chroot sur le '/' du disque dur, modification du mot de passe root, reboot… Merde, j'ai oublié de reconfigurer le xforcevesa, on reboot.

Là ça redémarre en graphique, le mot de passe root est OK. Je blackliste le driver nouveau, j'installe enfin les drivers nvidia, (j'oublie de faire le nvidia-xconfig, reboot sans xforcevesa, reboot)… je fais le nvidia-xconfig, reboot… ÇA MARCHE !

Je réinstalle vite-fait eclipse + Aptana + subclipse : ça démarre instantanément !

Ouh la la, ça m'a pris la journée quand même… Bon, j'étais de bonne humeur en déballant mes cadeaux, un peu plus ennervé en fin de journée, mais content quand même de ma nouvelle machine. Là, il est temps de partir en vacance !

Je reprends lundi, en route pour la migration des data ! 6GiO rien que dans le dossier Boulot, il va y avoir de l'attente…

frague

PS : pas de remarque désobligeante sur nvidia, je fait un peu de blender et j'utilise parfois ma machine de boulot pour calculer des animations la nuit. Cycle ne supporte que CUDA pour les calculs.

PPS : J'ai oublié de préciser que le reboot était TRÈS TRÈS lent, la partie BIOS durait bien 40/50 secondes…

  • # une piste pour le probleme de mot de passe entre l'installation et l'utilisation

    Posté par . Évalué à 2.

    ce ne serait pas simplement que pendant l'installation tu es en clavier anglais (meme si tu choisis une installation en francais) ?

    ainsi si ton mot de passe est habituellement azerty
    pendant l'installation tu tapes en realité qwerty

    et je t'expliques pas le bordel si tu fais un vrai mot de passe avec des chiffres et des caracteres speciaux…

    • [^] # Re: une piste pour le probleme de mot de passe entre l'installation et l'utilisation

      Posté par . Évalué à 1.

      Bonsoir,

      non , c'est un bug connu de l'installateur (Debian/wheezy): suivant les paquets que l'on installe, on a soit: un clavier correct, soit un clavier anglais. En installant une version serveur (sans gnome ni autre gui), on garde le clavier anglais même si on a bien configuré sa "locale". Il y a une astuce pour corriger ça après coup.

      C'est le bug : #694156

      astuce: update-initramfs -u -k all

      J'ai cherché longtemps (surtout, j'utilisais un lvm chiffré, alors la phrase de pass …)

  • # Euh !?

    Posté par . Évalué à 1.

    PPS : J'ai oublié de préciser que le reboot était TRÈS TRÈS lent, la partie BIOS durait bien 40/50 secondes…

    C'est très long c'est le moins qu'on puisse dire. T'as une option « Quick Boot » dans le BIOS peut-être, ça pourrait aider.

    Même remarque que plus haut pour le mot de passe root, un mappage différent entre l'installeur et le système une fois installé. Je ne vois que ça.

    • [^] # Re: Euh !?

      Posté par . Évalué à -1.

      Peut-être un problème de reconnaissance du disque dur, ce qui m'est déjà arriver sans aucune erreur de sa part.

      Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.