Forum Linux.debian/ubuntu [solved] monter automatique davfs2 sur raspberry pi

Posté par . Licence CC by-sa
Tags : aucun
2
25
fév.
2016

Je remercie d'avance toute personne qui acceptera de nous aider :)

J’éprouve une énorme difficulté a auto monter au boot du rasbpberry pi un folder davfs2 présent sur owncloud.
J'ai suivis les tuto Automatically Mount your ownCloud folder with webDAV et ubuntu-fr Davfs2.
Lorsque je fais "mount owncloud" en espace utilisateur, le dossier se monte correctement et j'y ai bien accès en RW.
Mais pas moyen de le faire se monter au démarrage. J'ai tenté via ajout d'un script dans "/etc/init.d/" ainsi qu'en éditant "/etc/rc.local" mais rien n'y fait.
Je pense que c'est dû a un problème d'utilisateur exécutant "rc.local". En effet, j'ai ajouté dans mon script de montage la création d'un fichier "test" : quand je lance le script en espace utilisateur, le fichier créé appartient à "pi:pi" alors que lorsque le script est appelé au boot le fichier créé appartient à "root:root".

Infos :
OS : Raspbian Jessie
C'est un projet hyper pressant, la personne en a besoin pour ce soir et je galère vraiment (j'étais certains que se serait rapide et facile). J'ai lancé l'installation d'un environnement graphique afin de chercher d'autres solutions.
Quasi toutes mes actions sont indiquées ici

  • # un probleme de droti d'acces

    Posté par . Évalué à 5.

    l'utilisateur root a-t-il le droit d'acceder aux partages DAV ?
    comment lui precises-tu quel utilisateur il doit utiliser pour acceder au partage DAV.

    dans la procedure il y a deux choses que tu as du faire avec l'utilisateur pi et qui ne seront pas dispo quand tu seras root :

    1°) ajouter l'utilisateur $USER au groupe DAVFS, c'est bete mais il faut aussi le faire pour root

    2°) creer le dossier $HOME/.davfs soit, cela va creer le dossier .davfs dans le dossier de l'utilisateur courant,

    ensuite tu y depose le secret, etc.

    bref quand tu es root, ton $HOME n'est pas /home/pi
    donc le davfs et son secret n'existe pas, etc

    il te faut donc refaire les memes manipulations avec l'utilisateur root…

    • [^] # Re: un probleme de droti d'acces

      Posté par . Évalué à 1. Dernière modification le 25/02/16 à 18:42.

      Merci pour ton aide Neox.
      N'est-ce pas préférable que se soit l'utilisateur courant qui monte le dossier (afin que ce soit ce dernier qui puisse poster les fichiers)?

      Alors les test en fonctions de se que tu as dis :
      sudo adduser root davfs2
      mkdir /home/root
      mkdir /home/root/.dafvs2
      cp -R /home/pi/.davfs2 /home/root/

      modification du fstab : $HOME/owncloud
      ==> ne fonctionne pas ("sudo mount owncloud" ne prend pas en compte le /home/root/davfs2/secret que j'ai créé, il demande le login/pass d'owncloud)

      J'ai aussi créé un /media/owncloud (pi:root 770) et tenté de faire pointer les configs (fstab, root et pi) vers ce point de montage mais toujours rien.

      Enfaîte, je trouve bizarre un truc:
      j'arrive bien a faire fonctionner "sudo -u pi /usr/bin/screen -d -m -S motion motion -c /home/pi/motion/motion.config" via le rc.local (motion se lance bien en utilisateur "pi") mais "sudo -u pi mount /media/owncloud" ne fonctionne pas.

      Et je n'arrive pas a trouver le fichier log qui pourrait m'aider :(

      Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

      • [^] # Re: un probleme de droti d'acces

        Posté par . Évalué à 2. Dernière modification le 25/02/16 à 19:21.

        Bon et bien le problème est corrigé et je ne sais pas trop pourquoi, j'ai trop bidouillé. (je vais reformater le raspberry pi et recommencer a zéro pour trouver)

        La config qui fonctionne pour le moment :
        Dans le /etc/rc.local ajouter un appel vers le script /home/pi/mountOwncloud.sh

        Dans /home/pi/mountOwncloud.sh

        #!/bin/sh
        sleep 5
        sudo -u pi mount /media/owncloud
        

        Dans /etc/fstab

        https://HOSTNAME:PORT/owncloud/remote.php/webdav/   /media/owncloud        davfs   _netdev,rw,user 0       0
        

        Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

        • [^] # Re: un probleme de droti d'acces

          Posté par . Évalué à 4.

          la version avec l'histoire de root, c'est parce que le home de root n'est pas dans /home/root mais dans /root

          mais la nouvelle version est propre, bien jouée.
          elle peut cependant etre ameliorée :

          dans /etc/rc.local, mettre directement

          sleep 5
          sudo -u pi mount /media/owncloud
          
          exit 0

          ca devrait aussi faire l'affaire

          • [^] # Re: un probleme de droti d'acces

            Posté par . Évalué à 2. Dernière modification le 26/02/16 à 00:11.

            merci pour l'infos :)

            en passant, sais tu se que _netdev signifie dans ma ligne fstab?

            Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

            • [^] # Re: un probleme de droti d'acces

              Posté par . Évalué à 2.

              oui je le sais,
              mais si toi tu ne le sais pas, c'est que tu joues au apprenti sorcier en copiant/collant des lignes sans les comprendre, cela peut s'averer dangereux.

              man fstab ne nous aide pas beaucoup, mais une simple recherche sur le net nous apprend que _netdev lui dit d'attendre que l'interface reseau siot monter avant de faire le montage (c'est mieux pour un disque reseau) evitant ainsi que le boot ne soit bloqué par le montage de ce partage

              • [^] # Re: un probleme de droti d'acces

                Posté par . Évalué à 1.

                Ça confirme se que je pensais merci, je n'étais pas sur de ma compréhension de la doc en anglais de cette option :P

                Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.