Forum Linux.debian/ubuntu souci squid3 + clamav + havp

Posté par .
Tags : aucun
1
18
juin
2010
Bonjour à tous,

Je viens de monter un proxy sur une Debian 5.0 Lenny avec squid 3 + squidguard qui fonctionne à merveille avec wpad .dat pour la conf auto des navigateurs.

Je souhaite rajouter une couche antivirus avec clamav + havp.

C'est là que j'ai un souci,

1) installation de clamav avec :
aptitude install clamav clamav-base

2) mise à jour de la base antivirus :
freshclam

3) scan du système :
clamscan -r

----------- SCAN SUMMARY -----------
Known viruses: 800680
Engine version: 0.96.1
Scanned directories: 302
Scanned files: 5451

4) installation de havp avec :
aptitude install havp

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
Les NOUVEAUX paquets suivants vont être installés :
havp libclamav5{a}
0 paquets mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de télécharger 0o/670ko d'archives. Après dépaquetage, 1962ko seront utilisés.
Voulez-vous continuer ? [Y/n/?] Y
Ãcriture de l'information d'état étendu... Fait
Préconfiguration des paquets...
Sélection du paquet libclamav5 précédemment désélectionné.
(Lecture de la base de données... 119354 fichiers et répertoires déjà installés.)
Dépaquetage de libclamav5 (à partir de .../libclamav5_0.94.dfsg.2-1lenny2_i386.deb) ...
Sélection du paquet havp précédemment désélectionné.
Dépaquetage de havp (à partir de .../archives/havp_0.89-1_i386.deb) ...
Traitement des actions différées (« triggers ») pour « man-db »...
Paramétrage de libclamav5 (0.94.dfsg.2-1lenny2) ...
Paramétrage de havp (0.89-1) ...
Ajout du groupe « havp » (identifiant 117)...
Terminé.
There is already /var/lib/havp/havp.loop, maybe from an earlier or custom installation, not building loopback-device
Mounting /var/lib/havp/havp.loop under /var/spool/havp ...done
Cleaning up /var/spool/havp... done
Starting havp: Starting HAVP Version: 0.89
LibClamAV Warning: ***********************************************************
LibClamAV Warning: *** This version of the ClamAV engine is outdated. ***
LibClamAV Warning: *** DON'T PANIC! Read http://www.clamav.net/support/faq ***
LibClamAV Warning: ***********************************************************
LibClamAV Error: cli_hex2str(): Malformed hexstring: This ClamAV version has reached End of Life! Please upgrade to version 0.95 or later. For more information see www.clamav.net/eol-clamav-094 and www.clamav.net/download (length: 169)
LibClamAV Error: Problem parsing database at line 740
LibClamAV Error: Can't load /var/spool/havp/clamav-0425b20ff3883100d37be40482c2c688/daily.ndb: Malformed database
LibClamAV Error: Can't load /var/lib/clamav//daily.cvd: Malformed database
One or more scanners failed to initialize!
Check errorlog for errors.
Exiting..
invoke-rc.d: initscript havp, action "start" failed.
E: Error starting service (could be due to port 8080 already in use), ignoring...
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Ãcriture de l'information d'état étendu... Fait
Lecture des descriptions de tâches... Fait

---------------------------

Pourquoi havp me dit que me version de ClamAV n'est pas à jour alors que ClamAV me dit le contraire et en regardant sur le net c'est bien la dernière version ??

Du coup j'ai plein d'erreur...

Auriez-vous une idée ??
  • # libclamav != clamav

    Posté par (page perso) . Évalué à 2.

    Ben il n'utilise pas clamav mais libclamav, qui d'après tes logs est en version 0.94 sous Debian (enfin je suppute :.Paramétrage de libclamav5 (0.94.dfsg.2-1lenny2) ..)
    .

    les pixels au peuple !

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.