Forum Linux.debian/ubuntu Vuze sur Raspian / ubuntu mate

Posté par . Licence CC by-sa
0
28
sept.
2017

Bonjour à tous

Nouveau sur Linux et ses variantes je nage complètement sur des problèmes de paquets et de dépendances non satisfaites.

Aujourd'hui je cherche à installer vuze.
l'installation via apt-get ne peut se faire car vuze (ou azureus) demande openjdk (ou jre) 7
mais ces paquets ne sont pas dispo (la dernier version est java 8 et elle est bien installé sur mon Raspi)
J'ai donc télécharger vuze directement depuis leur site et lorsque je lance vuze ou azureus, toujours la même chose, des erreurs de démarrage car libswt serait manquante. Pourtant, plusieurs librairie sont dispo dans le dossier swt (en 32 et 64bits)
Malgré cela rien à faire, il ne veut pas.

Java semble bien reconnu et le chemin est par contre OK
Auriez vous un conseil à me donner ou est-ce quelque chose que j'ai loupé ?
Avec raspbian et ubuntu mate, c'est le même problème à chaque fois.

Je voulais vraiment découvrir linux mais ca commence à me prendre la tête car ca fait deux semaine que je galère avec le probleme.

Même l'installation de firefox (pourtant un incontournable sur linux) ne veut pas s'installer
Via apt-get install firefox, il semblerait que "je demande l'impoossible" d'après le terminal.

Merci pour toutes aides possible.

Cdt

Tyto~

  • # architecture ARM

    Posté par . Évalué à 3. Dernière modification le 28/09/17 à 12:51.

    Peut-être checker de ce côté.

    Si c'est pour faire une seedbox torrent, je puis te conseiller plus tôt Transmission voir Deluge.
    Ils sont tout deux contrôlable à distance et si je ne m'abuse Transmission est déjà installé sur la plus part des distro.

    Même l'installation de firefox (pourtant un incontournable sur linux) ne veut pas s'installer
    Via apt-get install firefox, il semblerait que "je demande l'impoossible" d'après le terminal.

    Ça n'a rien à voir avec Linux mais avec ton architecture…
    Les nano ordinateurs (raspberry pi, odroid, arduino, etc, etc, etc) utilisent des processeurs ARM dont seulement quelques rares derniers (armv8) sont compatible 64bit.
    Firefox, d'après cette page, ne semble compatible qu'avec 32 et 64 bit.

    Je voulais vraiment découvrir linux mais ca commence à me prendre la tête car ca fait deux semaine que je galère avec le probleme.

    Apprentissage n°1 : dans le monde il existe différents types de processeurs et les logiciels, peut importe le système (Win, GNU/Linux, Mac), ne sont pas compatible avec tous.

    Si vous codez un logiciel sans une interface chatoyante, alors vous faites de la merde. Donation bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

    • [^] # Re: architecture ARM

      Posté par . Évalué à 1.

      Bonjour

      Merci pour ta réponse.

      L'avantage de Vuze (enfin je l'espère sur linux puisque dispo sur Windows) est qu'il dispose d'un parametrage qui oblige le logiciel à passer par une interface réseau pour fonctionner (dans mon cas un vpn xyz)
      Sans cette connexion, il ne tourne pas.

      Dans le cas de deluge et transmission, ils fonctionneront et passeront par ma connexion "de base" si le VPN venait à se deconnecter.

      Il y a bien la solution des iptable mais c'est vraiment trop complexe.
      Concernant Firefox, j'ai réussi à l'installer mais sans passer par la commande "standard" donc c'est que c'est bien fonctionnel (et dispo sur ubuntu mate de base donc.)

      Concernant ton lien, je te remercie mais je l'avais déjà lu cette article.
      Toujours le même probleme : il demande un paquet qui n'est plus existant puisque déjà dépassé avec une nouvelle version en cours.

      Dois-je en conclure que Linux ne reconnait pas des versions plus récente de paquet ?

      Moi je veux bien installer le jdk6 ou 7 mais dans ce cas ou le trouver ?
      Et si une mise à jour s'applique et que vuze ne tourne plus, j'aurais l'air idiot.

      Merci tout de même pour ton aide, j'apprécie :)

      Tyto~

      • [^] # Re: architecture ARM

        Posté par . Évalué à 2.

        Dois-je en conclure que Linux ne reconnait pas des versions plus récente de paquet ?

        Linux est le noyau de ta distribution. Les paquets et applications, si je ne m'abuse, c'est plus tôt le "problème" des distributions (la couche au dessus du noyau).

        il demande un paquet qui n'est plus existant puisque déjà dépassé avec une nouvelle version en cours

        Tu devrais donner des détails, je ne suis pas omniscient :P (je n'ai jamais tenté d’installer ces logiciels sur ARM)
        Tu as tenté d'installer ce paquet? C'est quoi son tit nom?

        Dans le cas de deluge et transmission, ils fonctionneront et passeront par ma connexion "de base" si le VPN venait à se deconnecter.

        Restricting Transmission to the VPN interface on Ubuntu Linux

        Sans cette connexion, il ne tourne pas.

        Note qu'on peut très facilement faire un petit script qui quitte un logiciel si une interface réseau n'est plus détectée :)

        Si vous codez un logiciel sans une interface chatoyante, alors vous faites de la merde. Donation bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.