Forum Linux.debian/ubuntu Xorg - Radeon 9600 - Forcer les modes

Posté par .
Tags : aucun
1
14
sept.
2008
Bonjour,

J'ai un portable sous Debian/Lenny avec une carte Radeon 9600 un bel écran 15" qui fait du 1600x1200. Je suis habitué à avoir les modes 4:3 à partir du 1600x1200, soit :
1600x1200 1280x1024 1024x768 800x600 et 640x480

Mais voilà, depuis quelque temps xrandr ne me propose plus que :
1600x1200 60.0*+
1280x800 60.0
1280x768 60.0
1024x768 60.0
800x600 60.3
640x480 59.9

Le 1280x1024 a disparu.
J'ai essayé pas mal de trucs avec xorg.conf (dont des Modeline dans la section Monitor) mais rien n'y fait.

En revanche si je boote sur une clef USB qui est encore sous Etch, j'ai les bons modes.

Il y a eu apparemment pas mal de changement dans Xorg, et j'ai beau chercher sur Google, je ne trouve que des réglages anciens qui ne marchent plus.

Quelqu'un ici connaîtrait-il le moyen de faire revenir mon mode 1280x1024 ?

Merci par avance.
  • # 1,333333

    Posté par . Évalué à 1.

    tu écris que ta résolution d'écran c'est 4/3 1600 x 1200
    il y a peu de portable dans ce cas

    le 4/3 c'est ça

    1600x1200

    1400x1050

    1280x960

    1024x768

    800x600

    640x480

    xorg en a décidé ainsi
    • [^] # Re: 1,333333

      Posté par . Évalué à 1.

      Oui, effectivement il y a souvent confusion entre le 1280x1024 et le 1280x960. Mais le problème est le même : je n'ai pas non plus le 1280x960 comme mode.
  • # fais le avec xrandr

    Posté par (page perso) . Évalué à 7.

    Il ne faut plus toucher au xorg.conf. Tu peux rajouter un mode à ceux que xrandr propose avec --newmode et --addmode.

    Supposons que tu n'as pas la modeline et que la fréquence dans cette résolution bizarre soit 60Hz. Tu la crées avec gtf :
    gtf 1280 1024 60

    Tu obtiens un truc du genre Modeline "1280x1024_60.00" Blabla bla que tu montres la modeline à xrandr :

    xrandr --newmode "1280x1024_60.00" Blabla bla (tout sauf modeline)

    Ensuite, il faut expliquer à xrandr que ce mode correspond à ton écran (supposons que l'écran s'appelle LVDS)
    xrandr --addmode LVDS "1280x1024_60.00"

    Et finalement, tu lui dis que c'est ce mode que tu veux utiliser
    xrandr --output LVDS --mode "1280x1024_60.00"
    • [^] # Re: fais le avec xrandr

      Posté par . Évalué à 2.

      Ahhhhh.
      Ça c'est une réponse qui me plait.
      Pas le temps d'essayer là de suite mais je m'y mets ce soir en rentrant.

      Merci !
    • [^] # Re: fais le avec xrandr

      Posté par . Évalué à 2.

      Eh ben ça marche très bien. Merci !
      Je me suis fait un petit script qui est lancé au démarrage de la session pour configurer mes modes à ma sauce.
      Cependant, j'aurais aimé un moyen de spécifier tout ça *avant* que le serveur X ne se lance. Je ne pense pas que ce soit prévu (pas de fichier de conf pour xrandr apparemment), mais on ne sait jamais.... C'est possible ?

      Merci encore.
      • [^] # Re: fais le avec xrandr

        Posté par (page perso) . Évalué à 4.

        Je viens de relire la page de wiki qui m'a tout appris : http://wiki.debian.org/XStrikeForce/HowToRandR12 et la section III.5 dit ce qu'il faut faire (utiliser l'option PreferredMode de X), donc il y a bien un moyen de faire le changement de façon durable.
        • [^] # Re: fais le avec xrandr

          Posté par . Évalué à 1.

          Ernest you made my day, comme on dit.
          Merci mille fois pour ce lien que je n'ai pas réussi à trouver après de longues recherches google.
          Ma config est maintenant pile poil aux petits oignons.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.