Forum Linux.debian/ubuntu XPS problème d'écran

Posté par .
Tags : aucun
1
22
jan.
2012

Bonjour.

Ceci est un problème que je me traîne depuis pas mal de temps, un problème graphique.

Je me servais de mon ordinateur en juillet, quand tout à coup, tout a planté. Je redémarre mon pc, impossible de faire fonctionner ubuntu. Étrange, mais je ne perds pas le nord et tente de le réinstaller. Pas moyen, l'ordinateur refuse de démarrer entièrement sur le live cd. Alors je range mon cd de 11.04 et essaye avec la 10.10. De même, pourtant il fonctionnait parfaitement avec cet ubuntu. 10.04, c'est la même chose. Alors je branche un écran externe. Pas de problème, tout démarre, toutes les versions.

Hmm, je me dis donc que le problème vient de l'écran interne, et le Diagnostic Dell révèle que j'ai raison, qu'il y a un bug avec le LCD.

C'est ainsi que mon pc portable s'est transformé en pc fixe.

Or, courant Octobre, il me vient l'idée pas très révolutionnaire de le démarrer en Low graphics. Là, l'écran interne fonctionne à merveille, de plus à la bonne résolution.

Je dis "Mouarffeza".

Il m'avait semblé que Windows ne fonctionnait pas non plus, cependant, un test récent, TRÈS récent m'a démontré que sous windows mon écran interne n'avait aucun problème, même avec la 3D et les pilotes NVIDIA d'installés.

Pourtant, même ArchLinux refuse de démarrer.

Donc je résume. J'ai un problème matériel qui empêche Ubuntu de faire fonctionner mon écran interne, mais que Windows ignore.
L'idée serait donc d'essayer de forcer la détection de mon écran, je veux bien essayer les pilotes libres ou proprios, comme vous le souhaitez.

J'ai une nvidia 8600M GT si ça peut vous informer,

merci d'avance,

J'ai posté ce message sur d'autres forums, juste dans le but de recevoir une aide le plus vite possible...

Je tiens aussi à signaler qu'ubuntu lorsqu'il est démarré sur un écran externe ne remarque pas l'existence de mon écran interne dans son display manager...

  • # forcer le driver dans xorg.conf

    Posté par . Évalué à 2.

    fait juste la subsection qui va bien dans le xorg pour forcer le driver.

    pour une carte nvidia tu peux tester :
    - vesa (low graphic)
    - nv (pilote libre)
    - nvidia (pilote non libre fournit par nvidia)

  • # Xorg.conf

    Posté par (page perso) . Évalué à 1.

    Peut être que le EDID de l'écran est corrompu, le mien est complètement foutu, aucune distribution ne fonctionne si je ne mets pas ce xorg.conf
    https://raw.github.com/stombi/configfiles/master/E2403WS-nvidia.xorg.conf

    • [^] # Re: Xorg.conf

      Posté par . Évalué à 0.

      Un grand merci !

      Ceci a résolu mon problème d'écran interne. Reste qu'ayant mis une configuration Xorg, je ne peux plus mettre mon écran externe =D C'est terrible, c'est soit l'un soit l'autre ! Mais merci beaucoup !

      • [^] # Re: Xorg.conf

        Posté par . Évalué à 2.

        si tu utilises le driver proprio nvidia
        utilise nvidia-settings (fournit avec en general) pour gerer tes changements d'ecrans

  • # Pilotes proprio

    Posté par . Évalué à 2.

    Même problème chez moi depuis une certaine version du pilote proprio.
    Avec même carte graphique bien sûr. Sur un Msi GX600.

    Sous nouveau aucun problème (a part la vitesse).
    Sous la version 170 du proprio idem a nouveau.
    Si écran externe debranché LCD fonctionne.

    Bref... c'est pas super.

  • # EDID mort et pilote nouveau

    Posté par . Évalué à 0.

    Je refais remonter le sujet : mon problème venait bien de l'EDID, et ce fichier xorg fonctionne. Seulement voilà, il m'oblige à utiliser le pilote nvidia et j'aimerais me servir de nouveau, y'a un moyen de lui forcer l'EDID ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.