Forum Linux.debian/ubuntu zabbix mysql [2002] Can't connect to local MySQL server

Posté par . Licence CC by-sa
Tags :
1
20
fév.
2015

Bonjour,

J'essaie d'installer Zabbix sur Debian 7 à partir des sources.

D’ailleurs impossible de trouver les paquets zabbix dans le cache apt, si là aussi vous avez une solution, je suis preneur!

Pour en revenir à mon installation à partir des sources, visiblement Zabbix n'arrive pas à se connecter à sa base mysql "zabbix".

14585:20150220:151845.334 Cannot connect to the database. Exiting…
14608:20150220:151845.345 Starting Zabbix Server. Zabbix 2.4.3 (revision 51175).
14608:20150220:151845.345 ****** Enabled features ******
14608:20150220:151845.345 SNMP monitoring: YES
14608:20150220:151845.345 IPMI monitoring: YES
14608:20150220:151845.345 WEB monitoring: YES
14608:20150220:151845.345 VMware monitoring: NO
14608:20150220:151845.345 Jabber notifications: YES
14608:20150220:151845.345 Ez Texting notifications: YES
14608:20150220:151845.345 ODBC: NO
14608:20150220:151845.345 SSH2 support: NO
14608:20150220:151845.345 IPv6 support: NO
14608:20150220:151845.345 ******************************
14608:20150220:151845.345 using configuration file: /usr/local/zabbix/etc/zabbix_server.conf
14608:20150220:151845.346 [Z3001] connection to database 'zabbix' failed: [2002] Can't connect to local MySQL server through socket '/var/run/mysqld/mysql.sock' (2)
14608:20150220:151845.346 database is down: reconnecting in 10 seconds

De plus :

root@debian:/# ps -ef | grep mysql
root 2507 1 0 14:15 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql 2910 2507 0 14:15 ? 00:00:05 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306
root 2911 2507 0 14:15 ? 00:00:00 logger -t mysqld -p daemon.error
root 14721 13289 0 15:40 pts/2 00:00:00 grep mysql

Je comprend pas ce "daemon.error".

Est ce que quelqu'un aurait une idée du pourquoi du comment ?

Merci d'avance.


Tuto suivi, j'ai juste pris la derniere version de zabbix sur source forge.


Je sais pas si cela peut aider mais j'ai aussi une erreur avec la commande.

update-rc.d zabbix-server defaults

update-rc.d: using dependency based boot sequencing
insserv: warning: script 'K01zabbix-server' missing LSB tags and overrides
insserv: warning: script 'zabbix-server' missing LSB tags and overrides

  • # Qu'as-tu tu fais?

    Posté par (page perso) . Évalué à 2.

    Compte admin mysql ?
    Ajout d'une base?
    Connexion via société ou réseau?

    Système - Réseau - Sécurité Open Source

    • [^] # Re: Qu'as-tu tu fais?

      Posté par . Évalué à 1.

      A la base c'est un TP,
      J'ai déjà 2 VM, avec DNS, serveur web, ntp, ftp, etc etc.
      Là je cherche à installer zabbix sur une autre vm pour créer un serveur de supervision avec Zabbix, syslog, nfdump.

      Et je galère !!

  • # Solution alternative

    Posté par . Évalué à 1.

    J'ai trouver une autre solution,

    J'avais essayer d'installer Zabbix à partir des dépôts.
    Orles zabbix n'étant plus dans les dépôts standards mais dans les testing…

    Voir, ce tuto, sur le forum de monitoring-fr.org

    A noter que l'auteur du sujet a eu le même problème que moi concernant la connection à la base mysql…

    Je vous dis si ca fonctionne.

    • [^] # Re: Solution alternative

      Posté par . Évalué à 1.

      Ca à l'air de fonctionner mais j'ai un problème avec la conf d'apache.
      Dans le tuto, il parle du dossier /etc/apache2/conf.d

      Or je n'ai pas de dossier conf.d …
      J'ai supposer que c'était comme dans ninx, j'ai donc créer un fichier de conf dans sites-available, copier la conf et créer un lien symbolique /etc/apache2/sites-available/zabbix-server et /etc/apache2/sites-enabled/zabbix-server

      ln /etc/apache2/sites-available/zabbix-server /etc/apache2/sites-enabled/zabbix-server

      et j'ai redémarrer apache2, j'ai une seul erreur

      Restarting web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
      . ok

      Mais pour l'instant c'est oas grave, je souhaite continuer a utiliser l @ip.

      Bref, il est toujours impossible d avoir le site …

      Je cherche la solution mais si quelqu'un a une idée, je suis preneur !

      merci d'avance.

      PS: je connais nginx mais pas vraiment apache.

    • [^] # Re: Solution alternative

      Posté par . Évalué à 1.

      Ca à l'air de fonctionner mais j'ai un problème avec la conf d'apache.
      Dans le tuto, il parle du dossier /etc/apache2/conf.d

      Or je n'ai pas de dossier conf.d …
      J'ai supposer que c'était comme dans ninx, j'ai donc créer un fichier de conf dans sites-available, copier la conf et créer un lien symbolique /etc/apache2/sites-available/zabbix-server et /etc/apache2/sites-enabled/zabbix-server

      ln -s /etc/apache2/sites-available/zabbix-server /etc/apache2/sites-enabled/zabbix-server

      et j'ai redémarrer apache2, j'ai une seul erreur

      Restarting web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
      . ok

      Mais pour l'instant c'est oas grave, je souhaite continuer a utiliser l @ip.

      Bref, il est toujours impossible d avoir le site …

      Je cherche la solution mais si quelqu'un a une idée, je suis preneur !

      merci d'avance.

      PS: je connais nginx mais pas vraiment apache.

    • [^] # Re: Solution alternative

      Posté par . Évalué à 1.

      Ca à l'air de fonctionner mais j'ai un problème avec la conf d'apache.
      Dans le tuto, il parle du dossier /etc/apache2/conf.d

      Or je n'ai pas de dossier conf.d …
      J'ai supposer que c'était comme dans ninx, j'ai donc créer un fichier de conf dans sites-available, copier la conf et créer un lien symbolique /etc/apache2/sites-available/zabbix-server et /etc/apache2/sites-enabled/zabbix-server

      ln -s /etc/apache2/sites-available/zabbix-server.conf /etc/apache2/sites-enabled/zabbix-server.conf

      et j'ai redémarrer apache2, j'ai une seul erreur

      Restarting web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
      . ok

      Mais pour l'instant c'est oas grave, je souhaite continuer a utiliser l @ip.

      Bref, il est toujours impossible d avoir le site … (page blanche)

      Je cherche la solution mais si quelqu'un a une idée, je suis preneur !

      merci d'avance.

      PS: je connais nginx mais pas vraiment apache.

    • [^] # Re: Solution alternative

      Posté par . Évalué à 1.

      Ca à l'air de fonctionner mais j'ai un problème avec la conf d'apache.
      Dans le tuto, il parle du dossier /etc/apache2/conf.d

      Or je n'ai pas de dossier conf.d …
      J'ai supposer que c'était comme dans ninx, j'ai donc créer un fichier de conf dans sites-available, copier la conf et créer un lien symbolique /etc/apache2/sites-available/zabbix-server et /etc/apache2/sites-enabled/zabbix-server

      ln -s /etc/apache2/sites-available/zabbix-server.conf /etc/apache2/sites-enabled/zabbix-server.conf

      et j'ai redémarrer apache2, j'ai une seul erreur

      Restarting web server: apache2AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1. Set the 'ServerName' directive globally to suppress this message
      . ok

      Mais pour l'instant c'est oas grave, je souhaite continuer a utiliser l @ip.

      Bref, il est toujours impossible d avoir le site … (page blanche)

      Je cherche la solution mais si quelqu'un a une idée, je suis preneur !

      merci d'avance.


      EDITE : SOLUTION trouvée, il faut supprimer le fichier /etc/zabbix/zabbix.conf.php

  • # Repo officiel

    Posté par (page perso) . Évalué à 1.

    fyi : http://repo.zabbix.com/

    Is it a Bird? Is it a Plane?? No, it's Super Poil !!!

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.