Forum Linux.débutant charger paramètres dans GRUB

Posté par . Licence CC by-sa
Tags : aucun
1
2
déc.
2014

Bonjour,
j'essaie d'installer une debian sur un PC qui a un chipset intel atom.
Sauf qu'au premier démarrage, après installation, j'ai un écran noir. Le CTRL + ALT + F1 (F1..F7) n'y fait rien.
J'ai cru comprendre que je devais désactiver le gma500_gfx et que je devais ajouter gma500_gfx.blacklist=yes mais je n'y arrive pas.

A l'aide !!

Merci de votre aide !

Millouzze

  • # Boote sur un autre support...

    Posté par . Évalué à 2.

    … par exemple une image d'install de debian, ouvre une console sans reprendre l'install, normalement la racine de ton système installé est montée quelque part.
    "chroot"e dedans, édite /etc/default/grub pour ajouter la commande de blacklist (le fichier est clair).
    Ensuite il faut réinstaller grub à partir du système installé (et non pas du système d'installation, qui ne prendrait pas la modification en compte).
    De mémoire c'est grub-install /dev/sdXXX (généralement /dev/sda ou sdb si tu n'as qu'un seul disque sur ton PC).
    Il faut peut-être avoir monté le répertoire /dev du système d'install sur le système installé ton PC avec mount -o bind /dev/ /chemin/vers/racine/installee/dev

  • # editer grub au demarrage

    Posté par . Évalué à 4.

    premierement, si tu vois la mire grub (qui te demande sur quel OS tu veux demarrer)
    tu tape simple "E" sur la ligne,
    ca va te permettre d'editer la ligne de demarrage de ton linux,

    ensuite tu cherches la ligne commencant par
    linux ...

    et tu ajoutes les options que tu veux,
    si ca marche, il faudra alors voir pour l'enregistrer pour eviter de faire l'edition à chaque demarrage.

    sous Ubuntu, c'est par exemple en editant le fichier /etc/default/grub

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.