Forum Linux.débutant Linux qui freeze tout le temps!!!

Posté par . Licence CC by-sa
Tags :
1
26
jan.
2016

Bonjour à tous!

Voilà, je suis au bord du désespoir!

J'ai installé sur mon ordinateur portable(Acer Aspire Es1 711) la distribution Fedora (23)J'en suis très satisfait sauf que mon ordinateur n'arrête pas de "frizzer". L’écran se fige et la souris refuse de bouger. Je ne peux même pas accéder au terminal. Je dois éteindre avec le bouton marche/arret de mon ordinateur. Les frizzes sont totalement aléatoire et c'est invivable.
En farfouillant sur le net, j'ai trouvé que s'était un bug du pilote intel i915.

J'ai éditer le fichier /etc/X11/xorg.conf.d/20-intel.conf avec les options Option "NoAccel" "True" et l'Option** "DRI" "False"** mais pas de changement. (mon ordinateur ralentis considérablement avec ses options)

Je ne sais pas trop quoi faire de plus.

Merci pour toutes réponses :)

  • # autre distrib

    Posté par . Évalué à 3.

    tu as essayé une autre distrib, par exemple depuis un liveCD/liveUSB
    ubuntu/debian/mageia….

    histoire de voir si ca vient de materiel ou du logiciel ?

    • [^] # Autre distrib

      Posté par . Évalué à 1.

      Bonsoir et merci pour ta réponse!

      Alors oui, j'ai essayé Linux Mint, et une autre distribution dérivé de fedora (je ne me souviens plus du nom). Même problème. Je pensais faire une tentative avec debian mais je reste attaché a Fedora. Alors si il y a une solution avec Fedora, autant tout essayer.

      • [^] # Re: Autre distrib

        Posté par . Évalué à 2.

        donc si tu as essayé avec d'autres distribs c'est que ca ne vient pas de linux,
        mais que ce serait plutot un probleme avec le materiel.

        les ventilos tournent bien ?
        la temperature est correcte ?

        • [^] # Re: Autre distrib

          Posté par . Évalué à 4.

          Si c'est aléatoire, teste la mémoire vive.

          • [^] # Mémoire vive

            Posté par . Évalué à 1.

            Bonjour!

            Alors j'ai oublié de préciser que je n'ai aucun problème avec windows 7.
            Quelqu’un pourrai me dire comment je peux faire pour tester la mémoire vive? J'imagine que je vais devoir utiliser le live cd.

            • [^] # Re: Mémoire vive

              Posté par . Évalué à 2.

              Tu peux tester ta memoire avec memtest86+ (souvent inclus dans les live)

              • [^] # Re: Mémoire vive

                Posté par . Évalué à 1.

                J'ai effectué le teste avec memtest. Je l'ai laissé tourner pendant des heures et il semble que tout a l'aire bon. Du moins, c'est comme cela que je l'ai interprété.

        • [^] # Matériel

          Posté par . Évalué à 1.

          Les ventilos ne semblent pas obstrué. Je m'en vais prendre sa température, on va voir si il a de la fièvre! :)

          • [^] # Re: Matériel

            Posté par . Évalué à 2.

            je pense que tu as déjà trouvé ces pages, mais au cas où…

            https://wiki.archlinux.org/index.php/Acer_Aspire_E11_Series
            https://wiki.archlinux.org/index.php/Intel_graphics#SNA_issues

            et sinon essaye aussi PCBSD, peut-être que c'est géré différemment et que ça ne fera pas de freeze

            • [^] # Re: Matériel

              Posté par . Évalué à 1.

              Bonjour!
              Oui effectivement, j'ai bel est bien vus ces documents. Surtout la section X freeze/crash with intel driver.
              Seule l'option Option "DRI" "False" ne fait plus freezer l'ordinateur. Cependant cette option ralentis considérablement l'OS et c'est vraiment infâme, surtout lors de visionnage de vidéo ou quand je joue.

              • [^] # Re: Matériel

                Posté par . Évalué à 2.

                pas de chance… :(

                visiblement ça vient bien du pilote d'accélération. Ou est-ce que ça pourrait aussi venir de l'acpi mal géré ? il est possible de désactiver ça au démarrage via une option dans grub.

                j'imagine que tu as testé aussi les différents rendus possibles :

                By default Direct Rendering Infrastructure 2 (DRI2) is used. To enable the next generation of DRI, DRI3, which contains several improvements, add the following line to your configuration file:
                
                Option      "DRI"    "3"
                
                 Glamor is Intel's experimental OpenGL 2D acceleration method and is not documented in the manpages. To use it, add the following line to your configuration file:
                
                Option      "AccelMethod"  "glamor"
                   SNA is the default acceleration method in xf86-video-intel. If you are experience issues with SNA (e.g. pixelated graphics, corrupt text, etc.), try using UXA instead, which can be done by adding the following line to your configuration file:
                
                Option      "AccelMethod"  "uxa"
                
                • [^] # Options et ACPI

                  Posté par . Évalué à 1.

                  Ouep… Pas de solution possible alors? J'avais déjà testé ces options : "AccelMethod" "glamor" et Option "AccelMethod" "uxa". Je vais essayer l'option "DRI" "3"

                  Si cela ne marche pas (et je n'y crois pas vraiment…) je vais essayer de désactiver l'acpi. Je vais regarder sur le net comment il faut faire.

                  Au faite, merci pour ton aide et tes conseilles :)

                  • [^] # Re: Options et ACPI

                    Posté par . Évalué à 2.

                    en fait pour l'ACPI souvent ça plante dès le démarrage lorsqu'il y a un problème d'incompatibilité, mais on ne sait jamais, toute piste est bonne à prendre. Le mieux serait d'essayer un live cd et de désactiver l'acpi (ainsi que noapic) dans le menu de démarrage :

                    https://help.ubuntu.com/community/BootOptions

                    sur certains livecd (mint je crois) il y a une option "mode de compatibilité". Après peut-être que ça désactive aussi les effects 3D et que tu ne verras pas d'où vient le problème. (d'ailleurs ça serait intéressant de pouvoir consulter les log suite au plantage, voir /var/log/dmesg ou équivalent)

                    Autres possibilités :
                    - rester avec un bureau minimaliste genre xfce ou openbox, sans accélération 2D et 3D (et pas de jeux graphiques du coup)
                    - attendre de nouvelles versions du noyau / des pilotes / des distributions
                    - voir s'il n'y a pas un périphérique USB qui pose problème (il y a 5-6 ans j'avais un PC qui plantait aléatoirement à cause d'un clavier en usb, avec un clavier ps2 ça passait)
                    - essayer un Unix alternatif : http://pcbsd.org/
                    Pareil, il y a quelques années j'avais des problèmes avec le pilote nvidia, ça freezait l'écran, et sous PCBSD non seulement c'était plus fluide mais je n'avais pas ces problèmes. Après, peut-être que ton portable sera moins bien supporté sous pcbsd que sous linux… à voir.
                    - retourner à windows :( Il y a possibilité quand même d'utiliser des outils unix genre cygwin. On peut aussi installer kde sous windows mais la version semble un peu vieille : https://windows.kde.org/

                    • [^] # Re: Options et ACPI

                      Posté par . Évalué à 1.

                      Pour l'instant, je n'ai pas de bug depuis que j'ai rajouté l'option. Mais je ne crie pas victoire trop vite car cela ne fait que deux petites heures que j'ai modifier mon fichier.
                      Donc Wait and See!
                      Si il y a un autre frizze, je tenterai l'astuce de L'acpi. Merci pour le lien.

                      -J'avais déjà essayé Mint sans le mode de compatibilité (si il existe bien?) et la encore j'avais eu le même problème. J'ai également essayé XFCE fedora … qui a eu un freeze en plein milieu de l’installation (ce qui est plutôt logique en y repensent…) Peut-être essayer sous debian…
                      -Pour le périphérique usb, cela pourrai peut-être provenir de ma clé usb wifi qui a déjà un paquet d'année à son actif et qui, en y réfléchissent, n'est pas très utile (à essayer donc!)
                      -Après, je ne suis pas très chaud pour revenir à windows… J'ai mis pas mal de temps a comprendre le système des RPM et prendre en main le terminal. Je préfère essayer un autre Unix. Après, si je n'ai pas le choix je revendrais à windows7.
                      Pcsbd a l'air pas trop mal. Je vais approfondir mes recherches de ce coté.

                      Merci pour toutes ces précisions!

                      • [^] # Re: Options et ACPI

                        Posté par . Évalué à 1.

                        Encore et toujours de frizze. Je vais tenter xfce sous debian.

                        • [^] # Re: Options et ACPI

                          Posté par . Évalué à 2.

                          vérifie que les extensions "composites" sont bien désactivées pour que ça ne ralentisse pas trop l'affichage. Je ne sais pas si c'est possible de désactiver également l'affichage du contenu des fenêtres lorsqu'on les déplaces ou redimensionne sur xfce…

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.