Forum Linux.débutant Pas internet sur Linux

Posté par . Licence CC by-sa
Tags : aucun
1
11
déc.
2014

Bonjour,

Voilà j'ai installé linux en double BOOT sur mon PC qui était sur Windows 8. J'avais fait la même chose sur mon ancien PC (sur Vista) et je n'avais aucun problème.
Là quand je lance linux tout marche très bien sauf que je n'ai pas internet… Impossible de se connecter au réseau wifi de ma fac et de chez moi.. Même quand je branche le câble ethernet j'ai aucun signal.
Sur Windows je n'ai aucun problème de cet ordre.

Donc voilà je demande de l'aide car j'ai cherché la solution partout sans trouver de réponse concernant mon problème…

C'est important pour moi car je me sers de linux tous les jours pour mon travail mais sur mon ordi de boulot qui n'est pas chez moi… J'aurais aimé l'avoir sur mon ordi perso avec internet pour installer les programmes & logiciels dont j'ai besoin pour travailler…

Merci de votre compréhension et de votre aide!!

Cordialement Nico.

  • # reseau

    Posté par . Évalué à 5. Dernière modification le 11/12/14 à 18:50.

    bonjour

    sous linux, peux tu ouvrir une console sous root et nous poster le resultat de la commande :

    ifconfig

    puis

    iwconfig

    dans la foulée :

    cat /etc/network/interfaces

    ainsi que

    dmesg | grep eth

    et

    uname -a

    mais mon doigt mouillé me dit qu'il manque sûrement microcode de la carte réseau

    • [^] # Re: reseau

      Posté par . Évalué à 4.

      Et également « ifconfig -a » pour voir s'il reconnaît la carte réseau sans l'avoir configurée.

      Peut-on également avoir le résultat de la commande « lspci -nn » et celle de « lsmod » pour voir si ton noyau a bien réussi à charger les pilotes concernés ?

      • [^] # Re: reseau

        Posté par . Évalué à 4. Dernière modification le 11/12/14 à 20:33.

        +1 pour les demandes d'info.

        Par contre il serait aussi utile de signaler de quelle distribution il s'agit pour que l'on puisse te donner les bonnes commandes car contrairement à Windows ou OsX il y a des outils importants propres à la distribution comme le gestionnaire de paquets et linux tout seul c'est un peu léger pour que l'on puisse vraiment t'aider.

        Sur Debian par exemple il y a un paquet qui contient les firmware non libres de pas mal de cartes qui pourrait ne pas être installé et qui expliquerait très bien ton problème (firmware-linux-free).

        • [^] # Re: reseau

          Posté par . Évalué à 3.

          une fois le cable ethernet branché :

          • voir si la prise ethernet est sur un cable actif

            sudo mii-tools

          • si c'est le cas, faire manuellement une requete DHCP ; il te faudra adapter le numero de ton inferface à ta config ; ce n'est pas nécessairement eth0

            dhclient eth0

  • # réponse

    Posté par . Évalué à 1. Dernière modification le 11/12/14 à 22:22.

    Tout d'abord merci beaucoup pour vos réponses! J'ai tout ce que vous m'avez demandé.
    Avant toute chose j'ai relevé un message d'erreur il me semble. Il y est écrit exactement:

    12.617750 nouveau E[ DEVICE] [0000:04:00.0] unknown chipset, 0x118010a2
    12.617785 nouveau E[ DRM] failed to create 0x80000060, -22

    Je sais pas si ça peut aider.
    De plus en ce qui concerne ma "version" je ne sais pas trop, en gros quand je lance linux il est écrit:
    GNU GRUB version 2.02~beta2-9ubuntu1

    Ensuite voici la lise des commandes ainsi que leurs résultats:

    $ifconfig
    eth0      Link encap:Ethernet  HWaddr 78:24:af:ab:78:86  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1 
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0 
              inet6 addr: ::1/128 Scope:Host 
              UP LOOPBACK RUNNING  MTU:65536  Metric:1 
              RX packets:163 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:163 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:0 
              RX bytes:11505 (11.5 KB)  TX bytes:11505 (11.5 KB)
    $iwconfig
    eth0      no wireless extensions. 
    
    lo        no wireless extensions.
    $cat /etc/network/interfaces
    # interfaces(5) file used by ifup(8) and ifdown(8) 
    auto lo 
    iface lo inet loopback
    $dmesg | grep eth
    [    0.864182] r8169 0000:03:00.0 eth0: RTL8168g/8111g at 0xffffc90000c7a000, 78:24:af:ab:78:86, XID 0c000800 IRQ 62 
    [    0.864185] r8169 0000:03:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko] 
    [   10.473103] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 
    [   10.803716] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.RP05.PEGP handle 
    [   12.621047] ACPI Error: Method parse/execution failed [\_SB_.PCI0.RP05.PEGP.DD02._BCL] (Node ffff880224123348), AE_NOT_FOUND (20131115/psparse-536) 
    [   19.264933] r8169 0000:03:00.0 eth0: link down 
    [   19.264981] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready 
    [   19.265217] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    $uname -a
    Linux nicolas-X750LN 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux 
    $ifconfig -a
    eth0      Link encap:Ethernet  HWaddr 78:24:af:ab:78:86  
              UP BROADCAST MULTICAST  MTU:1500  Metric:1 
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:1000 
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B) 
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0 
              inet6 addr: ::1/128 Scope:Host 
              UP LOOPBACK RUNNING  MTU:65536  Metric:1 
              RX packets:163 errors:0 dropped:0 overruns:0 frame:0 
              TX packets:163 errors:0 dropped:0 overruns:0 carrier:0 
              collisions:0 txqueuelen:0 
              RX bytes:11505 (11.5 KB)  TX bytes:11505 (11.5 KB)
    $lspci -nn
    00:00.0 Host bridge [0600]: Intel Corporation Haswell-ULT DRAM Controller [8086:0a04] (rev 0b) 
    00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell-ULT Integrated Graphics Controller [8086:0a16] (rev 0b) 
    00:03.0 Audio device [0403]: Intel Corporation Haswell-ULT HD Audio Controller [8086:0a0c] (rev 0b) 
    00:14.0 USB controller [0c03]: Intel Corporation Lynx Point-LP USB xHCI HC [8086:9c31] (rev 04) 
    00:16.0 Communication controller [0780]: Intel Corporation Lynx Point-LP HECI #0 [8086:9c3a] (rev 04) 
    00:1b.0 Audio device [0403]: Intel Corporation Lynx Point-LP HD Audio Controller [8086:9c20] (rev 04) 
    00:1c.0 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 1 [8086:9c10] (rev e4) 
    00:1c.2 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 3 [8086:9c14] (rev e4) 
    00:1c.3 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 4 [8086:9c16] (rev e4) 
    00:1c.4 PCI bridge [0604]: Intel Corporation Lynx Point-LP PCI Express Root Port 5 [8086:9c18] (rev e4) 
    00:1d.0 USB controller [0c03]: Intel Corporation Lynx Point-LP USB EHCI #1 [8086:9c26] (rev 04) 
    00:1f.0 ISA bridge [0601]: Intel Corporation Lynx Point-LP LPC Controller [8086:9c43] (rev 04) 
    00:1f.2 SATA controller [0106]: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] [8086:9c03] (rev 04) 
    00:1f.3 SMBus [0c05]: Intel Corporation Lynx Point-LP SMBus Controller [8086:9c22] (rev 04) 
    02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01) 
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 0c) 
    04:00.0 3D controller [0302]: NVIDIA Corporation GM108M [GeForce 840M] [10de:1341] (rev a2)
    $lsmod
    Module                  Size  Used by 
    bnep                   19624  2 
    rfcomm                 69160  0 
    bluetooth             391196  10 bnep,rfcomm 
    nls_iso8859_1          12713  2 
    snd_hda_codec_hdmi     46254  1 
    snd_hda_codec_realtek    61438  1 
    uvcvideo               80885  0 
    videobuf2_vmalloc      13216  1 uvcvideo 
    videobuf2_memops       13362  1 videobuf2_vmalloc 
    videobuf2_core         40664  1 uvcvideo 
    joydev                 17381  0 
    videodev              134688  2 uvcvideo,videobuf2_core 
    asus_nb_wmi            16990  0 
    asus_wmi               24191  1 asus_nb_wmi 
    sparse_keymap          13948  1 asus_wmi 
    snd_hda_intel          52355  5 
    snd_hda_codec         192906  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel 
    snd_hwdep              13602  1 snd_hda_codec 
    snd_pcm               102099  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel 
    snd_page_alloc         18710  2 snd_pcm,snd_hda_intel 
    snd_seq_midi           13324  0 
    intel_rapl             18773  0 
    x86_pkg_temp_thermal    14205  0 
    intel_powerclamp       14705  0 
    coretemp               13435  0 
    kvm_intel             143060  0 
    kvm                   451511  1 kvm_intel 
    snd_seq_midi_event     14899  1 snd_seq_midi 
    crct10dif_pclmul       14289  0 
    crc32_pclmul           13113  0 
    ghash_clmulni_intel    13216  0 
    snd_rawmidi            30144  1 snd_seq_midi 
    snd_seq                61560  2 snd_seq_midi_event,snd_seq_midi 
    snd_seq_device         14497  3 snd_seq,snd_rawmidi,snd_seq_midi 
    aesni_intel            55624  0 
    snd_timer              29482  2 snd_pcm,snd_seq 
    aes_x86_64             17131  1 aesni_intel 
    lrw                    13286  1 aesni_intel 
    gf128mul               14951  1 lrw 
    glue_helper            13990  1 aesni_intel 
    ablk_helper            13597  1 aesni_intel 
    cryptd                 20359  3 ghash_clmulni_intel,aesni_intel,ablk_helper 
    serio_raw              13462  0 
    nouveau              1097199  0 
    lpc_ich                21080  0 
    mxm_wmi                13021  1 nouveau 
    ttm                    85115  1 nouveau 
    snd                    69238  21 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_seq,snd_rawmidi,snd_hda_codec,snd_hda_intel,snd_seq_device,snd_seq_midi 
    i915                  783805  5 
    mei_me                 18627  0 
    mei                    82276  1 mei_me 
    bcma                   52096  0 
    soundcore              12680  1 snd 
    drm_kms_helper         53081  2 i915,nouveau 
    drm                   303102  6 ttm,i915,drm_kms_helper,nouveau 
    i2c_algo_bit           13413  2 i915,nouveau 
    video                  19476  3 i915,nouveau,asus_wmi 
    mac_hid                13205  0 
    wmi                    19177  3 mxm_wmi,nouveau,asus_wmi 
    parport_pc             32701  0 
    ppdev                  17671  0 
    lp                     17759  0 
    parport                42348  3 lp,ppdev,parport_pc 
    usb_storage            62209  1 
    hid_generic            12548  0 
    usbhid                 52570  0 
    hid                   106148  2 hid_generic,usbhid 
    ahci                   25819  3 
    libahci                32560  1 ahci 
    r8169                  67581  0 
    mii                    13934  1 r8169
    • [^] # Re: réponse

      Posté par . Évalué à 6.

      Avant toute chose j'ai relevé un message d'erreur il me semble. Il y est écrit exactement:
      12.617750 nouveau E[ DEVICE] [0000:04:00.0] unknown chipset, 0x118010a2
      12.617785 nouveau E[ DRM] failed to create 0x80000060, -22

      Rien d'alarmant de ce côté. « nouveau » est le pilote libre visant à prendre en charge les cartes graphiques nVidia pour ceux qui ne veulent pas installer le pilote propriétaire. Comme il n'est probablement pas à jour concernant ton matériel, il faudra peut-être le remplacer par celui du fabricant. Ce n'est pas difficile, mais on verra ça quand ta connexion fonctionnera.

      De plus en ce qui concerne ma "version" je ne sais pas trop, en gros quand je lance linux il est écrit:
      GNU GRUB version 2.02~beta2-9ubuntu1

      Tu travailles donc avec une Ubuntu. Tu peux essayer « lsb_release -a » pour avoir plus de détails

      ifconfig -a
      eth0 Link encap:Ethernet HWaddr 78:24:af:ab:78:86

      lo Link encap:Local Loopback

      Bonne nouvelle : ton système voit ton port Ethernet (c'est le contraire qui aurait été surprenant) ;
      Mauvaise nouvelle : le même système n'a absolument pas reconnu ton adaptateur WiFi. C'est un problème fréquent quand le matériel est trop récent, ou quand il nécessite un firmware non libre.

      Linux est un système formidable dans le sens où il prend directement en charge la plupart du matériel existant sans que l'utilisateur ait à faire quoi que ce soit. Windows en fait beaucoup moins mais comme les gens ne font pratiquement jamais d'installation initiale (le système est presque toujours pré-installé) et parce que le distributeur fait l'effort d'installer lui-même les pilotes sur les machines qu'il veut vendre, on a l'impression que ça marche tout seul.

      Branche ton câble Ethernet et essaie la commande de Marc Quinton plus haut : « sudo dhclient eth0 » pour réclamer manuellement l'attribution d'une adresse à ta machine (ce qui devrait en principe fonctionner tout seul). Ensuite, lance ton navigateur et vois si tu peux aller sur le web.

      lspci -nn

      02:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n 14e4:4365
      03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller 10ec:8168

      Ce sont ces lignes-là qui nous intéressent. La première est celle de ta puce Wifi, la seconde celle du port Ethernet. Ce qui est intéressant, c'est le couple vendor:product en bout de ligne qui identifie de manière déterministe (enfin, en principe, parce qu'on trouve parfois des clones) l'interface reliée à ton port PCI.

      Il faudrait voir chez Broadcom s'ils fournissent des pilotes officiels mais une brève recherche nous montre que quelqu'un a eu le même problème que toi avec une Ubuntu 13.01 :

      http://askubuntu.com/questions/334268/ubuntu-13-04-does-not-recognize-wireless-adapter-14e44365

      La commande proposée dans la réponse installe le package « bcmwl-kernel-source ». Tu auras peut-être besoin de « linux-firmware-nonfree » s'il n'est pas automatiquement inclus dans les dépendances.

      Voir aussi (plus vieux) : http://askubuntu.com/questions/55868/installing-broadcom-wireless-drivers

      • [^] # Re: réponse

        Posté par . Évalué à 2.

        D'accord je vois. Merci pour toutes ses explications je comprend mieux tout ça!

        Dés demain matin je me branche sur le port Ethernet et je tape la commande que Marc Quinton à écrite.

        Ensuite si ça marche je tape la commande pour installer le package « bcmwl-kernel-source ».

        Si jamais ça marche pas j'installe « linux-firmware-nonfree » et je réessaye le premier c'est bien ça?

        Je vous tiens au courant de l'évolution de cette étape.

        Merci encore; c'est très appréciable d'avoir de l'aide.

        • [^] # Re: réponse

          Posté par . Évalué à 1.

          Par contre c est tres surprenant que eth0 ne soit pas configuré en dhcp dans le fichier interfaces , surtout en 2014 wur ubuntu

          • [^] # Re: réponse

            Posté par . Évalué à 2.

            non c'est normal,
            c'est network manager qui va gerer les interfaces,

            du coup il n'y a rien dans /etc/network/interfaces

      • [^] # Re: réponse

        Posté par . Évalué à 2.

        Bonjour tous le monde, je viens au rapport:

        J'ai lancé ubuntu en branchant le câble ethernet. Ce qui se passe:
        - Le pc reconnait le câble et cherche à se connecter au réseau.
        - Au bout de 20 secondes il se déconnecte et recommence cette manip à l'infini.

        Lorsque j'ai tapé la commande sudo dhclient eth0 pour la première fois:
        - Après avoir tapé le mot de passe: eth0 no found (ou un truc dans ce style).

        J'ai attendu un peu et j'ai retaper la commande pensant que j'avais du faire une fausse manip:
        - Aucune réponse du terminal, obliger de faire crtl C ou crtl Z pour reprendre la main. (J'ai attendu longtemps).

        J'ai donc redémarré mon ordinateur et j'ai réessayé. Même chose, aucune réponse…

        • [^] # Re: réponse

          Posté par . Évalué à 2.

          Concernant la connexion filaire : Normalement c'est network-manager qui gère ça sous Ubuntu. Il apparaît comme une petite applet réseau. Peut-être que c'est mal configuré à ce niveau ?

          Normalement par cet applet tu devrais pouvoir configure le réseau, en mode DHCP (ou automatique) pour IPv4.

          Tu peux également trouver de l'aidre sur l'activité de network-manager dans le fichier /var/log/syslog normalement (connexion, déconnexion, etc.).

  • # Static IP

    Posté par . Évalué à 0. Dernière modification le 12/12/14 à 10:28.

    Vu que le DHCP n’a pas l’air de fonctionner, si tu connais ton plan IP, tu pourrais essayer de configurer une IP statique pour voir ce que ça donne.

    Si ça marche, c’est que c’est (encore Network Manager qui fou la m****)

    Si ça marche pas, ça devient très bizarre.

    HS
    Désolé, mais quand je vois ça :

    Linux est un système formidable […]

    Ça me donne des boutons… Linux n’est pas un « système » c’est un noyau.
    GNU (ou autre) est le système.

    Alors, oui Linux est un noyau, et oui il est formidable parce qu’il intègre énormément de choses.

    Le noyau de Windows (NT de souvenir) n’en fait pas autant, mais c’est totalement normal.

    La différence se situe au niveau de l’architecture kernel, Linux est monolityque et le kernel de Windows est un hybrid-kernel modulaire.
    Reférénce Wiki

    /HS

    • [^] # Re: Static IP

      Posté par . Évalué à 1.

      D'accord mais là je ne sais absolument pas comment faire, je ne sais pas du tout ce qu'est un plan IP…

      • [^] # Re: Static IP

        Posté par (page perso) . Évalué à 3.

        Il faut que tu prennes une adresse IP fixe qui est disponible.

        Une box se configure en se connectant en 192.168.1.1 ou 192.168.0.1 ou un truc du genre.

        Si tu nous dis si tu as une Livebox/Freebox/… on pourra t'aider, et donc tu prendras une adresse fixe pour ton PC, dans le même sous-réseau, du genre 192.168.1.23 ou 192.168.0.23

        If you choose open source because you don't have to pay, but depend on it anyway, you're part of the problem.evloper) February 17, 2014

    • [^] # Re: Static IP

      Posté par . Évalué à 1.

      Désolé, mais quand je vois ça :
      Linux est un système formidable […]
      Ça me donne des boutons… Linux n’est pas un « système » c’est un noyau.

      . « système » ne veut pas forcément dire « système d'exploitation ». C'est un terme générique ;
      . Quand je dis Linux, on peut se référer soit au seul noyau, soit à GNU/Linux et à tout ce qui l'entoure. Ça va sans dire ;
      . Le mot « système d'exploitation » PEUT désigner le seul noyau, dès lors que c'est un logiciel en place qui permet à un logiciel d'exploiter les ressources de sa machine. C'est d'ailleurs comme ça que Linux est défini dans le README à la racine de ses sources :

      WHAT IS LINUX?

      Linux is a clone of the operating system Unix, written from scratch by
      Linus Torvalds with assistance from a loosely-knit team of hackers across
      the Net. It aims towards POSIX and Single UNIX Specification compliance.

      It has all the features you would expect in a modern fully-fledged Unix,
      including true multitasking, virtual memory, shared libraries, demand
      loading, shared copy-on-write executables, proper memory management,
      and multistack networking including IPv4 and IPv6.

      C'est un peu comme les termes « unité centrale ». En principe, ça désigne le CPU. C'est par extension qu'on a utilisé la même terminologie pour désigner la machine qui le contient et sur laquelle viennent se brancher les périphériques.

      Alors, oui Linux est un noyau, et oui il est formidable parce qu’il intègre énormément de choses.
      Le noyau de Windows (NT de souvenir) n’en fait pas autant, mais c’est totalement normal.
      La différence se situe au niveau de l’architecture kernel, Linux est monolityque et le kernel de Windows est un hybrid-kernel modulaire.

      Ce n'est pas la question. Que les pilotes soient intégrés à l'intérieur ou à l'extérieur du noyau importe peu. La question était « pourquoi mon matériel pose-t-il des problèmes alors qu'il fonctionne sans problème sous Windows ? ». La réponse est : « parce que quelqu'un a fait le même travail en amont ».

      Et en ce sens, il est remarquable de voir comment le noyau Linux est capable de prendre directement et silencieusement en charge le matériel qu'il connaît. Je suis toujours impressionné par le pouvoir de détection des Knoppix, par exemple, qui recommence le tout à chaque session.

  • # des pistes

    Posté par . Évalué à 5.

    si le DHCP ne fonctionne pas, tu peux configurer l'IP en fixe sur ta machine grace au network-manager (l'icone en haut à droite qui t'indique que ca essaie de se connecter)

    dans ces reglages, active une connexion avec les infos suivantes :
    IP : 192.168.1.200 (suffisamment haut pour ne pas avoir de conflit avec d'autres postes à la maison)
    masque : 255.255.255.0
    passerelle : 192.168.1.1
    dns : 8.8.8.8

    valide et selection ce reseau dans la liste des reseaux disponibles.

    sinon :

    • plus rare, la carte eth0 n'est pas reconnue, j'avais eu a jonglé avec le windows et le linux d'un PC comme ca pour telecharger le paquet depuis le windows vers une clef usb, puis aller l'installer sur le linux depuis la clef usb.

    • wifi : à la maison j'ai activé le WPA2, certains PC ne reconnaissent meme plus le wifi (car la carte wifi ne gere pas ce protocole)

    • tu as une livebox, elle fait surement de l'IPv6 par defaut mais de maniere buggée
      il faudrait desactiver l'IPv6 de la box et voir si cela corrige le probleme du reseau filaire.

    • [^] # Re: des pistes

      Posté par . Évalué à 1.

      J'ai fait ce que vous m'avez dit, j'ai crée un réseau dans l'onglet IPv4 car cela m'étais impossible de le faire ailleurs….
      J'ai donc crée quelque chose qui fonctionne et voilà ce que j'ai:

      http://www.hostingpics.net/viewer.php?id=699057Screenshotfrom20141212133156.png

      http://www.hostingpics.net/viewer.php?id=777193Screenshotfrom20141212133242.png

      http://www.hostingpics.net/viewer.php?id=237265Screenshotfrom20141212133256.png

      Cependant je n'ai toujours pas accès a internet… Je ne sais plus quoi faire je commence a désespérer…
      Je suis aussi allé voir le site que vous m'avez indiqué mais je n'ai aucune réponse du terminal ni de rien d'autre sur la manip que j'ai suivis.

      • [^] # Re: des pistes

        Posté par . Évalué à 4.

        Bien, la 3e image montre que la carte eth0 existe et que vos reglages sont bons.

        dans un terminal, on va essayer 2 choses :

        ping -c 4 192.168.1.1 pour savoir si votre PC arrive à joindre votre box internet
        ping -c 4 8.8.8.8 pour savoir si votre PC arrive à joindre le DNS de google
        ping -c 4 linuxfr.org pour savoir si votre PC arrive à resoudre le nom linuxfr.org et à joindre la machine

        dans les 3 cas, vous devez avoir des reponses similaire à celle là (ici avec un ping vers 8.8.8.8)

        PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
        64 bytes from 8.8.8.8: icmp_seq=1 ttl=56 time=2.31 ms
        64 bytes from 8.8.8.8: icmp_seq=2 ttl=56 time=2.26 ms
        64 bytes from 8.8.8.8: icmp_seq=3 ttl=56 time=2.31 ms
        64 bytes from 8.8.8.8: icmp_seq=4 ttl=56 time=2.33 ms
        
        --- 8.8.8.8 ping statistics ---
        4 packets transmitted, 4 received, 0% packet loss, time 3004ms
        rtt min/avg/max/mdev = 2.263/2.308/2.338/0.043 ms

        on y voit dans les statistics : 4 transmis, 4 recus, 0% perdu

        • [^] # Re: des pistes

          Posté par . Évalué à 1. Dernière modification le 12/12/14 à 19:28.

          Voilà ce que j'obtiens après avoir tapé les 3 commandes. Cependant c'est assez surprenant car je ne retrouve plus le réseau (dans le network manager) que j'ai crée lorsque je branche le câble…
          Pourtant il existe bien quand je vais dans les paramètres!!

          ping -c 4 192.168.1.1
          PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
          64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=2.39 ms
          64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=2.44 ms
          64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=2.20 ms
          64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=2.22 ms

          --- 192.168.1.1 ping statistics ---
          4 packets transmitted, 4 received, 0% packet loss, time 3004ms
          rtt min/avg/max/mdev = 2.202/2.315/2.445/0.120 ms

          ping -c 4 8.8.8.8
          PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
          64 bytes from 8.8.8.8: icmp_seq=1 ttl=55 time=23.9 ms
          64 bytes from 8.8.8.8: icmp_seq=2 ttl=55 time=23.3 ms
          64 bytes from 8.8.8.8: icmp_seq=3 ttl=55 time=22.7 ms
          64 bytes from 8.8.8.8: icmp_seq=4 ttl=55 time=22.2 ms

          --- 8.8.8.8 ping statistics ---
          4 packets transmitted, 4 received, 0% packet loss, time 3005ms
          rtt min/avg/max/mdev = 22.266/23.073/23.922/0.648 ms

          ping -c 4 linuxfr.org
          PING linuxfr.org (88.191.250.176) 56(84) bytes of data.
          64 bytes from prod.linuxfr.org (88.191.250.176): icmp_seq=1 ttl=52 time=24.0 ms
          64 bytes from prod.linuxfr.org (88.191.250.176): icmp_seq=2 ttl=52 time=23.5 ms
          64 bytes from prod.linuxfr.org (88.191.250.176): icmp_seq=3 ttl=52 time=24.1 ms
          64 bytes from prod.linuxfr.org (88.191.250.176): icmp_seq=4 ttl=52 time=23.5 ms

          --- linuxfr.org ping statistics ---
          4 packets transmitted, 4 received, 0% packet loss, time 3004ms
          rtt min/avg/max/mdev = 23.556/23.821/24.124/0.282 ms

          • [^] # Re: des pistes

            Posté par (page perso) . Évalué à 3. Dernière modification le 12/12/14 à 23:12.

            Bon, alors, tu as accès à Internet. Du moins, quelque chose prétends être linuxfr.org …

            Dans un terminal/console fait un :

            wget linuxfr.org

            puis ouvre le fichier index.html dans un navigateur.

            Chez moi, en lançant la commande wget linuxfr.org j'ai:
            ```
            --2014-12-12 23:09:02-- http://linuxfr.org/
            Résolution de linuxfr.org (linuxfr.org)… 88.191.250.176
            Connexion à linuxfr.org (linuxfr.org)|88.191.250.176|:80… connecté.
            requête HTTP transmise, en attente de la réponse… 200 OK
            Taille : non indiqué [text/html]
            Sauvegarde en : « index.html »

            [ <=>           ] 93 550      --.-K/s   ds 0,08s   
            

            2014-12-12 23:09:02 (1,19 MB/s) - « index.html » sauvegardé [93550]
            ```
            Tu devrais avoir la même chose. Tu as accès à Internet.

            • [^] # Re: des pistes

              Posté par . Évalué à 3. Dernière modification le 13/12/14 à 00:41.

              À ce stade, il peut même directement ouvrir son navigateur Internet puisque les temps de réponse des pings sont cohérents et que les DNS fonctionnent correctement (l'adresse de DLFP est la bonne). Par contre, il est possible que le Network Manager lui fasse croire qu'il est toujours en mode hors-connexion. Si c'est le cas, il faudra peut-être décocher l'option « Fichiers → Travailler en mode hors connexion » (en faisant apparaître le menu en appuyant une fois sur Alt si nécessaire).

              • [^] # Re: des pistes

                Posté par (page perso) . Évalué à 1.

                Il peut éventuellement virer le paquet Network Manager.

                C'est une des premières choses que je fais lorsque je tombe sur une machine avec un problème réseau.

                • [^] # De pire en pire; problème sur problème

                  Posté par . Évalué à 1. Dernière modification le 13/12/14 à 12:34.

                  Voilà maintenant quand je démarre ubuntu:
                  Pendant le chargement trois messages apparaissent:
                  -Waiting fot network configuration
                  -Waiting up to 60 more secondes for network configuration…
                  -Booting system without full network configuration…
                  -> Là je pense: soit il manque un petit quelque chose, soit c'est foutu.

                  Ensuite quand le chargement est terminé (bien plus long que d'habitude!):
                  - L'icone du network manager a disparu et voici ce qu'il m'affiche quand je vais dans les réglages:
                  http://www.hostingpics.net/viewer.php?id=977540Screenshotfrom20141213012132.png
                  - Il réapparaît au bout de 2 min comme sortit de nul part et: il ne reconnait plus du tout mon cable ethernet, je n'ai donc plus accès au réseau que j'ai crée.
                  Avec ifconfig -a, il voit bien mon câble ethernet…
                  J'ai tapé ping -c 4 192.168.1.1 et j'ai plus rien qui passe……

                  J'ai une question cela dit:
                  - J'ai crée une IP statique, dois-je modifier le fichier /etc/network/interfaces ? si oui que dois-je mettre dedans?
                  - Ne vaut-il mieux pas que je désinstalle et réinstalle ubuntu sur mon ordinateur? J'ai peut être fait une fausse manip, qu'en pensez vous?

                  Merci encore de votre aide, je commence vraiment a désespérer et sans vous je ne serais plus quoi faire..

                  • [^] # Re: De pire en pire; problème sur problème

                    Posté par . Évalué à 3.

                    Ne vaut-il mieux pas que je désinstalle et réinstalle ubuntu sur mon ordinateur? J'ai peut être fait une fausse manip, qu'en pensez vous?

                    Non, c'est quelque chose qu'on ne fait pour ainsi dire jamais avec des distributions de Linux. Ce n'est pas de chance mais normalement, ça se dépanne. :-)

                    Avec ifconfig -a, il voit bien mon câble ethernet…

                    En fait, NetworkManager n'est pas le sous-système réseau proprement dit mais une application de plus haut niveau qui se charge de faire toutes les manips que l'on fait ici à la main quand ça commence à devenir compliqué.

                    « ifconfig » est la commande historique de gestion des interfaces elles-mêmes sur tous les UNIX ou presque depuis longtemps. L'option « -a » veut dire « all » et lui demande de présenter toutes les interfaces connues ou déclarées auprès du noyau… même si elles ne sont pas montées. Quand tu tapes « ifconfig » seul, la commande t'affiche uniquement les interfaces actives (« up »).

                    Cette commande te permet donc d'attribuer une (voire plusieurs) adresses à ton interface réseau, de l'activer ou la désactiver, de lui attribuer un masque réseau, et de faire quelques réglages qui lui sont propres. Pour avoir une connexion pleinement active quand on monte tout à la main, il faut également ajouter une passerelle par défaut vers ta box avec « route » et ajouter les DNS dans « /etc/resolv.conf ». Tu peux également utiliser la commande « ip » qui essaie de tout rassembler sous une même banière.

                    NetworkManager est très appréciable quand il marche correctement mais quand il pose problème, il devient pénible parce qu'il a tendance à redescendre les cartes réseau qu'on a monté soi-même s'il ne les connaît pas. :-( Il peut donc être utile de l'éteindre complètement le temps de faire tes manipulations. Je ne sais pas si ta distribution est déjà sous SystemD ou pas encore (il me semble que non) mais tu peux essayer ceci (en root)

                    systemctl stop NetworkManager.service
                    ifconfig eth0 192.168.1.200 netmask 255.255.255.0 up
                    route add default gw 192.168.1.1 eth0
                    echo "nameserver 8.8.8.8" >> /etc/resolv.conf

                    Ces commandes servent à faire à la main ce que tu configures en principe dans les panneaux de NetworkManager qui, lui ensuite, se chargent de passer les mêmes appels directement au système. Tu peux refaire le ping

                    ping -c4 linuxfr.org

                    Si ça passe, essaie de voir si tu peux surfer avec ton navigateur.
                    Évidemment, tout ce que l'on a saisi ci-dessus disparaîtra au redémarrage. D'où l'importance d'avoir un gestionnaire qui fonctionne.

                    Merci encore de votre aide, je commence vraiment a désespérer et sans vous je ne serais plus quoi faire..

                    Et bravo à toi pour ta persévérance ! En principe, les Ubuntu et autres distribs sont au point côté réseau depuis longtemps. Ça fait bien longtemps que je n'avais plus rencontré ce genre de bug technique lors d'une installation initiale. Ça vaut le coup de ne pas abandonner maintenant car lorsque ce sera réglé, ton système restera stable pendant de nombreuses années. Tu auras l'occasion de bien en profiter, au point de ne plus pouvoir t'en passer. :-)

                    • [^] # Re: De pire en pire; problème sur problème

                      Posté par . Évalué à 2. Dernière modification le 13/12/14 à 17:41.

                      Au rapport:
                      Alors bonne nouvelle: En me connectant j'ai pas eu le droit au "booting system without full network config"
                      De plus j'ai eu de suite accès au réseau que j'ai crée l'autre jour! Donc jusqu'ici tout vas bien.
                      Mais voilà j'ai lancé le navigateur pour voir:
                      http://www.hostingpics.net/viewer.php?id=325499Screenshotfrom20141213171858.png

                      Ce qui est dingue c'est que je suis connecté! On le voit bien en haut de la photo.

                      Par contre toujours pas d'accès a internet. De plus voici le rapport des commandes que j'ai tapé:

                      systemctl stop NetworkManager.service
                      systemctl: command not found

                      ifconfig eth0 192.168.1.200 netmask 255.255.255.0 up
                      pas de rep

                      route add default gw 192.168.1.1 eth0
                      pas de rep

                      echo "nameserver 8.8.8.8" >> /etc/resolv.conf
                      pas de rep

                      ping -c4 linuxfr.org
                      ping: unknown host linuxfr.org
                      root@nicolas-X750LN:/home/nicolas# ping -c4 192.168.1.1
                      PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
                      From 192.168.1.200 icmp_seq=1 Destination Host Unreachable
                      From 192.168.1.200 icmp_seq=2 Destination Host Unreachable
                      From 192.168.1.200 icmp_seq=3 Destination Host Unreachable
                      192.168.1.1 ping statistics
                      4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2999ms
                      pipe 4

                      et pour finir j'ai quand même essayé ceci:
                      wget linuxfr.org
                      --2014-12-13 17:10:14-- http://linuxfr.org/
                      Resolving linuxfr.org (linuxfr.org)… failed: Name or service not known.
                      wget: unable to resolve host address ‘linuxfr.org’

                      • [^] # Re: De pire en pire; problème sur problème

                        Posté par . Évalué à 2.

                        Bizarre cette histoire… ifconfig -a à ce stade il raconte quoi ?
                        Pour vérifier que la connexion physique est ok tu as la commande ethtool qui peut être installée avec sudo apt-get install ethtool. Puis ethtool ethX pour récupérer des infos.
                        Le fait que un coup ça passe et pas l'autre avec tous les paramètres en durs me fait penser que tu as peut être un soucis au niveau du câblage (mauvaise connexion).

                      • [^] # Re: De pire en pire; problème sur problème

                        Posté par . Évalué à 2.

                        C'est vraiment étrange. Comme dit juste au dessus, on ne peut pas écarter totalement la défectuosité de ton câble même si, comme tu l'as indiqué, ça fonctionne sous Windows. Mais je pense plutôt qu'il s'agit de deux systèmes mal configurés qui entrent en concurrence.

                        systemctl stop NetworkManager.service
                        systemctl: command not found

                        Ok, ta distrib n'utilise pas encore systemd. Ça fera un troll de moins. :-)

                        ifconfig eth0 192.168.1.200 netmask 255.255.255.0 up
                        pas de rep

                        Le fait de ne pas avoir de réponse est bon signe avec une commande DOS ou UNIX. Ça indique qu'elle s'est exécutée correctement, sauf si on attend d'elle qu'elle nous renvoie justement quelque chose à l'écran ou qu'elle est conçue (ou configurée) pour rester muette.

                        Il est possible que ta box y mette de la mauvaise volonté également.

                        En principe, ça se dépanne assez facilement mais par forum interposé, en étant débutant et sans avoir accès au Net, ça risque effectivement de prendre du temps. Il faut savoir également que, comme tous les systèmes, ton Ubuntu fait l'objet de mises à jour qui sont téléchargées d'un coup après son installation initiale et qui, en principe, résolvent toutes ces coquilles.

                        Si tu réinstalles, je te conseille de le faire en laissant ton câble Ethernet branché dès le départ. Le système te demandera peut-être de configurer le réseau juste avant de lancer l'installation mais il sera alors en mesure d'aller directement chercher ce qui lui manque.

                        Dernière question : tu es dans quelle région ? Peut-être existe-t-il un LUG à proximité de chez toi avec des gens prêts à t'aider physiquement.

                        • [^] # Re: De pire en pire; problème sur problème

                          Posté par . Évalué à 1.

                          D'accord je vois, il va me falloir une aide physique et je m'en doutais. à la limite je préfère ça plutôt que de bidouiller à droite à gauche sans comprendre ce que je fais vraiment.

                          J'ai une connaissance avec qui j'ai parlé hier qui est "informaticien", il s'y connait pas mal et veut m'aider, le problème c'est qu'il ne veut pas résoudre le problème, il veut tout désinstaller et me mettre sur Debian ou alors me créer une "virtual box" sur Windows. Il est complètement borné et ne veut pas faire autre chose parce que, je cite "il a la flemme et pas que ça a faire" et "Ubuntu c'est de la merde"…

                          Je précise que je me sers d'Ubuntu parce que c'est plus accessible pour programmer puis avec les commandes Unix et toute le données que je traite c'est bien plus rapide. Je fais des simulations physique et de la modélisation informatique, on programme en C et les plus âgés en Python; on se sert de Mac Os et Ubuntu mais jamais de Windows, même pas pour envoyer un mail!

                          Donc sinon j'habite en région parisienne dans le 91 et je travaille à la faculté des sciences fondamentales à Evry.
                          Où puis-je trouver de l'aide dans le coin?

                          • [^] # Re: De pire en pire; problème sur problème

                            Posté par . Évalué à 2.

                            Donc sinon j'habite en région parisienne dans le 91 et je travaille à la faculté des sciences fondamentales à Evry.

                            Je n'ose y croire. J'habite Évry également. Je t'envoie un message privé.

                            • [^] # Re: De pire en pire; problème sur problème

                              Posté par . Évalué à 1.

                              Ha oui en effet c'est surprenant!!
                              Je vous donne directement mon adresse mail: nicolas.gattoni@ens.univ-evry.fr

                              • [^] # Re: De pire en pire; problème sur problème

                                Posté par . Évalué à 2.

                                Hmm. Les messages privés ne sont plus disponibles. :-(

                                Merci d'avoir laissé une adresse. L'e-mail est parti. :-)

                              • [^] # Re: De pire en pire; problème sur problème

                                Posté par . Évalué à 4.

                                Juste une remarque hors-sujet.

                                Lorsque tu postes une adresse e-mail sur un site accessible publiquement c'est une bonne idée de l' « obfusquer », histoire de compliquer le boulot des robots qui récupèrent ces adresses pour t'envoyer des spams…

                                Typiquement tu aurais pu écrire : nicolas POINT gattoni AT ens POINT univ-evry POINT fr

                                J'aurais même tendance à dire qu'il faut être encore plus créatif car les robots les plus évolués doivent réussir à récupérer une adresse « planquée » de cette manière…

                                Par exemple : nicolas ### gattoni CHEZ ens . univ TIRET evry __ fr (remplacer ### et __ par un point et supprimer les espaces)

                                C'est très chiant j'avoue mais le spam l'est encore plus…

                                On peut aussi créer une image avec un dispositif anti-OCR (comme pour un CAPTCHA)…

          • [^] # Re: des pistes

            Posté par . Évalué à 2.

            le 12/12 à 19h24, tu avais acces à internet (vu que les ping pouvaient aller à l'exterieur)

            puis tu as modifié quelques choses
            et maintenant cela ne fonctionne plus
            alors que cela fonctionnait…

            donc il te suffit de reparer ce que tu as cassé ;)

            et si c'etait une fresh installation sans rien dedans, et que tu as enlevé un paquet critique comme le network-manager qui te donne acces au reseau, le plus simple est en effet de reinstaller, pour repartir sur une base neuve, sans bidouillage.

            • [^] # Re: des pistes

              Posté par . Évalué à 4.

              Oui j'en suis bien conscient! C'est donc pour cela que j'ai besoin d'une aide direct et physique car je ne sais pas ce que je fais.
              Grace à obsidian nous allons réparer le problème.
              Je vous tiens au courant pour vous expliquer ce qu'on aura fait pour régler le problème, cela pourra servir à quelqu'un d'autre je l'espère

              • [^] # Re: des pistes

                Posté par (page perso) . Évalué à 2.

                Et sinon, pour ton information, Ubuntu est basé sur Debian.
                Donc, tu n'aurais pas vu une grande différence.

                Si quelqu'un préfère t'installer Debian… parce qu'il préfère Debian (idem pour moi), ça se comprends.

                Au taf, mon poste est sous Ubuntu, mais on administre des serveurs sous Debian.
                Chez moi et sur mes serveurs privés, c'est Debian.

                Je m'intéresse à *BSD, mais je n'ai pas encore pris le temps d'essayer, et c'est bien plus différent de Debian.

                A+

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.