Forum Linux.débutant Probléme d'installation avec Apt-get ou Aptitude

Posté par . Licence CC by-sa
Tags : aucun
2
23
mai
2013

Bonjour à tous,

Malheureusement j'ai cassé outil d'installation (Apt-get ou aptitude) sur mon serveur Debian 6.

Voici le message d'erreur

root@servxxxx:/var/log# aptitude
aptitude: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by aptitude)
aptitude: /usr/lib/libstdc++.so.6: version
GLIBCXX_3.4.9' not found (required by aptitude)
aptitude: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by /usr/lib/libapt-pkg.so.4.10)
aptitude: /usr/lib/libstdc++.so.6: version
GLIBCXX_3.4.9' not found (required by /usr/lib/libapt-pkg.so.4.10)
aptitude: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by /usr/lib/libept.so.1)
aptitude: /usr/lib/libstdc++.so.6: version
GLIBCXX_3.4.11' not found (required by /usr/lib/libept.so.1)
aptitude: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by /usr/lib/sse2/libxapian.so.22)
aptitude: /usr/lib/libstdc++.so.6: version
GLIBCXX_3.4.11' not found (required by /usr/lib/sse2/libxapian.so.22)
aptitude: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libboost_iostreams.so.1.42.0)

Les infos concernant mon serveur.
root@servxxxxx:/# uname -a
Linux servlibre 2.6.32-5-686-bigmem #1 SMP Sun Sep 23 10:27:25 UTC 2012 i686 GNU/Linux

source.list
deb http://ftp.fr.debian.org/debian/ squeeze main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze main contrib non-free

deb http://security.debian.org/ squeeze/updates main contrib non-free
deb-src http://security.debian.org/ squeeze/updates main contrib non-free

deb http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free
deb-src http://ftp.fr.debian.org/debian/ squeeze-updates main contrib non-free

deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib

est-ce que quelqu'un peut m'aider svp..
Merci

  • # apt-get

    Posté par (page perso) . Évalué à 1.

    essaye :
    # apt-get install gcc

    wind0w$ suxX, GNU/Linux roxX!

    • [^] # Re: apt-get

      Posté par (page perso) . Évalué à 1.

      il est fort probable qu' apt-get génère la même erreur

    • [^] # Re: apt-get

      Posté par . Évalué à 1.

      Merci pour votre réponse..

      apt-get ne fonctionne pas sur mon serveur.
      donc j'ai téléchargé le package gcc_4.4.5-1_i386.deb

      voici le résultat
      root@servlibre:/tmp# dpkg -i gcc_4.4.5-1_i386.deb
      (Reading database … 160678 files and directories currently installed.)
      Preparing to replace gcc 4:4.4.5-1 (using gcc_4.4.5-1_i386.deb) …
      Removing old gcc doc directory.
      Unpacking replacement gcc …
      Setting up gcc (4:4.4.5-1) …
      Processing triggers for man-db …
      root@servlibre:/tmp# apt-get update
      apt-get: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.9' not found (required by apt-get)
      apt-get: /usr/lib/libstdc++.so.6: version
      GLIBCXX_3.4.11' not found (required by apt-get)
      apt-get: /usr/lib/libstdc++.so.6: version GLIBCXX_3.4.11' not found (required by /usr/lib/libapt-pkg.so.4.10)
      apt-get: /usr/lib/libstdc++.so.6: version
      GLIBCXX_3.4.9' not found (required by /usr/lib/libapt-pkg.so.4.10)

      • [^] # Re: apt-get

        Posté par (page perso) . Évalué à 0. Dernière modification le 23/05/13 à 16:03.

        tu as récupéré la même version 4:4.4.5-1 de squeeze du paquet.
        essaye de récupérer la version 4:4.7.2-1 de wheezy : http://packages.debian.org/fr/wheezy/gcc
        installe avec dpkg … il te faudra peût-être récupérer des dépendances aussi : cpp, gcc-4.6, gcc-4.7 … tu verras au fur et à mesure si dpkg te retourne des erreurs.

        squeeze est la old-stable, la nouvelle stable est wheezy je te suggère fortement de modifier ton source.list (squeeze -> wheezy) dès que ton souci avec apt/aptitude sera réglé.

        Pour tes deux dernières ligne "sarge" regarde si il n'y a pas plus récent

        wind0w$ suxX, GNU/Linux roxX!

        • [^] # Re: apt-get

          Posté par . Évalué à 0.

          tes deux dernières ligne "sarge"

          Qu'utilise tu en sarge pour les avoir garder?

          Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

        • [^] # Re: apt-get

          Posté par . Évalué à 1.

          Peut-être prendre les choses une par une. En attendant la migration Squeeze -> Wheezy (à faire dans un environnement stable et avec du temps devant soi), je m'amuserais pas à introduire des paquets Wheezy pour résoudre une problème, sauf à être certain de ce que je fais.

          Dans le log, il doit y avoir une trace des opérations précédentes, aussi.

      • [^] # Re: apt-get

        Posté par . Évalué à 2.

        Aucun rapport avec gcc, le paquet à réparer est libstdc++6.

        l'installer avec dpkg devrait fonctionner.

  • # rechercher la cause

    Posté par . Évalué à 6.

    en gros, que faisais-tu avant que ca deconne ?

    on peut imaginer que tu as desinstallé des fichiers, supprimé des paquets.
    en ce cas il faut remettre dans l'etat precedent (à partir d'un backup par exemple)

    des symptomes, on en deduit qu'il manque des fichiers ou qu'il ne les trouve pas.
    as-tu regardé si les fichiers existent toujours ?

    ls -l /usr/lib/libstdc++.so.6*

    chez moi ca donne :

    ls -l /usr/lib/libstdc++.so.6*
    lrwxrwxrwx 1 root root 19 4 mai 2011 /usr/lib/libstdc++.so.6 -> libstdc++.so.6.0.13
    -rw-r--r-- 1 root root 1043976 15 nov. 2010 /usr/lib/libstdc++.so.6.0.13

    dpkg, s'il fonctionne permet de savoir d'ou vient le fichier

    dpkg -S /usr/lib/libstdc++.so.6.0.13
    libstdc++6: /usr/lib/libstdc++.so.6.0.13

    donc au pire il faut reinstaller ce paquet

    si dpkg fonctionne, à partir du .deb telecharger sur les depots debian
    si dpkg ne fonctionne pas, en decompressant le .deb, puis en recopiant l'aborescence sur ta machine

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.