Forum Linux.débutant service Kibana

Posté par . Licence CC by-sa
1
5
fév.
2016
    Bonjour je suis un débutant qui ne travail par sur Linux ... :(  (La je suis sur centos 7), j'ai installé Elasticsearch Logstash et Kibana4.1.4.

    Alors quand je tape la commande "service kibana restart" juste après le changement de mon kibana.yml il me marque 
    root@localhost init.d]# service kibana restart
    env: /etc/init.d/kibana: Aucun fichier ou dossier de ce type

    Or dans mon dossier init.d le script est présent ... :/

    [root@localhost init.d]# ls
    elasticsearch  functions  kibana  logstash  netconsole  network  README

    voici le script de kibana présent de init.d : 

        #!/bin/sh
        #
        # kibana -- startup script for kibana4
        #
        # chkconfig: - 85 15
        # processname: kibana
        # pidfile: /var/run/kibana.pid
        # description: Kibana is a webui to visualize data
        #
        ### BEGIN INIT INFO
        # Provides: kibana
        # Required-Start: $local_fs $remote_fs $network
        # Required-Stop: $local_fs $remote_fs $network
        # Default-Start: 2 3 4 5
        # Default-Stop: 0 1 6
        # Short-Description: start and stop kibana
        ### END INIT INFO
        #
        #
        . /etc/init.d/functions

        PIDFILE="/var/run/kibana.pid"
        KIBANA_DIR="/opt/kibana/"

        start() {
                echo -n "Starting Kibana Daemon: "
                if [ -f $PIDFILE ]; then
                        PID=`cat $PIDFILE`
                        echo Kibana already running: $PID
                        exit 1;
                else
                        cd $KIBANA_DIR
                        PID=`./bin/kibana >/dev/null 2>&1 & echo $! > $PIDFILE`
                        echo `cat $PIDFILE`
                fi

        }

        stop() {
                echo -n "Shutting down Kibana Daemon: "
                echo
                killproc kibana
                echo
                rm -f /var/lock/subsys/kibana
                return 0
        }

        case "$1" in
            start)
                start
                ;;
            stop)
                stop
                ;;
            status)
                status kibana
                ;;
            restart)
                stop
                start
                ;;
            *)
                echo "Usage:  {start|stop|status|restart}"
                exit 1
                ;;
        esac
        exit $?

    Pourriez vous m'aider s'il vous plait .. 
    Merci

    #note j’accède bien a mon localhost:9200 de elasticsearch mais mon localhost:5601 impossible     d'y accéder .. :/        
  • # Droit

    Posté par (page perso) . Évalué à 2.

    Le fichier est bien exécutable ?

    chmod a+rx /etc/init.d/kibana

  • # oui il est exécutable

    Posté par . Évalué à 1.

    Oui le fichier est bien exécutable , de-plus j'ai vérifié les propriéllétés de celui-ci et dans les permission : exécution : la case est cocher pour autoriser l'exécution du fichier comme un programme

  • # j'ai du nouveau !

    Posté par . Évalué à 1.

    J'ai testé la commande systemctl restart kibana.Service ; la il me propose de rentrer le mot e passe, je tape celui de root. ensuite un message d’erreur me dit de consulter le fichier de log pour plus d'information sur l’erreur.

    Celui m'indique ceci … :
    unit kibana.service entered failer state.
    kibana.service failed
    Unregistered Authentication Agent for uni-process:5307:86

    Faut-il définir un utilisateur pour kibana ? comment faire ..? :/

    • [^] # Re: j'ai du nouveau !

      Posté par . Évalué à 1. Dernière modification le 05/02/16 à 15:08.

      DU nouveau encore .. :/

      ● kibana.service - LSB: start and stop kibana
      Loaded: loaded (/etc/rc.d/init.d/kibana)
      Active: failed (Result: exit-code) since ven. 2016-02-05 15:02:28 CET; 5min ago
      Docs: man:systemd-sysv-generator(8)
      Process: 7373 ExecStart=/etc/rc.d/init.d/kibana start (code=exited, status=2)

      févr. 05 15:02:28 localhost.localdomain kibana[7373]: --restricted
      févr. 05 15:02:28 localhost.localdomain kibana[7373]: --verbose
      févr. 05 15:02:28 localhost.localdomain kibana[7373]: --version
      févr. 05 15:02:28 localhost.localdomain kibana[7373]: Options du shell :
      févr. 05 15:02:28 localhost.localdomain kibana[7373]: -irsD ou -c commande ou -O shopt_option (invocation seulement)
      févr. 05 15:02:28 localhost.localdomain kibana[7373]: -abefhkmnptuvxBCHP ou -o option
      févr. 05 15:02:28 localhost.localdomain systemd[1]: kibana.service: control process exited, code=exited status=2
      févr. 05 15:02:28 localhost.localdomain systemd[1]: Failed to start LSB: start and stop kibana.
      févr. 05 15:02:28 localhost.localdomain systemd[1]: Unit kibana.service entered failed state.
      févr. 05 15:02:28 localhost.localdomain systemd[1]: kibana.service failed.

      • [^] # Re: j'ai du nouveau !

        Posté par . Évalué à 1.

        Bonjour,

        J'ai un peu bricolé avec es…

        Que te donne la commande ?

        $ sudo journalctl -u kibana.unit
        C'est l'utilitaire de lecture des logs de systemd.

        Tu peux aussi regarder du côté des logs de kibana :

        $ sudo tail /var/log/kibana/errors.log
        Bonne recherches !

        • [^] # Re: j'ai du nouveau !

          Posté par . Évalué à 1.

          LA commande journalctl -u kibana.unit me donner ceci comme réponse :

          -- Logs begin at lun. 2016-02-08 09:54:34 CET, end at lun. 2016-02-08 10:00:28 CET. --
          ensuite tail /var/log/kibana/errors. log me donne ceci :

          Et pour la commande : tail /var/log/kibana/errores.log :

          je n'ai aucun repertoire kibana dans /var/log …. :/

          Excusez moi si je fais mal je suis députant :/

      • [^] # Re: j'ai du nouveau !

        Posté par . Évalué à 2. Dernière modification le 05/02/16 à 23:57.

        Docs: man:systemd-sysv-generator(8)

        Ne cherches plus, on a trouvé le coupable …

        (désolé, trop tentant …).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.