Forum Linux.débutant thunderbird et lien dans les mails

Posté par .
Tags : aucun
1
22
mai
2009
Bonjour,

J'ai un petit soucis qui devient agaçant à la longue.
J'utilise thunderbird pour lire mes mails et quand je clique sur un lien j'ai systématiquement ce message "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Pouvez-vous me dire comment modifier cela ?

Merci.
  • # Firefox planté

    Posté par . Évalué à 2.

    Ça veut dire que Thunderbird appelle Firefox pour en passant le lien en paramètre, comme tu le ferais depuis la ligne de commande. Si toutefois, au lancement, Firefox s'aperçoit qu'une instance de lui-même est déjà lancée, il va transmettre la demande à cette instance et quitter. Ainsi, c'est toujours le même navigateur qui gère tous tes liens.

    Toutefois, si Firefox plante, il n'a plus de fenêtre mais le processus existe toujours, sans répondre. Il faut alors tuer toutes tes instances de Firefox encore en arrière plan.

    Fais un « ps aux | grep firefox » depuis une console et utilise kill pour les éliminer. Un killall firefox ne fonctionnera pas ici à cause du chemin d'accès complet dans le nom du processus.
    • [^] # Re: Firefox planté

      Posté par (page perso) . Évalué à 1.

      Mais un pkill -9 firefox devrait marcher. Voire même un pkill fox.
    • [^] # Re: Firefox planté

      Posté par . Évalué à 2.

      Le hic est que Firefox n'est pas planté. Si dans le même temps j'appelle Firefox en ligne de commande en fournissant une url je n'ai pas ce message d'erreur.

      N'y a-t-il pas une option dans Thunderbrid pour voir avec quels paramètres est lancé Firefox lorsque je clique sur un lien ?

      Merci.
      • [^] # [RÉSOLU] Re: Firefox planté

        Posté par . Évalué à 6.

        En fait mon Thunderbird est lancé avec l'option no-remote (pour pouvoir en lancer plusieurs simultanément avec des profils différents).

        Du coup Firefox est appelé avec la variable d'environnement MOZ_NO_REMOTE.

        Pour contourner le problème j'ai créé le script /usr/local/bin/start-firefox:

        #!/bin/bash
        unset MOZ_NO_REMOTE
        /usr/bin/firefox $*


        et dans l'éditeur de configuration de Thunderbird j'ai créé la clé network.protocol-handler.app.http avec la valeur /usr/local/bin/start-firefox.
    • [^] # Re: Firefox planté

      Posté par (page perso) . Évalué à 2.

      killall firefox ne fonctionnera pas ici à cause du chemin d'accès complet dans le nom du processus.
      ??!
      Ca fonctionne chez moi (tm):
      # killall firefox-bin

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.