Forum Linux.général Choisir l'entrée du futur démarrage

Posté par (page perso) . Licence CC by-sa
Tags : aucun
3
9
juil.
2014

Bonjour,

Jadis avec Mandrake, quand on relançait le système, on pouvait choisir à l'avance sur quel entrée du bootloader la machine devait redémarrer. C'était bien pratique, pas besoin de rester devant l'écran le temps du reboot (pour, au hasard, choisir Windows). Et donc possibilité d'aller changer l'eau du canari par exemple.

Pourquoi ne voit-on plus cette option sur les distribs récentes ?

Merci.

  • # grub-reboot

    Posté par . Évalué à 7.

    La documentation de Debian parle de grub-reboot avec en argument le petit numéro correspondant au système ou noyau sur lequel tu veux amorcer au prochain redémarrage.

    Donc voilà, ça existe toujours, a priori (pas testé, j'ai pas le nécessaire sous la main, là.)

  • # Ça marche toujours

    Posté par (page perso) . Évalué à 4.

    Sous Mageia 4 / KDE 4, j'ai toujours cette possibilité

    • [^] # Re: Ça marche toujours

      Posté par (page perso) . Évalué à 1.

      Donc ça dépendrait de l'environnement de bureau ? Parce que je suis aussi sous Mageia mais avec Mate je n'ai pas d'option au redémarrage.

      • [^] # Re: Ça marche toujours

        Posté par . Évalué à 3.

        D'après mes souvenirs lorsque j'utilisais KDE du temps de la version 3, la fonctionnalité recherchée n'était disponible seulement si on utilisait KDM comme gestionnaire de connexion.
        Est-ce que c'est toujours le cas ? Est-ce compatible avec grub/grub2 ? Je ne sais pas.

        • [^] # Re: Ça marche toujours

          Posté par (page perso) . Évalué à 2.

          Sous Gnome 3 (et Mageia 4), je n'ai pas l'option par défaut lorsque je décide de rebooter, même si j'imagine que cela doit être possible d'en disposer (je n'ai pas cherché).
          Sous KDE (et Mageia 4), l'option de choix de boot est proposée et correspond au nom indiqué dans grub et je crois que cela fonctionne aussi avec grub2 (installé sur le netbook d'une personne au premier samedi du libre à la Villette).

  • # grub & options

    Posté par . Évalué à 2.

    http://askubuntu.com/questions/148662/how-to-get-grub2-to-remember-last-choice

    Je cite:

    'Put the following in /etc/default/grub:

    GRUB_DEFAULT=saved
    GRUB_SAVEDEFAULT=true

    Then run:

    sudo update-grub'

    Et le choix que tu fais est préservé.

    • [^] # Re: grub & options

      Posté par . Évalué à 5.

      C'est bien de donner cette méthode mais c'est pas exactement ce que l'auteur souhaitait faire ;)

      • [^] # Re: grub & options

        Posté par . Évalué à 1.

        Tu as peut-être des sous-entrées?
        Cela dépend de la version de Grub2.
        Problème résolu de la manière suivante sur debian jessie et sid:
        installation de grub2-2.02-beta2-10
        Pour avoir la liste de toutes les entrées sans sous-menu
        /etc/default/grub
        GRUB_DISABLE_SUBMENU="y"

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.