Forum Linux.général Cas d'utilisation : N'autoriser que firefox à sortir sur les ports HTTP(S)

Posté par (page perso) . Licence CC by-sa
4
21
juil.
2015

Bonjour forum,

Denis Szalkowski pense qu'on ne peut pas n'autoriser que firefox à sortir sur les ports 80 et 443 .

Après recherche rapide, j'ai l'impression que la meilleure solution serait de combiner une isolation en cgroup (grâce à systemd ?) et un filtrage meta cgroup grâce à nftables. Je n'ai jamais fait cela et n'ai pas le temps aujourd'hui.

Points bonus : Je soupçonne qu'une notification graphique XDG correspondant au rejet d'une connexion sortante avec des informations concernant l'application concernée (...)

Forum Linux.général Partage samba freebox en lecture seule même si monter rw

Posté par (page perso) . Licence CC by-sa
Tags :
1
16
juil.
2015

bonjour,

j'avais cette ligne dans mon /etc/fstab pour monter le partage windows du freebox server

//192.168.1.254/Disque\040dur /media/freebox cifs _netdev,rw,users,iocharset=utf8,uid=1000,gid=1000,sec=none,file_mode=0777,dir_mode=0777,noauto 0 0
Ca marchait très bien jusqu'à avant hier.

Je peux toujours faire le montage, mais je ne peux rien y écrire. Pourtant mount me dit bien que le montage est en rw.

Un simple touch truc me retourne 'permission non accordée' que ca soit en root ou pas.

Donc je comprends pas.

Est-ce que c'est une protection à la (...)

Forum Linux.général slitaz 5 plus lent que 4.0 (video saccadée)

Posté par . Licence CC by-sa
Tags : aucun
1
13
juil.
2015

Bonjour, j'ai slitaz 4 installé sur mon eeepc 900 MHz et 1 Go de ram il est capable de lire 5 vidéos en simultané alors que slitaz 5-RC1, RC2 ou RC3 n'est pas capable d'en lire une seule sans saccade, le processeur tourne à fond et si je met en plein écran ça freeze.
Je tient absolument à la version 5 car c'est la seule que j'arrive à installer sur un vieux laptop nec versa C200 1,2 GHz 256 Mo

(...)

Forum Linux.général PC portable ASUS bruyant

Posté par . Licence CC by-sa
Tags : aucun
0
13
juil.
2015

Bonjour,

J'ai actuellement un gros problème avec un PC portable ASUS que je viens d'acquérir.
C'est le modèle K401-LB avec un processeur intel corei5 5200U a 2.2 GHZ.

Dès que je vais sur Linux (mint 17.2 bureau mate), le PC se met à faire beaucoup de bruit.
Je suspecte le fait que le ventilateur du cpu tourne à sa vitesse maximum alors que le processeur est à peine à 42 degrés.

J'ai essayé aussi avec Ubuntu et j'ai aussi ce (...)

Forum Linux.général Restauration Données

Posté par . Licence CC by-sa
1
9
juil.
2015

Bonjour à tous,

Voici mon problème :

Je possède un NAS Buffalo LS-WXL Series WX4 avec 2 HDD Seagate Barracuda 2000Gb en RAID 0. Malheureusement le disque 1 a craché et je ne sais pas si je peux récupérer mes données.

J'ai entendu dire qu'il y avait peut être une solution avec Linux et le système de fichier XFS mais je ne sais pas du tout comment cela s'utilise.

Pouvez-vous m'aider?

Merci d'avance.

Ichigo

Forum Linux.général Framebuffer

Posté par . Licence CC by-sa
Tags :
2
8
juil.
2015

Bonjour,

dans le cadre de notre projet, nous avons besoin de faire de l'affichage d'image très rapidement sur un écran servant à faire de la calibration de caméra.

Pour faire simple :
- nos caméras sont dans le noir, au dessus de l'écran de calibration (rétroéclairage éteint).
- les caméras acquièrent en permanence
- on affiche l'image à l'écran (les cristaux LCD de l'écran changent)
- on allume le rétroéclairage de l'écran un laps de temps nécessaire à la mesure (...)

Forum Linux.général Forcer la résolution d'un écran

Posté par . Licence CC by-sa
Tags : aucun
3
6
juil.
2015

Bonjour,

nous travaillons actuellement avec des écrans HD (1920x1080) sur nos machines.

Nous avons eu des cas où des écrans ne répondaient par sur le canal DDC, résultat un affichage 800x600.

En tapant xrandr, on voit bien que l'écran ne peut que faire du 800x600.

J'ai essayé de forcer la résolution via les commandes classiques xrandr :
- cvt 1920 1080
- xrandr --newmode …
- xrandr --addmode
- xrandr --output … --mode …

Mais rien à faire. Impossible de (...)

Forum Linux.général Gnome, alignement à droite

Posté par . Licence CC by-sa
Tags : aucun
1
6
juil.
2015

Bonjour,

Je suis passé de XFCE à gnome 3, sacré changement ! J'ai un petit soucis. J'utilise en fait l'extension Dash to dock et j'ai également affiché les icones sur le bureau ce qui fait que le dock passe sur les icones. J'ai cherché une astuce pour aligner automatiquement mes icones a droite mais je ne trouve rien du tout.

Vous avez une idée ? Merci pour votre aide !

Forum Linux.général Utiliser la carte graphique NVIDIA et la carte INTEL intégrée

Posté par . Licence CC by-sa
Tags : aucun
0
30
juin
2015

Bonjour,

J'utilise Linux Mint 17.1 sur un PC fixe. J'ai un Intel Core i5-4570s, une carte mère H97M-ITX et une carte graphique Nvidia GeForce GTX 960. J'ai 3 écrans dont un uniquement VGA.

Je cherche à faire fonctionner mes trois écrans, 2 connectés à la carte graphique et 1 connecté à la carte mère.
Pour l'instant je n'ai que ceux de la carte graphique qui fonctionne, impossible de faire fonctionner celui branché sur la carte mère. Avant d'avoir ma carte (...)

Forum Linux.général Test réseau: adressage ip

Posté par . Licence CC by-sa
Tags : aucun
1
29
juin
2015

Bonjour,

Je cherche à faire une manipe wifi un peu tordue qui consiste à générer du trafic de brouillage wifi à partir d'un seul Raspberry Pi utilisant iperf.
Le but est d'utiliser le rapsi à la fois en tant qu'AP et client, en utilisant deux dongles wifi connectés sur deux ports usb du même raspi.
Les configurations AP et client fonctionnent bien (le client s'associe bien à l'ap) mais le problème est, comme je m'y attendais, que le trafic ip (...)

Forum Linux.général création d'un installeur pour tout système linux

Posté par . Licence CC by-sa
Tags : aucun
1
26
juin
2015

Bonjour,
Dans le cadre de mon stage, je vais prochainement avoir à faire un installeur pour le logiciel que ma boite développe. Je ne vais bien sur pas vous demander de le faire à ma place, je cherche juste un bon tuto.

L'installateur doit pouvoir tourner sous à peu prêt n'importe quoi (Ubuntu, Debian, Rhel, BSD, Windows, Mac, …). Pour Mac et Windows, je verrais plus tard et sur d'autre forum, c'est pas le plus pressé. La solution n'a pas (...)

Forum Linux.général Parametrage openwrt derrière une box [résolu]

Posté par . Licence CC by-sa
Tags : aucun
0
24
juin
2015

Bonjour à vous,

Je dispose d'un routeur tp-link avec Openwrt (Barrier Breaker 14.07 / LuCI Trunk) dont le wan est connecté à une box en mode routeur.

En ipv4 tout fonctionne bien [hormis bien sûr la réflexion de me dire que c'est du nat]

l'avantage pour moi (temporairement) est d'avoir un firewall plus élaboré que celui de la box ---> ipv4 ok

La ou je rencontre une difficulté se situe au niveau de l'ipv6.

Sur le lan du routeur que (...)

Forum Linux.général MySQL - oom killer

Posté par . Licence CC by-sa
Tags :
0
17
juin
2015

Bonjour à tous,

Je vous sollicite à nouveau pour un problème relativement complexe.

Samedi matin j'ai eu un "too many connection" bloquant mon applicatif sur MySQL (version = 5.5.40).
Mon max_connections est à 350 et rien n'explique encore une telle anomalie hormis un 'optimize' qui tournait et qui a peut être bloqué plusieurs bots.

J'ai donc killé tous les bots + toutes les sessions MySQL et nous étions repartis.

Mardi matin (hier donc), j'ai eu la désagréable surprise de constater (...)

Forum Linux.général Décrypter une partition luks au démarrage avec grub Archlinux

Posté par . Licence CC by-sa
Tags : aucun
0
10
juin
2015

Bonjours a toute la communauté linux

-Je cherche à déchiffre une partition luks Scindé en LVM qui contient la Swap et le système !
on va l'appeler "sda1"

-Je voudrais que sda1 s'ouvre avec un fichier clé !
on va appelé cette clé " Cle-arch"

-je voudrais que cette clé soit dans une partition crypter luks !
on va appeler cette partition "sda2"

donc j'aimerais que Grub va cherché ce fichier clé qui ce trouve dans sda2 pour décrypter la partition sda1
dans (...)

Forum Linux.général Probléme de metric route

Posté par (page perso) . Licence CC by-sa
Tags : aucun
0
7
juin
2015

Bonjour, j'ai ce probléme:

toc ~ # route -n quand ça marche pas
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG    3      0        0 enp3s0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
127.0.0.0       127.0.0.1       255.0.0.0       UG    0      0        0 lo
172.16.0.0      192.168.0.12    255.255.0.0     UG    3      0        0 enp3s0
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 enp3s0
192.168.142.0   0.0.0.0         255.255.255.0   U     0      0        0 enp2s0
toc ~ # /bin/route add -net 172.16.0.0
(...)

Forum Linux.général Hotplug SATA

Posté par (page perso) . Licence CC by-sa
Tags : aucun
3
31
mai
2015

Bonjour,

Je voudrai savoir quelle est la bonne pratique pour le débranchement à chaud de son disque externe en SATA. Je cherche quelque chose d'assez "user friendly" pour l'utilisateur lambda qui utilise Gnome.

Pour le branchement, pas de soucis, le disque est reconnu à la volée et on peut monter le disque d'un clic.

Pour le débranchement, doit on juste démonter les partitions utilisées avant de débrancher le disque? ou faut-il faire un #echo 1 > /sys/block/sdb/device/delete avant ?
L'utilitaire disque (...)

Forum Linux.général Projet : conflit avec vstmod

Posté par . Licence CC by-sa
Tags : aucun
0
31
mai
2015

Bonjour à tous,

Je suis sur un projet en ce moment. Je me charge de développer une communication fiable entre l'ordinateur et un matériel avec les ressources informatiques que j'ai en ma possession.

J'utilise un "pack" du nom de SeaBreeze. Je suis confronté à un problème. Lorsque je récupère des données d'un matériel du nom d'USB4000, je reçois des données erronées. Le lien concernant SeaBreeze ci-contre spécifie que pour le matériel USB4000, SeaBreeze est en conflit avec VSTMOD sous Linux.

(...)

Forum Linux.général Média center pour mythbuntu

Posté par . Licence CC by-sa
Tags : aucun
2
27
mai
2015

Bonjour a tous et toutes!

Voila, je suis en stage, je débute dans le monde linux et j'ai un projet. Mon but est de trouver une appli qui permettrais d'afficher musique, vidéo, image, PDF et powerpoint.
Le tout en une seul appli. J'ai vu qu'il y a un addons non officiel pour les PDF sur XBMC.

Seulement mon tuteur m'a rajouter une contrainte: il faut qu'il y est une interface admin et une utilisateurs pour éviter que n'importe qui foute (...)

Forum Linux.général Limiter l'utilisateur

Posté par . Licence CC by-sa
Tags : aucun
3
24
mai
2015

Bonjour,

J'administre à titre personnel 3 postes de travail dans une PME. Petit à petit, et afin de limiter les incompatibilités, on bascule les applications qui nécessitent encore un windows virtualisé vers des solutions SAAS (gestion commerciale, comptabilité).
Pour la sauvegarde, on a choisi une solution payante Dropbox.
Jusque là, tout ronronne correctement, et seul un dernier poste a encore besoin d'un virtualbox, mais c'est le temps du transfert de l'exercice comptable vers la solution SAAS.
Dernièrement, on me signale (...)

Forum Linux.général Quel Licence Utiliser ?

Posté par . Licence CC by-sa
1
23
mai
2015

Bonjour à tous,

Je souhaite développer un site web dont je rendrai le code open source afin de de profiter d'éventuelles pull request / issues / remarques de la communauté.

Je souhaiterai par contre être le seul a pouvoir l'exploiter, avoir le droit "d'usage" sur ce code source sur le domaine souhaité.

Connaissez-vous une licence open source qui répond à ces critères ?

M0dM

Forum Linux.général ffmpeg et conversion de mp4 version 1 en version 2

Posté par . Licence CC by-sa
Tags : aucun
1
23
mai
2015

Bonjour,

Je viens d'acheter un cadre photo numérique, et je n'arrive pas à lire dessus les vidéos mp4 que je réalise avec ma tablette :-/

Une vidéo capturée sur Youtube fonctionne sur le cadre, et avec la commande file je me suis aperçu que les mp4 créés via la tablette sont en version 1 :
VID_20150516_172601.mp4: ISO Media, MPEG v4 system, version 1
alors que les mp4 que le cadre lit bien sont en version 2

Je viens de passer (...)