Forum Linux.général Codage de caractères

Posté par (page perso) . Licence CC by-sa
Tags : aucun
2
19
sept.
2016

Bonjour à tous,

Ce week-end j'ai réalisé un transfert de données entre deux baies stockages. L'ancienne : NetApp FAS2020, la nouvelle NetApp FAS2520. Les fichiers concernés sont des fichiers offices, images, pdf… ils étaient mis à dispo directement depuis la baie via cifs. Afin de les transférer plus facilement j'ai monté l'ancien volume et le nouveau volume en nfs sur un serveur redhat.

Un coup de rsync et quelques heures plus tard tout était transféré. Sauf qu'après coups je me rend compte qu'il y un problème avec le codage des caractères dans les noms de fichiers. Que se soit sur l'ancienne baie ou la nouvelle baie les é sont remplacés par des _. Sur le serveur les locales sont
```

locale

LANG=fr_FR.UTF-8
LC_CTYPE="fr_FR.UTF-8"
LC_NUMERIC="fr_FR.UTF-8"
LC_TIME="fr_FR.UTF-8"
LC_COLLATE="fr_FR.UTF-8"
LC_MONETARY="fr_FR.UTF-8"
LC_MESSAGES="fr_FR.UTF-8"
LC_PAPER="fr_FR.UTF-8"
LC_NAME="fr_FR.UTF-8"
LC_ADDRESS="fr_FR.UTF-8"
LC_TELEPHONE="fr_FR.UTF-8"
LC_MEASUREMENT="fr_FR.UTF-8"
LC_IDENTIFICATION="fr_FR.UTF-8"
LC_ALL=
```

si je créé des nouveaux fichiers directement sur la nouvelle baie avec de é, ils s'affichent correctement. Je pourrais faire une recherche de _ et le remplacer par é mais parfois c'est un è ou ç qui se cache derrière le _ donc pas moyen d'automatiser le truc.

Est-ce qu'au niveau de nfs3 il y a des options pour forcer un codage au moment du montage ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.