Forum Linux.général desactiver le wifi au boot

Posté par .
Tags : aucun
1
30
jan.
2010
Salut à tous,

pour une fois c'est moi qui pose la question.

Avant j'avais un ordinateur avec un interrupteur physique pour couper le bluetooth et le wifi.
Maintenant j'ai un ordinateur sans interrupteur :(

du coup quand la machine demarre, le bluetooth et le wifi sont ON par defaut.

je peux bien sur utiliser le network-manager pour les couper, mais j'amerais faire l'inverse
demarrer avec le wifi et le bluetooth à OFF, et les allumer quand j'en ai besoin.

j'ai bien entendu chercher avec mon ami americain, mais je ne trouve que des solutions pour activer le wifi au boot (ce que j'ai deja).

Ma distrib : Ubuntu Karmic, sous Gnome.
Le wifi : ca tourne avec fwcutter et un driver bcm4322 (installés par la distro)
  • # /etc/network/interfaces

    Posté par . Évalué à 1.

    Bon, je ne suis pas un pro de ce fichier de conf, surtout des inter-actions avec network-manager, mais je pense qu'un truc du genre :

    iface wlan0 inet manual

    devrait marcher. Après, à une époque, ce qu'on définissait dans /e/n/i n'était pas managé par n-m, mais maintenant ça a changé. Après, est-ce que ça marche bien ... (perso j'ai perdu eth0 dans n-m depuis quelques temps en testing, je ne sais pas pourquoi ...)
    • [^] # Re: /etc/network/interfaces

      Posté par . Évalué à 3.

      à une epoque /etc/network/interfaces entrait en conflit avec N-M
      c'est pour ca que je n'ai meme pas testé

      mais je vais regarder
      sinon c'est vrai que je peux me faire 2 boutons qui (de)chargent les modules et font DOWN/UP sur l'interface
    • [^] # Re: /etc/network/interfaces

      Posté par . Évalué à 2.

      Je ne suis pas sûr que ce soit ce qu'il recherche. Sur un portable, désactiver le wifi (via un interrupteur) permet surtout d'économiser la batterie. En mettant l'interface en manuel, la carte va uniquement ne pas chercher à se connecter mais elle est alimentée quand même (la led témoin doit être allumée).
      A mon avis, il faudrait bloquer le chargement du module (blacklist) et faire un petit script qui le charge à la demande.
      • [^] # Re: /etc/network/interfaces

        Posté par . Évalué à 2.

        je crois que ca va se finir comme ca, mais je vais continuer à chercher...
        • [^] # Re: /etc/network/interfaces

          Posté par . Évalué à 2.

          Bon, ma solution du "manual" n'était peut-être pas très juste, mais je suis quasiment sûr que "ifconfig wlan0 down" (ou mieux : "ip link set etho down") éteint la carte. Bref, qu'il suffit de mettre son interface down pour qu'elle s'éteigne, et qu'un up la rallumera. Pas besoin de décharger le module. (test fait sur le driver b43)

          Ma "preuve" c'est que mon interface wifi, quand je démarre en console (donc sans n-m ou qui que ce soit d'autre cherche à la gérer) est down, et aucun module n'est chargé ! (mais elle est bien présente) Si je la up, le module se charge (uniquement la première fois) et la radio est lancée. Si je down, il m'indique dans les logs que la radio est désactivée. Je crois que c'est ce que tu cherches.
  • # Le mot clé est ...

    Posté par . Évalué à 3.

    rfkill.
    • [^] # Re: Le mot clé est ...

      Posté par . Évalué à 2.

      Merci à toi,

      je viens d'essayer rfkill et cela correspond à la solution à mon probleme.

      helas le driver wifi ne gere pas l'option rfkill et n'est pas pris en charge par le programme du meme nom.

      par contre ca marche nickel avec la carte bluetooth (ce qui est deja pas mal)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.