Forum Linux.général gvfs-mount et smb

Posté par .
Tags : aucun
1
10
sept.
2012

Hello,

J'ai un NAS QNAP avec quelques partages CIFS.J'y accède assez facilement via Nautilus.

Cependant, quand je veux y accéder via le terminal il semble que les montages ne sont pas présents dans ~/.gvfs.
J'ai installé le package gvfs-fuse pour essayer d'améliorer les choses mais toujours rien.

Quand j'essaye d'effectuer en ligne de commande, j'ai le résultat suivant:
gvfs-mount -v smb://qnap-nas/public/
Error mounting location: le volume n'implémente pas le montage

J'ai cherché sur le net et j'ai pas trouvé de réponses concluantes.

Je pense pouvoir m'en sortir avec un mount classique mais je suis assez curieux de savoir pourquoi cela ne marche pas.

Des idées ?

Merci.

  • # au choix chez moi

    Posté par . Évalué à 2. Dernière modification le 10/09/12 à 23:47.

    • ln -s /home/user/.gvfs /chemin/ou/tu/veux/le/montage
    • mount -t cifs qnap-nas:/public /chemin/ou/tu/veux/le/montage -o username=leuser,password=sonmotdepasse

    la derniere ligne pouvant etre servir de base de depart pour etre mise dans /etc/fstab pour monter le dossier directement au boot de la machine

    • [^] # Re: au choix chez moi

      Posté par . Évalué à 1.

      Finalement, j'ai opté pour une solution similaire via /etc/fstab.
      Merci.

  • # Ailleurs ?

    Posté par . Évalué à 2.

    J'ai remarqué qu'en passant de Mageia 1 à 2, le point de montage automatique avait changé. Il ne se trouve plus dans ~/.gvfs mais dans /run/user/nomutilisater/gvfs/
    Je n'en sais pas plus sur les raisons de ce changement, mais essaye de regarder par là.

    • [^] # Re: Ailleurs ?

      Posté par . Évalué à 1.

      J'ai rien trouvé à cet emplacement sur ma debian.
      J'ai finalement opté pour un montage classique via fstab.
      Merci.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.