Forum Linux.général ipv6 dns et miredo

Posté par .
Tags : aucun
1
4
fév.
2011
un ifconfig normal

rob@ordi1:~$ su
Mot de passe :
ordi1:/home/rob# ifconfig
eth1 Link encap:Ethernet HWaddr 00:90:f5:1f:a4:2b
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interruption:11 Adresse de base:0x2000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1327 errors:0 dropped:0 overruns:0 frame:0
TX packets:1327 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:134717 (131.5 KiB) TX bytes:134717 (131.5 KiB)

ppp0 Link encap:Protocole Point-à-Point
inet adr:10.241.9.145 P-t-P:10.64.64.64 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:6003 errors:0 dropped:0 overruns:0 frame:0
TX packets:10450 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:3
RX bytes:842723 (822.9 KiB) TX bytes:14038987 (13.3 MiB)


puis je vais sur http://www.test-ipv6.com
Your IPv4 address on the public internet appears to be 92.90.17.5
No IPv6 address detected
World IPv6 day is June 8th, 2011. No problems are anticipated for you with this browser, at this location.
You appear to be able to browse the IPv4 internet only. You will not be able to reach IPv6-only sites.
Your DNS server (possibly run by your ISP) appears to have no access to the IPv6 internet, or is not configured to use it. This may in the future restrict your ability to reach IPv6-only sites. [more info]
Your readiness scores

j'installe miredo et je lance le service avec init
ordi1:/home/rob# /etc/init.d/miredo start
Starting Teredo IPv6 tunneling daemon: miredo.

puis je relance ifconfig,le relay teredo me donne une adresse ipv6 = 2001:0:53aa:64c:24cc:9405:a3a5:eefa

ordi1:/home/rob# ifconfig
eth1 Link encap:Ethernet HWaddr 00:90:f5:1f:a4:2b
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interruption:11 Adresse de base:0x2000

lo Link encap:Boucle locale
inet adr:127.0.0.1 Masque:255.0.0.0
adr inet6: ::1/128 Scope:Hôte
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2270 errors:0 dropped:0 overruns:0 frame:0
TX packets:2270 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:0
RX bytes:212124 (207.1 KiB) TX bytes:212124 (207.1 KiB)

ppp0 Link encap:Protocole Point-à-Point
inet adr:10.241.9.145 P-t-P:10.64.64.64 Masque:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:14357 errors:0 dropped:0 overruns:0 frame:0
TX packets:26069 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:3
RX bytes:1490535 (1.4 MiB) TX bytes:36545910 (34.8 MiB)

teredo Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
adr inet6: fe80::ffff:ffff:ffff/64 Scope:Lien
adr inet6: 2001:0:53aa:64c:24cc:9405:a3a5:eefa/32 Scope:Global
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1280 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 lg file transmission:500
RX bytes:0 (0.0 B) TX bytes:192 (192.0 B)

je retourne sur test-ipv6.com
Your IPv4 address on the public internet appears to be 92.90.17.5
Your IPv6 address on the public internet appears to be 2001:0:53aa:64c:143f:1ea4:a3a5:eefa
Your IPv6 service appears to be: Teredo
World IPv6 day is June 8th, 2011. No problems are anticipated for you with this browser, at this location.
Congratulations! You appear to have both IPv4 and IPv6 internet working. If a publisher publishes to IPv6, your browser will connect using IPv6. Note: Your browser appears to prefer IPv4 over IPv6 when given the choice. This may in the future affect the accuracy of sites who guess at your location.
Your IPv6 connection appears to be using Teredo, a type of IPv4/IPv6 translation using a public gateway. The quality for this may suffer, as you are using a public gateway to reach IPv6 based sites.
Your DNS server (possibly run by your ISP) appears to have no access to the IPv6 internet, or is not configured to use it. This may in the future restrict your ability to reach IPv6-only sites


la dernière phrase semble indiquer que le serveur d'adresses dns du fournisseur d'accès ne gère pas ipv6 pour le moment
dns primaire = 172.20.2.10
dns secondaire = 172.20.2.39
je pense changer les adresses dns de ma clé 3g+ mais il sont renseignés automatiquement avec network-manager

puis j'active l'accès ipv4/ipv6 chez mon hébergeur sur www.petelaforme.com et pas sur www.gaulodico.com

rob@ordi1:~$ traceroute6 www.petelaforme.com
traceroute vers cluster010.ovh.net (2001:41d0:1:1b00:213:186:33:19) de 2001:0:53aa:64c:18a8:8c95:a3a5:eefe, port 33434, du port 54985, 30 sauts max, 60 octet/paquet
1 teredo.bit.nl (2001:7b8:3:27:87:251:43:68) 1603.529 ms 407.446 ms 415.807 ms
2 teredo-gw.jun1.bit-1.network.bit.nl (2001:7b8:3:27::2) 811.471 ms 427.824 ms 199.733 ms
3 amsix2.routers.ovh.net (2001:7f8:1::a501:6276:2) 895.821 ms 233.290 ms 587.762 ms
4 rbx-g2-a9.fr.eu (2001:41d0::af1) 703.696 ms 519.929 ms 459.661 ms
5 * * *
6 th2-1-6k.fr.eu (2001:41d0::5b1) 880.815 ms 499.823 ms 443.990 ms
7 p19-2-6k.fr.eu (2001:41d0::512) 1007.825 ms 336.126 ms 447.266 ms
8 cluster010.ovh.net (2001:41d0:1:1b00:213:186:33:19) 336.027 ms 447.012 ms 227.893 ms

rob@ordi1:~$ traceroute6 www.gaulodico.com
www.gaulodico.com port 33434 : Aucune adresse associée avec le nom de l'hôte

http://ipv6.google.com = http://[2a00:1450:8002::69]:80

comment outrepasser les serveurs dns fournis par le fai pour la clé 3G+
il y a les google dns 8.8.8.8 et 8.8.4.4 peut être meilleurs
  • # resolv.conf

    Posté par (page perso) . Évalué à 3.

    nameserver 8.8.8.8
    dans /etc/resolv.conf.head
    • [^] # Re: resolv.conf

      Posté par . Évalué à 1.

      sur ma debian squeeze
      network-manager 0.8.1-6 installé
      /etc/resolvconf/resolv.conf.d/head

      j'ai
      # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
      # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
      • [^] # Re: resolv.conf

        Posté par (page perso) . Évalué à 2.

        À première vue network-manager va modifier les resolv.conf, donc il faut définir le DNS dans network-manager : http://wiki.debian.org/NetworkConfiguration#DNSconfiguration(...)
        • [^] # Re: resolv.conf

          Posté par . Évalué à 1.

          sur le lien voilà ce que l'on trouve:
          DNS configuration for network-manager

          Warning: This section has not been tested with an actual network-manager setup. Please test it and remove this notice.

          If you are using NetworkManager, put your settings in /etc/sysconfig/network-scripts/ifcfg-*. Example:

          DNS1=127.0.0.1
          DNS2=8.8.8.8
          DNS3=8.8.4.4

          Using the GUI, this means:

          1. Systems menu → Preferences → Network Connections.
          2. Choose a connection (from the Wired or Wireless tab) and click Edit.
          3. Change the Method to something other than "Automatic (DHCP)” in the IPv4 Settings tab. For example, "Automatic (DHCP) addresses only” is likely to be appropriate.
          4. Enter the DNS servers in the “DNS servers” field, separated by spaces.
          5. Click "Apply.”

          Note that your DHCP client might override these settings; if so, consider whether to report it as a bug, and see below for the DHCP client configuration.

          This section is based on http://code.google.com/speed/public-dns/docs/using.html, which see for details.

          je clique sur l'icone de network-manager dans la zone de notification
          je clique sur l'onglet : connexion mobile a large bande
          puis gsm connexion,modifier
          puis paramètres ipv4 methode
          je choisis: adresses automatiques uniquement (ppp)
          là le champ dns est valide
          j'ajoute 8.8.8.8,8.8.4.4
          je relance la connexion et dans les informations de connexions,les adresses dns ont changées,il y a du progrès

          je retourne sur http://test-ipv6.com
          Your DNS server (possibly run by your ISP) appears to have IPv6 internet access

          voilà l'expliquation qu'ils donnent:
          This FAQ has been produced to try and address what it means for the v6ns test to be "bad".

          This test specifically verifies that your DNS resolver (usually operated by your internet service provider, or your corporate IT department) is capable of reaching IPv6 internet sites for DNS lookups. If you explicitly configured the use of a different DNS server, such as OpenDNS or Google's Public DNS, you'll test those services instead.

          If this test fails: it means that the DNS resolver you are using, requires IPv4 to reach the DNS authoritative servers of your favoriate web sites. In the near future, every web site of consequence will remain accessible in this form, so there is no immediate danger.

          If this test succeeds: it means that your DNS resolver is fully capable of reaching IPv6 DNS servers. This means that the operator of that DNS server has IPv6 within their network. If they do not already offer you IPv6, this may be a sign that they are actively working on trying to make it possible.

          merci mr tiot
  • # liste de sites

    Posté par . Évalué à 1.

    http://plutarco.lab.bt.es/html/ipv6/global_results.html
    http://www.ipv6.uni-leipzig.de/ipv6/stats/stats.php3

    petit test sur http://www.ipv6.hawaii.edu

    rob@ordi1:~$ ping -c 1 www.ipv6.hawaii.edu
    ping: unknown host www.ipv6.hawaii.edu

    rob@ordi1:~$ ping6 -c 1 www.ipv6.hawaii.edu
    PING www.ipv6.hawaii.edu(2607:f278:4101:11:dead:beef:f00f:f) 56 data bytes
    64 bytes from 2607:f278:4101:11:dead:beef:f00f:f: icmp_seq=1 ttl=49 time=959 ms

    le site http://www.ipv6.hawaii.edu est accessible seulement en ipv6 et ça marche

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.