Forum Linux.général Linux & Raid1, Reboot infini et carte réseau

Posté par (page perso) .
Tags : aucun
1
28
nov.
2008


Bonjour,

heureux possesseur depuis peu de temps d'une nouvelle configuration (GA-EX58-UD5 + Intel i7 920) qui à remplacée ma vieille A8N Sli Deluxe + AMD 64 3000 de 4ans, j'ai rapidement déchanté avec tous les problèmes que je rencontre encore aujourd'hui.




Croyez moi, si j'en viens à poster un message, c'est que je ne sais vraiment plus quoi tester, j'espère donc trouver des idées, aides qui me sauveront la vie :) (surtout celle de cette foutu carte mère qui va finir par la windows :) )




Donc, trève de blabla je vous explique mes problèmes :



1. Le Raid


J'ai un contrôleur RAID (Intel ICH10R), je souhaite donc m'en servir, apparemment, après, quelques recherches sur Internet, je peux m'asseoir dessus, aucun pilote pour Linux, j'ai bien essayé le pilote noyau Intel/ICP (GDT) mais rien n'y fait, il voit mon array comme 2 disques séparés, 2 questions :




  • Une idée pour faire fonctionner ce contrôleur Intel mentionné plus haut ?

  • Ayant peu d'espoir concernant le contrôleur hardware, je pensais faire du Raid logiciel, y'a t-il des retours d'utilisation dans l'assistance ?



2. Ma carte réseau r8111


Je possède 2 prises réseaux sur ma carte mère, avec du RTL8111/8168B derrière, ceux qui ont ce chipset doive connaitre le souci qui y est lié, en effet, une fois sur 2, la carte ne fonctionne pas, elle est reconnu par le kernel mais les paquets n'ont pas l'air de passer...



Sans rentrer dans les détails du problème, quelqu'un ayant ce chipset à-t-il déjà réussi à la faire fonctionner ?



3. Cycle Of Death


Je garde le meilleur pour la fin, à chaque fois que je lance une commande de reboot, le pc fait mine de redémarrer et au moment d'afficher la prepost du bios, le pc reboot encore et cela indéfiniment, je suis obligé de l'éteindre, d'attendre quelques secondes (20 bonnes secondes), de rebrancher l'alim, et voilà, le pc est de nouveau opérationnel.

Je pense avoir tout essayé du côté logiciel, acpi, etc...et aussi du coté hard, test alim, suppression de tous les disques, etc, modification dans le bios, bref, je sais plus quoi faire à part rafraichir la page des mises à jour du Bios sur le site du constructeur...



Voilà mes problème du moment, croyez-moi, je ne suis pas prêt de réinvestir dans du matériel aussi récent qui me semble pas vraiment utilisable (sous linux).

Merci par avance, si vous avez des idées à me donner...

  • # Ha, le matériel récent ...

    Posté par . Évalué à 4.

    Même si linux s'est amélioré depuis pas mal d'années, il faut toujours un petit bout de temps avant que le matos soit bien supporté ... Avant c'était quelques années, maintenant c'est plutôt quelques semaines, quand c'est du "standard", ce qui a l'air d'être ton cas.

    Connaître ta distribution aurait aussi pu aider. Je pense que pour ton matos, il va falloir aller du coté des distro "unstable".

    Pour tes questions :

    - Pour le RAID, je te déconseille d'utiliser celui de ta CM, ça apporte plus d'emmerdes qu'autre chose quand c'est uniquement du soft-raid (ce qui est le cas ici). Bref, c'est juste un bios, ça n'accélerrera rien du tout, mieux vaut utiliser le raid soft sous linux. Retour de ma part : ça fonctionne de manière complètement invisible chez moi sous debian, c'est proposé à l'install en standard (RAID0 + LVM).

    - Carte réseau : je ne sais pas, mais si c'est du matos récent, vaut surement mieux un kernel récent. Je suppose que c'est quelques bugs de jeunesse du driver.

    - "Cycle of death" : pareil, aucune idée, mais ça doit être du au manque de maturité du driver.

    Je croyais que c'était "connu" que du nunux sur du matos récent (les i7 sont sortis cette semaine, non ?) c'est pas la joie ...
    • [^] # Re: Ha, le matériel récent ...

      Posté par (page perso) . Évalué à 2.

      OK, merci pour tes conseils.

      Concernant le kernel, j'ai un 2.6.27, donc je suis totalement à jour de ce côté...j'ai testé le 2.6.28-rc6, idem.

      Je croyais que c'était "connu" que du nunux sur du matos récent (les i7 sont sortis cette semaine, non ?) c'est pas la joie ...

      Oui mais bon, achetant un PC tous les 3/4ans (je rentabilise), j'essaie d'acheter des config lourdes afin de tenir le temps qu'il faut...
  • # La carte réseau

    Posté par (page perso) . Évalué à 3.

    Elle devrait bien marcher avec les kernels récents, mais je te conseille de mettre un >= 2.6.27.6 qui a quelques corrections pour.
    • [^] # Re: La carte réseau

      Posté par (page perso) . Évalué à 1.

      Je suis taquet au niveau du kernel ( 2.6.27-gentoo-r4 ), je vais essayer d'installer un 2.6.27.7.

      je crois les doigts...
      • [^] # Re: La carte réseau

        Posté par (page perso) . Évalué à 2.

        kernel téléchargé, compilé, installé, pc rebooté, pour le moment, tout va bien avec le 2.6.27.7.

        Concernant le Raid, j'ai laché l'affaire du Raid hardware et passé au software...

        2 problèmes de résolus pour le moment...il reste plus que ce satané cycle of death.
        • [^] # Re: La carte réseau

          Posté par (page perso) . Évalué à 7.

          >Concernant le Raid, j'ai laché l'affaire du Raid hardware et passé au software...

          ça tombe rien, tu n'a pas de raid hardware, tu a ce qu'on appelle du
          "soft-raid", c'est a dire un bios qui stocke les infos du raid que tu veut,
          un bete controlleur disque sata et un driver qui utilise le fameux bloc
          de données pour initialiser un raid soft.
          Rien de plus, donc te prend pas la tête avec ça.

          Si tu veut du raid hard c'est pas le même tarif, ni les mêmes composants, exemple:
          http://www.materiel.net/ctl/SATA1/8703-9500S_4_ports_bulk_.h(...)

          La tu as un processeur dédié, de la mémoire dédiée, possibilité de monter une batterie de sauvegarde, ....
          • [^] # Re: La carte réseau

            Posté par (page perso) . Évalué à 2.

            Ouch. C'est plus cher qu'un ordi.

            Envoyé depuis mon lapin.

          • [^] # Re: La carte réseau

            Posté par (page perso) . Évalué à 1.

            Ouais, je m'en suis aperçu après avoir lu pas mal de doc sur le net...

            Grosse déception, bref, je suis passé au raid 1 software, pour le moment, aucun souci...
            • [^] # Re: La carte réseau

              Posté par . Évalué à 3.

              Rhaa, je croyais aussi que le fait que le RAID présent sur les CM était du faux raid était un truc connu ... Faudrait vraiment en parler un peu plus peut-être ...
  • # raid ou plutot fakeraid

    Posté par . Évalué à 3.

    j'ai pareil avec ma carte mere (ASUS P5N-D et A8N-SLI)

    en fait il faut installer le paquet dmraid qui va s'occuper de trouver le raid et de te proposer un peripherique /dev/mapper/nvidia_dsfdsfeze

    ce que j'ai fait du coup, je garde mon systeme sur un petit disque (80Go)
    et je met le reste sur le raid.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.