Forum Linux.général Plus de son après mise à jour

Posté par .
Tags : aucun
1
17
sept.
2012

Bonjour à tous, je suis nouvelle sur ce forum ainsi que sur linux….
je viens d'acquérir depuis quelques jours un netbook asus eeepc x101 ch avec linux ubuntu. totalement novice sur linux j'ai commencée a prendre mes marques jusqu'à ce que je decide de faire les quelques 400 mises à jours que mon ubuntu me demandait….et là plus de son alors que tout est impeccable en configuration…. j'ai donc comme indiqué dans certains forum reinstaller ubuntu en fesant un recovery au demarrage, effectivement je recupere mon son mais a ce moment là je ne dois pas faire les mises a jours sinon cela recoupe le son… Je suis tres embetee car je ne trouve aucun pilotes pour linux au sujet de mon son….

je suis sur ubuntu 12.04 LTS

32 bits
merci de votre aide…..à bientot.

  • # bug ?

    Posté par (page perso) . Évalué à 2.

    Pour la mise à jour, c'est toujours en restant en lts ?

    Système - Réseau - Sécurité Open Source

  • # Mystérieux matériel...

    Posté par (page perso) . Évalué à 3.

    Bonjour,

    Alors j'ai un peu fureté sur le net et aucune information sur le chipset son embarqué dans l'engin…
    Et pourtant il y a bien du son !
    Donc voici ce qui pourrait être intéressant de faire pour commencer :

    Dans un terminal lancer la commande
    lshw > listing_matos

    Ensuite regarder dans le fichier listing_matos à la section multimedia pour trouver le matériel et le pilote..

        *-multimedia
             description: Audio device
             product: 631xESB/632xESB High Definition Audio Controller
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress bus_master cap_list
             configuration: driver=HDA Intel latency=0 module=snd_hda_intel
    
    

    NB : si il te sort un "Command not found" quant tu tappes la commande installe le programme :
    sudo apt-get install lshw

    Ensuite regarder ce qui est utilisé pour gérer le son…
    Il y a de fortes chance que ce soit alsa…
    dpkg -l | grep alsa
    te retourne il quelque chose ?

    Et pour finir après ta mise à jour as tu vérifié que les niveau n'étaient pas tombé à zéro avec le mixer ? ( je sais ça semble balot )

    Fuse : j'en Use et Abuse !

    • [^] # Re: Mystérieux matériel...

      Posté par . Évalué à 2.

      merci !!

      alors je vais commencer par le debut …lol
      pour la commande : lshw > listing_matos le terminal me dit erreur ce programme doit etre lancé par super utilisateur, hors je suis la seule et principale utilisatrice de ce pc…

      ensuite pour la commande : apt-get install lshw
      Lecture des listes de paquets… Fait
      Construction de l'arbre des dépendances

      Lecture des informations d'état… Fait
      lshw est déjà la plus récente version disponible.
      Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
      gir1.2-json-1.0 realpath efibootmgr libdmraid1.0.0.rc16 libidl-common
      gir1.2-timezonemap-1.0 kpartx-boot archdetect-deb python-pyicu libxcb-glx0
      user-setup kpartx rdate btrfs-tools libidl0 localechooser-data
      gir1.2-xkl-1.0 liborbit2 libdebconfclient0 dmraid
      Veuillez utiliser « apt-get autoremove » pour les supprimer.
      0 mis à jour, 0 nouvellement installés, 0 à enlever et

      0 non mis à jour

      pour l'autre voici ce qu'il me met :
      nelly@nelly-X101CH:~$ dpkg -l | grep alsa
      ii alsa-base 1.0.25+dfsg-0ubuntu1 ALSA driver configuration files
      ii alsa-hda-realtek-patched-dkms 1.0 alsa-hda-realtek-patched driver in DKMS format.
      ii alsa-utils 1.0.25-1ubuntu5 Utilities for configuring and using ALSA
      ii bluez-alsa 4.98-2ubuntu7 Bluetooth ALSA support
      ii gstreamer0.10-alsa 0.10.36-1ubuntu0.1 GStreamer plugin for ALSA

      voila…apres je suis totalement novice a tout cela !!

      • [^] # Re: Mystérieux matériel...

        Posté par (page perso) . Évalué à 3. Dernière modification le 17/09/12 à 15:49.

        Arrf j'ai oublié qu'il fallait les droit root !
        En fait le super utilisateur, dit "root" est l'administrateur de la machine, et là ce sera toi !
        Celui qui a tout les pouvoirs, tous les droits. Ce compte est toujours présent sur une machine unix, et il convient de comprendre et faire attention à ce que tu fais quand tu utilises l'"administrateur"

        Tu peux t’approprier les droits super-utilisateur pour les commandes que tu lances en préfixant avec la commande "sudo" et il va te demander ton mot de passe. Donc la bonne commande est :

        sudo lshw > matos

        Cela va lancer la programme de collecte des informations matériel ( "lshw" ) avec les droits root ( car "sudo" ) et le supérieur permet de rediriger le résultat dans un fichier, ce qui est bien pratique pour regarder tranquillement le résultat avec l'éditeur de texte par exemple.
        Connaître son matos est toujours important, pour savoir de quoi on parle et ce qui ne marche plus exactement ! :o)

        A première vue c'est bien Alsa ( Advanced Linux Sound Architecture ) qui est utilisé.
        Un truc qui peux être intéressant c'est de te familiariser avec la commande
        alsamixer
        Ca te fait un mixer dans le terminal et tu peux régler les niveaux avec les flèches haut-bas, et te déplacer de jauge en jauge avec les flèches droite-gauche. ( touche Echap pour sortir ). Les jauges importantes pour toi sont "PCM" et "Master".
        Il serait intéressant de voir, après la mise à jour, si les jauges ne passent pas à "0", auquel cas il suffit de monter… Si ca ne vient pas de là, eh bien le petit retour arrière tu l'as déjà pratiqué.

        Fuse : j'en Use et Abuse !

        • [^] # Re: Mystérieux matériel...

          Posté par . Évalué à 3.

          Hum,

          lshw > listing_matos

          puis

          sudo lshw > matos

          Si tu profite de rajouter un sudo pour changer le nom du fichier de sortie de listing_matos en matos, tu cherches à l'embrouiller.

          alsamixer
          Ca te fait un mixer dans le terminal et tu peux régler les niveaux avec les flèches haut-bas, et te déplacer de jauge en jauge avec les flèches droite-gauche. ( touche Echap pour sortir ). Les jauges importantes pour toi sont "PCM" et "Master".
          Il serait intéressant de voir, après la mise à jour, si les jauges ne passent pas à "0", auquel cas il suffit de monter… Si ca ne vient pas de là, eh bien le petit retour arrière tu l'as déjà pratiqué.

          Il faut aussi regarder si la jauge n'est pas muette… (touche m pour switcher entre mute/unmute).

          Je ne suis pas au point sur toutes les blagounettes graphiques, mais ça m'étonnerai fortement qu'il n'existe pas de mixer graphique un peu plus simple d'accès.

          • [^] # Re: Mystérieux matériel...

            Posté par . Évalué à 1.

            en tout cas merci à vous ! je teste tout ça et je vous dis si j'obtiens du son !

            • [^] # Re: Mystérieux matériel...

              Posté par . Évalué à 2.

              a parament mon precedent post n'a pas fonctionné, je remet donc ce que j'ai trouvé dans multimedia:
              *-multimedia
              description: Audio device
              produit: N10/ICH 7 Family High Definition Audio Controller
              fabriquant: Intel Corporation
              identifiant matériel: 1b
              information bus: pci@0000:00:1b.0
              version: 02
              bits: 64 bits
              horloge: 33MHz
              fonctionnalités: pm msi pciexpress bus_master cap_list
              configuration: driver=snd_hda_intel latency=0
              ressources: irq:46 mémoire:dff00000-dff03fff

              Pour ce qui est d'alsamixer, tout est sur 100<>100 en revanche j'ai un petit carré dans lequel il y a soit OO soit MM j'ai beau essayé les 2 mais toujours pas de son… je desespere vraiment d'avoir pris linux…..

              • [^] # Re: Mystérieux matériel...

                Posté par . Évalué à 2.

                OO c'est actif, MM c'est silencieux (Mute).

                Avec quels programmes tu n'as plus de sons ? Tous ?

                Qu'en dis le support Asus ?

                De mémoire, sur mon eeePC le source.list pointait vers leurs dépots..

                Tu peux taper la commande "cat /etc/apt/sources.list" et poster le résultat ici ?

                THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

                • [^] # Re: Mystérieux matériel...

                  Posté par . Évalué à 1. Dernière modification le 18/09/12 à 14:08.

                  je n'ai aucun son nul part.

                  voici ce que cela donne, pour se qui est du support je vais essayer d'appeler asus, mais c 'est le service apres vente cdiscount qui laisse a désirer donc je vais essayer de trouver une solution de passer par asus sans passer par cdiscount.
                  voici le résultat de la commande :

                  # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
                  # newer versions of the distribution.
                  deb http://archive.ubuntu.com/ubuntu/ precise main restricted
                  deb-src http://archive.ubuntu.com/ubuntu/ precise main restricted
                  
                  ## Major bug fix updates produced after the final release of the
                  ## distribution.
                  deb http://archive.ubuntu.com/ubuntu/ precise-updates main restricted
                  deb-src http://archive.ubuntu.com/ubuntu/ precise-updates main restricted
                  
                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
                  ## team. Also, please note that software in universe WILL NOT receive any
                  ## review or updates from the Ubuntu security team.
                  deb http://archive.ubuntu.com/ubuntu/ precise universe
                  deb-src http://archive.ubuntu.com/ubuntu/ precise universe
                  deb http://archive.ubuntu.com/ubuntu/ precise-updates universe
                  deb-src http://archive.ubuntu.com/ubuntu/ precise-updates universe
                  
                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
                  ## team, and may not be under a free licence. Please satisfy yourself as to
                  ## your rights to use the software. Also, please note that software in
                  ## multiverse WILL NOT receive any review or updates from the Ubuntu
                  
                  ## security team.
                  deb http://archive.ubuntu.com/ubuntu/ precise multiverse
                  deb-src http://archive.ubuntu.com/ubuntu/ precise multiverse
                  deb http://archive.ubuntu.com/ubuntu/ precise-updates multiverse
                  deb-src http://archive.ubuntu.com/ubuntu/ precise-updates multiverse
                  
                  ## N.B. software from this repository may not have been tested as
                  ## extensively as that contained in the main release, although it includes
                  ## newer versions of some applications which may provide useful features.
                  ## Also, please note that software in backports WILL NOT receive any review
                  ## or updates from the Ubuntu security team.
                  
                  deb http://security.ubuntu.com/ubuntu precise-security main restricted
                  deb-src http://security.ubuntu.com/ubuntu precise-security main restricted
                  deb http://security.ubuntu.com/ubuntu precise-security universe
                  deb-src http://security.ubuntu.com/ubuntu precise-security universe
                  deb http://security.ubuntu.com/ubuntu precise-security multiverse
                  deb-src http://security.ubuntu.com/ubuntu precise-security multiverse
                  
                  ## This software is not part of Ubuntu, but is offered by Canonical and the
                  ## respective vendors as a service to Ubuntu users.
                  deb http://archive.canonical.com/ubuntu precise partner
                  deb-src http://archive.canonical.com/ubuntu precise partner
                  
                  ## This software is not part of Ubuntu, but is offered by third-party
                  ## developers who want to ship their latest software.
                  deb http://extras.ubuntu.com/ubuntu precise main
                  deb-src http://extras.ubuntu.com/ubuntu precise main
                  
                  
  • # Suggestion comme ça...

    Posté par . Évalué à 2.

    Tu as essayé de supprimer le .pulseaudio dans ton dossier personnel? J'ai eu le même syndrome avec Debian Testing…

    • [^] # Re: Suggestion comme ça...

      Posté par . Évalué à 2.

      désolée je suis totalement novice sur linux….lol

      • [^] # Re: Suggestion comme ça...

        Posté par (page perso) . Évalué à 2.

        Alors
        - tu ouvres "Dossier personnel"
        - tu vas dans affichage et tu clique sur "afficher les fichiers cachés"
        - il vient plein de fichier et de dossier, tu renommes le dossier ".pulse" en ".pulse-old"
        - tu renommes le fichier ".pulse-cookie" en ".pulse-cookie-old"
        - dans affichage tu déselectionnes "afficher les fichiers cachés"
        - tu fermes la session et tu la rouvre (si tu comprend pas comment faire tu redémarre ton ordinateur)

        Normalement tu devrais avoir du son.

        Mon conseil tu peut le faire avant ce qui est en dessus
        tu cliques sur le logo ubuntu (la première icone en haut à gauche) et tu tapes "son" sans les guillemets.
        Tu lances l'application "Son" en cliquant dessus.
        Dans l'onglet Sortie tu regarde ce que tu as dans "Jouer le son au travers de" tu regardes si c'est bien la sortie haut-parleurs avec audio interne, il se pourrait qu'il y est de cliquer hdmi.
        Tu peut même tester le son.
        Si tu as du son avec tester le son et toujours pas avec ce que tu teste tu lance un fichier audio et tu vas dans l'onglet Applications et tu regarde si ton application n'est pas à 0.

        En espérant que cela puisse t'aider.

  • # Autre suggestion

    Posté par (page perso) . Évalué à 7.

    Dans ces problèmes de truc qui ne marchent plus (bureau, son) après une mise à jour ou une mise à niveau , j'emploie la technique suivante: je commence par créer un nouvel utilisateur et je regarde si il a les mêmes problèmes. Ca permet de savoir si le problème est dans la configuration du répertoire utilisateur, devenu incompatible avec le nouveau logiciel, ou au niveau du système.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.