Forum Linux.général Problème avec mon disque dur

Posté par .
1
23
mai
2012

Bonjour,

Je vous écris ce petit message car j'ai un gros problème avec mon dd
je voulais formater à bas niveau mon disque dur j'ai donc téléchargé PartedMagic
j'ai lancé Erase Disk sélectionner mon disque interne et j'ai lancer le formatage mais le problème c'est que mon ordi a été arête et quand j'ai voulu reprendre il me demandait un mots de passe pour le dd alors que j'avais bien mis NULL lors du formatage

J'ai donc booté sur le cd de parted Magic ms il ne retrouve pas le dd je l'ai donc débranché et rebranché en externe et la il l'a reconnu j'ai pu le formater en bas niveau mais lorsque le formatage c'est fini et que j'ai voulu rebooter il y avait toujours un mot de passe… :/

J'ai regarder un peu sur internet et j'ai trouver une piste la commande hdparm mais elle me revoit un erreur que voilà

SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

et lorsque je fais la commande hdparm -I /dev/sda voila se qu'il affiche :

la ligne ci-dessus et cela (il n'y a pas d'erreur c bien des point d'interrogation pour les premières lignes)

ATA device, with non-removable media
Model Number: ����Ҁ�����q��� @��t��6�S���>
@�P
Serial Number: ��쓩�음�����윛

Firmware Revision: ��,����
Media Serial Num: ߀�s$��D% �t��mP@�y���R���OF��lb@�� �P
Media Manufacturer: S`�c&��K��B�@샫��@
Transport: 0x8580; Revision: 0xec40
Standards:
Used: unknown (minor revision code 0xec67)
Supported: 13 12 11 10 8 6 5
Likely used: 13
Configuration:
Logical max current
cylinders 0 47360
heads 0 60497
sectors/track 24064 57280
--
CHS current addressable sectors: 226552904
Logical Sector size: 512 bytes
Physical Sector size: 512 bytes
device size with M = 1024*1024: 110621 MBytes
device size with M = 1000*1000: 115995 MBytes (115 GB)
cache/buffer size = unknown
Nominal Media Rotation Rate: 60537
Capabilities:
IORDY(can be disabled)
Queue depth: 15
Standby timer values: spec'd by Standard
R/W multiple sector transfer: Max = 81 Current = ?
Recommended acoustic management value: 21, current value: 224
DMA: not supported
PIO: pio0 pio1 pio2 pio8
Cycle time: no flow control=60481ns IORDY flow control=62528ns
* reserved 69[0]
* reserved 69[1]
* reserved 69[3]
* reserved 69[4]
* WRITE BUFFER DMA command
* READ BUFFER DMA command
* Long physical sector diagnostics
* CFast specification support
Security:
Master password revision code = 48256
not supported
not enabled
not locked
not frozen
not expired: security count
not supported: enhanced erase
Logical Unit WWN Device Identifier: 8ee0ec6a9ea0ec4c
NAA : 8
IEEE OUI : ee0ec6
Unique ID : a9ea0ec4c
Integrity word not set (found 0xec95, expected 0x9ca5)

Une autre piste serai de décortique les source de Erase Disk mais je ne suis pas capable de le faire

merci à quiconque pourra m'aider…

  • # utf8 ?

    Posté par (page perso) . Évalué à 1. Dernière modification le 23/05/12 à 17:12.

    je sais pas mais as-tu essayer dans un terminal utf8 ? ou alors non utf8 (latin1) si tu l'as déjà fait dans un term utf8

    sinon c'est quoi ton disque dur ? quelle marque
    tu peux essayer de refaire un formatage bas niveau avec le soft du fabricant du disque sous windows ou DOS.

    Et sous PartedMagic, quel soft as-tu utiliser pour ce formatage bas niveau ?

    • [^] # Re: utf8 ?

      Posté par . Évalué à 1.

      J'ai utiliser Erase Disk…

      mon disque dur est un samsung model HM500JI

      nn j'ai pas encore essayer dans un terminal utf8

      • [^] # Re: utf8 ?

        Posté par . Évalué à 0.

        mais le problème n'est pas qu'on arrive pas a lire sa sa me parait pas très grave mais plutôt qu'il me faille un mots de passe pour accédé à mon disque dur.

        j'ai remarqué des différence avec d'autre screen au niveau des dernières lignes et surtout security et sur les screen que j'avais vu il n'y a pas de not devant le supported voila pour d'ample information

        merci pour ton aide

        • [^] # Re: utf8 ?

          Posté par (page perso) . Évalué à 2.

          je comprends pas trop comment un dd ou shred sur un disque peut provoquer un tel problème.

          • [^] # Re: utf8 ?

            Posté par (page perso) . Évalué à 3.

            t'as crée une table de partition ? parce que sinon t'as distro croit peut-être avoir à faire à un disque crpyté et demande un mdp ?

            • [^] # Re: utf8 ?

              Posté par (page perso) . Évalué à 0.

              +1 et il se peux aussi qu'il n'y ait plus que la partition de restauration du constructeur qui elle est peut être chiffrée…
              Que donne fdisk -l sur le device ?

              Fuse : j'en Use et Abuse !

            • [^] # Re: utf8 ?

              Posté par . Évalué à 0.

              nn… c'est quoi une table de partition ??? et distro???

              • [^] # Re: utf8 ?

                Posté par (page perso) . Évalué à 2.

                Distro c'est Distribution, c'est une abréviation utilisée dans la communauté.

                La table de partition, pour faire simple c'est le découpage du disque physique en "sous-disques"
                Par exemple la mode récente veux que le disque des laptop contient deux partitions
                - une partition caché qui contient tout ce qui va bien pour restaurer le portable dans l'état où tu l'as acheté.
                - une partition avec le windobe.

                Le formatage bas niveau a certainement supprimé la table de partition donc le disque est complètement vierge, non découpé, ce qui peux peut-être faire tilter ta distribution. Il faudrait que tu en remettre une. De souvenir tu as un outils qui s'appel "partition editor" dans Parted Maqik. Sinon dans un terminal en ligne de commande un outil assez intuitif et convivial : cfdisk /dev/sda.

                Fuse : j'en Use et Abuse !

          • [^] # Re: utf8 ?

            Posté par (page perso) . Évalué à 1.

            Plutôt d'accord avec toi, je pense que ca vient de son Bios ( j'ai fait un commentaire dédié il y a 3 minutes )

            Fuse : j'en Use et Abuse !

            • [^] # Re: utf8 ?

              Posté par . Évalué à 3.

              Plutôt d'accord avec toi, je pense que ca vient de son Bios (j'ai fait un commentaire dédié il y a 3 minutes)

              Non parce que ça m'énerve :) Ya pas d'espace après "(" et avant ")"

              • [^] # Re: utf8 ?

                Posté par (page perso) . Évalué à 1.

                Je sais… Les correcteurs orthographique le détecte aussi.
                Mais je trouve que c'est moins lisible sans espace …donc j'en colle toujours !
                Rien que pour énerver les gens comme toi ! ;-)

                Fuse : j'en Use et Abuse !

      • [^] # Re: utf8 ?

        Posté par (page perso) . Évalué à 2.

        Erase Disk …
        oui et encore …

        C'est juste une boite de dialogue pour choisir entre dd, shred, et nwipe

  • # Et si cela venait de.....

    Posté par (page perso) . Évalué à 2.

    Tu n'as pas mis de mot de passe au formatage mais peut-être que ton bios le fait pour toi !

    Le modèle de disque est pour un laptop à ce que j'ai vue or certains laptop récents reportent le mot de passe bios sur le disque…. Ceci peux expliquer cela…

    Fuse : j'en Use et Abuse !

    • [^] # Re: Et si cela venait de.....

      Posté par . Évalué à 0.

      j'ai pas toucher au bios et ya pas de mot de passe par défaut au bios nn???

      j'ai lu que les mots de passe était écrit sur une puce annexe au disque dur je me demandait si elle n'était pas sur la carte sata mais j'ai pas le moyen de tester avec une autre carte sata…

      je désespère de plus en plus a trouver se mots de passe

    • [^] # Re: Et si cela venait de.....

      Posté par . Évalué à 0.

      je trouve se message le plus important, à la moindre commande hdparm que je fait il s'affiche

      _SG_IO: bad/missing sense data, sb[]: 70 00 05 00 00 00 00 0a 00 00 00 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

      j'ai bien peur qu'il soit mort…

  • # Heu ?

    Posté par . Évalué à 3.

    C'est quoi ce disque bizarre ? Normalement quand on trifouille les partitions des données comme le "Serial Number" ne deviennent pas totalement illisible, et je n'ai jamais vu de disque où il ait une valeur qui ne soit pas écrite en l'ASCII 7 bits.

    Je soupçonne moi aussi une sale bidouille du côté du fabricant du disque ou du portable.

    Essaie de "nettoyer" le disque en bootant sur un Live CD de Linux quelconque et en faisant un "dd if=/dev/zero of=/dev/sda" (/dev/sda à remplacer par le nom du disque, fais attention à pas effacer le mauvais !!), et tente de faire une réinstallation.

    THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

    • [^] # Re: Heu ?

      Posté par . Évalué à 1. Dernière modification le 24/05/12 à 08:55.

      Oui je suis du même avis, ça pue le constructeur qui a tenté d'implémenter une protection contre le formatage manuel bas niveau, ou un contrôleur qui ne supporte pas l'adressage d'un disque qui ne possède pas (encore) de table de partition, (ce qui est le cas lors du formatage lowlevel).

      Mais bon la dernière fois que j'ai vu un cas comme ça c'était y'a genre 15 ans….Toute une série de disque (de mémoire Western Digital), ne pouvaient être formatés bas niveau que sur une carte contrôleur spécifique où sinon avec un soft vendu par le constructeur.

    • [^] # Re: Heu ?

      Posté par . Évalué à 1.

      je pense que le problème viens du fait que l'ordi c'est arête pendant le formatage bas niveau provoquant sûrement des dégât dans la puce qui gère le disque dur… je ne vois pas d'autre explication.

      j'ai relancer un formatage bas niveau avec erase disk et la commande dc3dd le formatage prend bc de temps 123 heures car seulement une vitesse de 1 mb/s

      voila pour les nouvelle merci de votre aide

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.