Forum Linux.général Probleme partition en read only apres coupure électrique

Posté par .
Tags : aucun
1
3
jan.
2010
Bonjour,
Ma cop ayant changé une ampoule a oublié que le pc était allumé :D
et du coup lorsque j'ai redémarre rle systeme je me suis aperçu que celui-ci était monté en read-only!
Mais je ne comprend pas car malgres de nombreux reboot, un fsck /dev/sda1, un fsck.ext4 /dev/sda1 il me dit que le FS est propre ...
alors je ne vois pas pourquoi il refuse de monter la partition normallement...
J'ai aussi essayé un boot en recovery mode pour executer un fsck mais meme resultat.
Voici mon /etc/fstab:

UUID=2b85a508-2fc9-4d34-8b2a-f5f49d8f69a3 / ext4 relatime,errors=remount-ro,iocharset=utf8 0 1

J'ai bien pensé à virer cette option (mais je peux pas ecrire dans le /etc/fstab) je sais c'est balo :D donc peut etre avec un cd bootable ...
mais dans tous les cas j'aimerai bien comprendre poruquoi je ne peux plus écrire sur le FS apres une coupure de jus :(

dd@kiss:~$ echo a > a
-bash: a: Système de fichiers accessible en lecture seulement

Sniff sniff sniff merci pour votre aide
  • # workaround ...

    Posté par . Évalué à 1.

    J'ai trouvé un workaround sans booter sur un CD ...
    http://www.linuxsa.org.au/pipermail/linuxsa/1999-December/01(...)

    Mais ca ne m'explique pas pourquoi mon systeme s initialiser en mode normal mais avec les options de read only...
    D'autant que je jn'ai pas d'erreurs dans dmesg...
    Si quelqu'un a plus d infos ...
    • [^] # info complémentaire

      Posté par . Évalué à 1.

      A-tu fait le fsck avec l'option -f (pour forcer le check même si le journal est ok)?

      Sinon j'aurais bien penché pour un problème physique sur le disque, mais tu devrais avoir des erreurs d'E/S dans dmesg ...
      • [^] # Re: info complémentaire

        Posté par . Évalué à 1.

        Bonjour merci pour ce retour (à cette heure tardive :)

        Voici le retour du fsck:
        root@kiss:/home/david# fsck -f /dev/sda1
        fsck 1.41.4 (27-Jan-2009)
        e2fsck 1.41.4 (27-Jan-2009)
        Passe 1 : vérification des i-noeuds, des blocs et des tailles
        Passe 2 : vérification de la structure des répertoires
        Passe 3 : vérification de la connectivité des répertoires
        Passe 4 : vérification des compteurs de référence
        Passe 5 : vérification de l'information du sommaire de groupe
        /dev/sda1 : 342260/5316608 fichiers (0.3% non contigus), 16546036/21239930 blocs

        Par ailleurs, grace a la commande
        mount -t ext4 -o rw,remount /dev/sda1 /
        J'ai pu modifier mon fstab de la sorte
        # <file system> <mount point>
        proc /proc proc defaults 0 0
        # / was on /dev/sda1 during installation
        UUID=2b85a508-2fc9-4d34-8b2a-f5f49d8f69a3 / ext4 rw,relatime,iocharset=utf8 0 1
        /dev/sda2 none swap sw 0 0
        /dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
        /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

        Et j'ai ce résultat pour la commande mount:
        /dev/sda1 on / type ext4 (rw)
        blabla

        Donc si tu me suis je devrais etre en rw ?? et ben surprise:
        root@kiss:/home/dd# echo a > a
        bash: a: Système de fichiers accessible en lecture seulement

        Alors la je comprend plus rien :(
        • [^] # Re: info complémentaire

          Posté par . Évalué à 2.

          je ne sais pas si cela a évolué depuis l'écriture de l'article, mais ext4 ne donne pas envie quand même :

          http://en.wikipedia.org/wiki/Ext4#Delayed_allocation_and_pot(...)

          Si tu as fait un mount remount et que tu as pu modifier /etc/fstab c'est que tu peux bien écrire physiquement dessus. Peut-être qu'un fichier système a été corrompu. Essaye de monter ton système normalement avec un livecd, tu seras un peu mieux fixé sur la cause de ton problème, mais je crois que tu est bon pour une réinstallation (et profite en pour tout sauvegarder, mais tu avais déjà une sauvegarde à jour n'est-ce pas ?).
          Si j'ai bien lu, ton /home et ton / ne sont pas séparés ?

          Moralité, si tu ne veux pas que cela se reproduise, change de copine ou de fs...

          Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

          • [^] # Re: info complémentaire

            Posté par . Évalué à 1.

            Pourquoi réinstaller ?
            • [^] # Re: info complémentaire

              Posté par . Évalué à 1.

              ben ouaip c'est hallucinant en fait...
              Voila ce que j'ai du faire pour que ca fonctionne... (mais ca ne resoud pas le problme dans le fond)

              mount -t ext4 -o rw,remount /dev/sda1 /
              (j'ai ajouté cette ligne dans le rc.local)

              Mais ce que je ne comprend pas c'est la différence avec le fait dans l'entrée dans le fstab et pourquoi au demarrage il se monte en rw (voir l'output du mount) et que malgres tout je ne peux rien ecrire dessus ...

              En fait on dirait que le FS est bien monté en rw... Mais c'est comme si il etait "locké" au demarrage... Enfin je sais pas ce que vous en pensez ...
  • # tune2fs -e continue ?

    Posté par (page perso) . Évalué à 1.

    bin t'as regardé les options du fs ?
    tune2fs -l /dev/sdax | grep 'Errors behavior'

    si c'est remount-ro, t'as trouvé ton problème...
    • [^] # Re: tune2fs -e continue ?

      Posté par . Évalué à 1.

      Bonjour,

      Voici le résultat de la commande:
      tune2fs -l /dev/sda1 | grep 'Errors behavior'
      Errors behavior: Continue


      Par ailleurs j'ai résolu mon problème de la manière suivante:

      J'ai édite le /boot/grub/menu.lst et j'ai remplacé le "ro" par un "rw" sur la ligne kernel...

      Ce qui est bizarre c'est que ça se soit mis en place tout seul

      Quelqu'un a une idée ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.