Forum Linux.général Rsync sur un serveur distant (avec mot de passe en clair)

Posté par (page perso) .
Tags : aucun
1
9
juil.
2009
Bonjour,

J'en vois déjà sauter sur le topic pour s'énerver sur moi en disant que je dois jamais passer le mot de passe en clair et gnia gnia gnia !
S'il vous plaît, ne me demandez pas pourquoi, c'est comme ça!

Je dois donc récupérer une liste de fichiers (liste stockée dans un fichier) à partir d'un serveur.
Je souhaite utiliser rsync car il semble le plus approprié dans ce cas (j'ai un accès ssh sur le serveur).

Seulement je suis un peu (beaucoup ?) paumé !

Je suis parti là dessus :
rsync -e "ssh -o StrictHostKeyChecking=no -pw $DATA_PASSW -l $DATA_USER" --files-from=$BACK_FILE --backup --backup-dir=$DATA_DIR -avzr $SERV_IP:/ $DATA_DIR


Cela ne semble pas fonctionner ... :(

Merci de me filer un petit coup de pouce :)
  • # Rsync sur un serveur distant (avec mot de passe en clair)

    Posté par (page perso) . Évalué à 3.

    Salut,

    Pour ma part je passe par un echange de clefs ssh, comme ca pas besoin de mot de passe et c'est secure :-)
    Tu pousses le .ssh/id_dsa.pub du serveur A dans le .ssh/authorized.keys du serveur B et A se connecte sans passwd a B. Vue que rsync ca marche avec ssh ca passe tout seul.
  • # Simplifie

    Posté par (page perso) . Évalué à 3.

    D'abord vérifie que la ligne ssh seule fonctionne.

    Ensuite pour les options de rsync, r est redondant avec a, es-tu sur de vouloir faire des backup ? Es-tu sur de vouloir transférer tout / ?

    Attention au format de files-from, il doit contenir les fichiers avec le nom exact tel que pris par rsync, donc pas de le répartoire racine dans le nom.
    • [^] # Re: Simplifie

      Posté par (page perso) . Évalué à 1.

      Effectivement, la ligne ssh ne semble pas fonctionner ...
      L'option pw ne semble pas exister malgrès qu'il me semble l'avoir vu quelque part sur le net...

      En fait, je ne veux transférer que certains dossiers/fichiers qui sont stockés dans un fichier ($BACK_FILE est le chemin du fichier)

      Peut être il y a t'il un autre moyen plutôt que d'utiliser rsync ou peut être que je l'utilise mal et qu'il faut repartir de 0 ? :(
      • [^] # Re: Simplifie

        Posté par . Évalué à 2.

        A ma connaissance, ça n'est pas possible avec juste ssh (par contre, sous windows avec putty, enfin plink plus précisément, tu as bien une option -pw)



        Tu peux utiliser http://sourceforge.net/projects/sshpass/ pour faire ça sous Linux.

        (dispo dans les paquets debian)
        • [^] # Re: Simplifie

          Posté par (page perso) . Évalué à 3.

          En effet c'est pas possible avec ssh seul.
          Par contre il est possible d'utiliser expect pour donner le mot de passe à ssh
        • [^] # Re: Simplifie

          Posté par (page perso) . Évalué à 1.

          Très bon paquet que celui ci !

          Ca marche chez moi, merci beaucoup :)
  • # gnia gnia gnia !

    Posté par (page perso) . Évalué à 5.

    Je saute sur le topic pour m'énerver sur toi en disant que tu ne dois jamais passer le mot de passe en clair et gnia gnia gnia !



    Et sinon... un message d'erreur ? :-)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.