Forum Linux.général Samba depuis l'explorateur Windows

Posté par (page perso) .
Tags : aucun
1
9
août
2010
Tient, un problème que je n'ai encore jamais rencontré...

Une machine Debian Lenny avec Samba fait office de serveur. Cette machine est "sur internet" (chez OVH).

J'accède sans aucun problème aux partages Samba depuis la ligne de commande de ma machine Linux perso, et de machines Linux au bureau.

J'y accède également depuis des Windows XP pro et 2003 en ligne de commande (net use x: \\machine.com\partage /user:toto). Vraiment aucun problème.

Par contre, impossible d'y accéder depuis l'explorateur Windows (explorer.exe).
Je mets \\machine.com\partage dans la barre d'adresse, ça me demande identifiant et mot de passe... puis ça me le redemande. Et ensuite j'ai un message d'erreur "Impossible de trouver le fichier ou l'élément \\machine.com\partage. Vérifiez que vous l'avez entré correctement et recommencez, ou à partir du menu Démarrer, cliquez sur Rechercher pour trouver l'élément."

Les journaux ne contiennent rien. Pas une trace de connexion. Je mets "log level = 5" et relance Smaba.
Cette fois j'ai des informations dans les journaux: ça indique que le nom d'utilisateur n'est pas celui que j'indique (toto), mais celui de la session Windows (par exemple Administrateur depuis un serveur Windows 2003).

Question: quelqu'un a une idée de pourquoi ça n'utilise pas le bon nom d'utilisateur ?
Alors que ça fonctionne parfaitement en ligne de commande depuis les mêmes Windows.
  • # utilisateur@machine ou machine\utilisateur

    Posté par . Évalué à 2.

    pour les logins il faut peut-etre utiliser les versions :
    utilisateur@machine ou machine\utilisateur

    sinon il faut verfier les fonctions "parcours de voisinage reseau"
    et les ports associés pour savoir si ca passe bien entre le client et le serveur.
    • [^] # Re: utilisateur@machine ou machine\utilisateur

      Posté par (page perso) . Évalué à 2.

      Problème résolu.

      J'ai posté le pourquoi sur la liste de diffusion Samba, mais ça n'a pas l'air de passer (pourtant je suis inscrit).

      C'est l'utilisation conjointe de:
      netbios name = "whatever"
      disable netbios = yes

      Soit l'un, soit l'autre, pas les deux.

      Je ne sais pas si le bug vient de Samba, d'explorer.exe ou un peu des deux.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.