Forum Linux.général Se connecter sur un réseau virtuel ?

Posté par . Licence CC by-sa
Tags : aucun
1
19
mai
2016

Bonjour,

J'ai un réseau de machines virtuelles, elles utilisent toutes le réseau 192.170.100/24 avec l'interface eth1

De mon poste je ne peux pas faire de ssh pour me connecter sur ce réseau je suis obligé d'ouvrir une machine.

J'ai essayé de créer une interface virtuelle mais ça ne marche pas :

ip link delete eth1
ip tuntap add dev eth1 mode tap
ip addr add 192.170.100.200/24 brd + dev eth1
ip link set dev eth1 up
ip a
eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN qlen 500
    link/ether 82:51:a5:ef:6b:84 brd ff:ff:ff:ff:ff:ff
    inet 192.170.100.200/24 brd 192.170.100.255 scope global eth1

Est-il possible de configurer mon poste pour se connecter sur ce réseau ?

Merci.

  • # il y a de l'idée mais.... ca depend surtout de la techno de virtualisation

    Posté par . Évalué à 5.

    les questions dans l'ordre :
    - ou se trouvent les machines virtuelles sur ta machine ? ou sur un serveur distant ?
    - quelle techno de virtualisation utilises-tu ? virtualbox ? vmware ? kvm ?

    de là dependront les reponses.

    en effet, suivant les technos, il faut juste te brancher la meme carte que celle qui permet aux machines de sortir sur le reseau,
    pour d'autres, c'est un reseau purement privé qui ne peut pas etre acceder de l'exterieur, etc

    • [^] # Re: il y a de l'idée mais.... ca depend surtout de la techno de virtualisation

      Posté par . Évalué à 2. Dernière modification le 19/05/16 à 11:29.

      Bonjour,

      Mes VMs sont sur VirtualBox pour le moment.
      Les VM possèdent deux interfaces :

      eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
      ether 08:00:27:ef:db:35 txqueuelen 1000 (Ethernet)
      RX packets 27 bytes 1134 (1.1 KiB)
      RX errors 0 dropped 0 overruns 0 frame 0
      TX packets 0 bytes 0 (0.0 B)
      TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

      eth1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
      inet 192.170.100.18 netmask 255.255.255.0 broadcast 192.170.100.255
      inet6 fe80::a00:27ff:fe27:4061 prefixlen 64 scopeid 0x20<link>
      ether 08:00:27:27:40:61 txqueuelen 1000 (Ethernet)
      RX packets 172 bytes 23967 (23.4 KiB)
      RX errors 0 dropped 0 overruns 0 frame 0
      TX packets 174 bytes 19874 (19.4 KiB)
      TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

      eth0 (192.168.1/24 en dhcp) est fermé et je ne veux pas l'ouvrir pour être tranquille dans mon réseau.
      De mon poste je souhaiterais donc pouvoir me connecter sur le réseau 192.170.100/24 mais je n'y arrive pas :(

      Toutes mes excuses en voulant cliquer sur répondre je t'ai moinsé
      En faite non je t'ai plussé ;)

      • [^] # Re: il y a de l'idée mais.... ca depend surtout de la techno de virtualisation

        Posté par . Évalué à 3.

        plusieurs options avec tes VMs,

        si c'est un PC fixe, configurer les cartes reseaux en mode "bridge"
        tes VMs seront alors sur le meme reseau que tes machines normales,

        si c'est un PC nomade (un portable par exemple) ou que tu veux vraiment isoler les VMs du reseau ordinaire,
        il faut prendre le mode "host only"
        les VMs sont alors sur un switch virtuel et il faut quand meme configurer la carte vboxnet0 du PC avec une IP dans le meme reseau que les VMs

  • # J'ai un peu avancé mais je ne me connecte toujours pas :-(

    Posté par . Évalué à 2.

    Je me suis crée une VM pour faire mes tests.
    Ça avance mais ce n'est pas encore ça.

    Voici ce que j'ai fait, l'Iface n'est pas running, quand je parcours le web j'ai l'impression d'être le seul à ne pas y arriver :(

    21h27> ip link delete eth1'''
    
    21h27> ip tuntap add dev eth1 mode tap
    21h27> ifconfig eth1
    eth1: flags=4098<BROADCAST,MULTICAST>  mtu 1500
            ether 42:a1:9d:40:6b:6f  txqueuelen 500  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    
    21h27> ip addr add 192.170.100.200/24 brd + dev eth1
    
    21h27> ip link set dev eth1 up
    
    21h27> echo 1 > /proc/sys/net/ipv4/conf/eth1/proxy_arp
    
    21h27> arp -Ds 192.170.100.200 eth0 pub
    
    21h27> ifconfig eth1
    eth1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
            inet 192.170.100.200  netmask 255.255.255.0  broadcast 192.170.100.255
            ether 42:a1:9d:40:6b:6f  txqueuelen 500  (Ethernet)
            RX packets 0  bytes 0 (0.0 B)
            RX errors 0  dropped 0  overruns 0  frame 0
            TX packets 0  bytes 0 (0.0 B)
            TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
    
    
    21h27> netstat -rn
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
    0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0
    192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
    192.170.100.0   0.0.0.0         255.255.255.0   U         0 0          0 eth1
    
    21h27> ping -c 2 192.170.100.5
    PING 192.170.100.5 (192.170.100.5) 56(84) bytes of data.
    From 192.170.100.200 icmp_seq=1 Destination Host Unreachable
    From 192.170.100.200 icmp_seq=2 Destination Host Unreachable
    
    --- 192.170.100.5 ping statistics ---
    2 packets transmitted, 0 received, +2 errors, 100% packet loss, time 1001ms
  • # Host-only networking

    Posté par . Évalué à 2.

    Dans virtualbox et VM, il faut que tu crées un réseau "host-only"

    https://www.virtualbox.org/manual/ch06.html#network_hostonly

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.