Forum Linux.général separate xscreen - multi écran carte Nvidia!

Posté par .
Tags : aucun
1
24
mai
2010
Bonjour,

J'ai installé und euxieme ecran relié a ma carte Nvidia, je souhaiterais avoir 2 sessions X distinctes... (mais qui utilsieraient même souris +clavier) il semble que ce soit ce que l'on appel du separate xscreen...

Le souci c'est que je n'arrive pas a configurer cela via nvidia-settings (vieux bug qui me dit que je ne peux enregistrer dans le fichier xorg.conf malgrès l'execution via sudo...) et même avec un copier coller de la conf généré ca ne fonctionne pas...

Je me suis donc lancé dans l'ecriture du xorg.conf :)

et ca ne fonctionne toujours pas, le deuxieme ecran reste noir, j'ai bien le curseur (mais c'est une croix..) et si je fais un
# export DISPLAY=:0.1
# startkde

Alors il me pete une erreur qui s affiche sur le deuxieme ecran en me disant que pour lui KDE est déjà lancé sur ce DISPLAY...

Voici mon xorg.conf:
Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
Screen 1 "Screen1" LeftOf "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Unknown"
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 1700"
BusID "PCI:15:0:0"
Screen 0
EndSection

Section "Device"
Identifier "Device0 (2nd)"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 1700"
BusID "PCI:15:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device0 (2nd)"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection



Je suis sur que c'est moche mais bon je n'ai pas réussi à faire mieux :D

Merci de votre aide!
  • # DISPLAY=:0.1 ou :1.0 ???

    Posté par . Évalué à 4.

    il me semble qu'il faudrait faire un export DISPLAY=:1.0
    car justement c'est un serveur X different.

    le :0 etant le premier ecran, le :1 serait logiquement le deuxieme.
  • # nvidia-settings

    Posté par (page perso) . Évalué à 2.

    nvidia-settings marche pas trop mal et est plutôt pratique… peut-être que si tu cherches un peu plus ou si tu nous donne des infos tu pourrais trouver une astuce. Je dis ça par-ce que à un moment aussi j'arrivais pas à écrire le xorg.conf en passant par le logiciel sous debian, je sais plus comment je m'en suis sorti mais je n'y ai pas passé trop de temps je crois.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.