Forum Linux.général Sortie VGA sur un Thinkpad W520

Posté par . Licence CC by-sa
2
29
nov.
2015

Bonjour,
Je suis l'heureux acquéreur d'un Thinkpad W520 d'occasion tout neuf et je viens d'installer Debian dessus. Tout fonctionne très bien, à l'exception cependant de la sortie VGA qui n'est pas détectée (j'imagine qu'il en va de même des sorties HDMI et DVI mais je n'ai rien pour les tester).
Je précise tout d'abord qu'il s'agit d'un PC avec Optimus, j'ai donc installé bumblebee et le pilote propriétaire nvidia. Ça marche très bien (testé sur divers jeux vidéos assez gourmands, c'est très fluide).
Cependant, d'après mes recherche sur le Web, ce modèle fait partie de quelques qui ont la sortie VGA branchée à la carte nVidia plutôt qu'à la carte Intel. C'est donc normal que ça ne fonctionne pas. J'ai essayé la procédure décrite par exemple ici utilisant l'utilitaire intel-virtual-output.
Cependant, lorsque je lance l'utilitaire, le second écran n'est pas détecté par xrandr :

felixzero@ln2:~$ optirun true
felixzero@ln2:~$ intel-virtual-output 
felixzero@ln2:~$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
LVDS1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080     60.00*+  59.93    50.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1360x768      59.80    59.96  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
VGA1 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

Je précise que la sortie VGA fonctionnait sous Windows (ce n'est donc pas un problème matériel).
Voici, pour information, mes fichiers de configurations:

felixzero@ln2:~$ cat /etc/bumblebee/bumblebee.conf | cut -d'#' -f1
[bumblebeed]
VirtualDisplay=:8
KeepUnusedXServer=true
ServerGroup=bumblebee
TurnCardOffAtExit=false
NoEcoModeOverride=false
Driver=nvidia
XorgConfDir=/etc/bumblebee/xorg.conf.d

[optirun]
Bridge=auto
VGLTransport=proxy
PrimusLibraryPath=/usr/lib/x86_64-linux-gnu/primus:/usr/lib/i386-linux-gnu/primus:/usr/lib/primus:/usr/lib32/primus
AllowFallbackToIGC=false

[driver-nvidia]
KernelDriver=nvidia-current
PMMethod=none
LibraryPath=/usr/lib/x86_64-linux-gnu/nvidia:/usr/lib/i386-linux-gnu/nvidia:/usr/lib/nvidia
XorgModulePath=/usr/lib/nvidia,/usr/lib/xorg/modules
XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

[driver-nouveau]
KernelDriver=nouveau
PMMethod=none
XorgConfFile=/etc/bumblebee/xorg.conf.nouveau

felixzero@ln2:~$ cat /etc/bumblebee/xorg.conf.nvidia | cut -d'#' -f1              
Section "ServerLayout"
    Identifier  "Layout0"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"
    Option "ProbeAllGpus" "false"
    Option "NoLogo" "true"
    Option "UseDisplayDevice" "none"
EndSection

Si quelqu'un a une idée ou déjà rencontré ce problème, je suis preneur.
felixzero

  • # le commencement

    Posté par . Évalué à 3. Dernière modification le 29/11/15 à 18:56.

    quand tu demarres la machine, vois-tu le demarrage sur les 2 ecrans ?
    que dit la commande lspci | grep -i vga ?

    le principe d'optimus c'est qu'il y a bien 2 cartes, mais la carte 3D (nvidia) envoie l'image calculée à la carte Intel, qui se charge de l'afficher.

  • # à tenter ?

    Posté par . Évalué à 1.

    Est-ce que tu as essayer ces commandes ?
    ~# prime-select intel ou ~# prime-switch intel
    il faut redémarrer le serveur X11 aussi. Inspiré de cette source : install-configure-nvidia-optimus-driver-ubuntu

    • [^] # Re: à tenter ?

      Posté par . Évalué à 1.

      Après recherche, prime-select et prime-switch proviennent du paquet nvidia-prime incompatible avec bumblebee et disponible uniquement sous Ubuntu.
      Ça peut être une solution mais je suis dans l'incapacité de la tester dans l'immédiat. J'essaierai en installant une Ubuntu sur une clé USB en mode persistant pour voir si ça marche mieux que bumblebee.

      • [^] # Re: à tenter ?

        Posté par . Évalué à 1.

        Bon, j'ai installé Kubuntu sur un disque dur externe et installé prime. prime-select semble marcher (après redémarrage de X), mais pas plus de succès pour détecter l'écran externe.

        root@test-kubuntu:/home/felixzero# xrandr
        Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
        LVDS-0 disconnected (normal left inverted right x axis y axis)
        DP-0 disconnected (normal left inverted right x axis y axis)
        DP-1 disconnected (normal left inverted right x axis y axis)
        DP-2 disconnected (normal left inverted right x axis y axis)
        DP-3 disconnected (normal left inverted right x axis y axis)
        DP-4 disconnected (normal left inverted right x axis y axis)
        DP-5 disconnected (normal left inverted right x axis y axis)
        LVDS-1-0 connected primary 1920x1080+0+0 344mm x 193mm
           1920x1080     60.00*+  59.93    50.00  
           1680x1050     59.95    59.88  
           1600x1024     60.17  
           1400x1050     59.98  
           1280x1024     60.02  
           1440x900      59.89  
           1280x960      60.00  
           1360x768      59.80    59.96  
           1152x864      60.00  
           1024x768      60.04    60.00  
           960x720       60.00  
           928x696       60.05  
           896x672       60.01  
           960x600       60.00  
           960x540       59.99  
           800x600       60.00    60.32    56.25  
           840x525       60.01    59.88  
           800x512       60.17  
           700x525       59.98  
           640x512       60.02  
           720x450       59.89  
           640x480       60.00    59.94  
           680x384       59.80    59.96  
           576x432       60.06  
           512x384       60.00  
           400x300       60.32    56.34  
           320x240       60.05  
        VGA-1-0 disconnected
        
  • # La solution

    Posté par . Évalué à 1.

    J'ai trouvé la solution au problème, je la poste ici pour toi étranger qui aura le même problème en juillet 2017.

    Il faut commenter la ligne suivante du xorg.conf.nvidia :

    Option "UseDisplayDevice" "none"
    

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.