Forum Linux.général touche Compose

Posté par .
Tags : aucun
1
20
sept.
2010
J'appelle à l'aide parce que je cherche depuis plusieurs heures, et j'ai fait plusieurs essais, mais je n'obtiens pas ce que je souhaite.

Pour aller au plus court : je ne souhaite pas de touche "Compose" sur mon clavier.

Avant que je n'éteigne mon système, mon clavier marchait comme je voulais ; mais depuis ce matin ce n'est plus le cas. Ma touche [Control_L] est devenue [Compose].

Je suis sous UNR "10.04.1 LTS" et j'ai tenté :
1 - "$ xev" pour voir si cette touche n'était pas HS
2 - l'interface de Gnome pour affecter [Compose] à une autre touche ; ça marche dans le sens où j'ai une 2ème touche [Compose] !
3 - "$ xmodmap -e 'keycode 37 = Control_L'" et xev est content ; moi pas, ça ne change rien à ce que me fait mon clavier
4 - de créer "~/.Xmodmap" avec la ligne "keycode 37 = Control_L" ; il est bien pris en compte au login, mais ça ne change toujours rien à ce que me rend mon clavier
5 - par l'interface de Gnome, de passer par un clavier "français autre", "espagnol", "américain", etc...
6 - et de me délogguer/relogguer, comme de rebooter dans l'espoir qu'un cache inopiné ne veuille s'effacer ; mais je suis resté vainement incompris...

Maintenant, je suis dépité !
Voici mon cri :

Je veux retrouver mon clavier français _avec ma touche contrôle en bas à gauche_, sans touche [Compose] inopportune.

· Quelqu'un a-t-il déjà rencontré un problème similaire ?
· Quelqu'un l'aurait-il déjà résolu ?
→ Si oui, comment ?
→ Comment descotcher [Compose] de ma touche contrôle ?

Merci beaucoup, d'avance.


--
Daniel
  • # utilsateur vierge ?

    Posté par . Évalué à 2.

    tu as essayé de creer un nouvel utilisateur, pour voir si lui aussi à le probleme ?

    car apparemment jusqu'au login tout va bien, c'est apres que ca deconne
    donc ce serait lié au profil utilisateur.

    à voir ensuite dans les programmes qui se lancent au demarrage, si y a pas l'assistant pour personne handicapé, ou un truc qui remapperait les touches.
  • # Peut-etre avec la méthode "officielle" ?

    Posté par . Évalué à 1.

    As tu essayé la méthode "officielle" ?
    Système/Préférences/Clavier
    Onglet Agencement puis bouton Options
    Dans la liste "Position de la touche Compose" ...


  • # La solution que j'ai adoptée

    Posté par . Évalué à 2.

    Bonjour,

    Bonne nouvelle, j'ai retrouvé ma touche [Control_L] !

    @NeoX : merci pour les suggestions
    @guy : Oui, j'ai suivi la méthode officielle. C'est ma démarche que j'ai étiquetée "2".

    Pour information, j'ai suivi ce témoignage <http://ubuntuforums.org/showthread.php?t=1517120#3>.

    Donc :
    1/ $ gconf-editor
    2/ sélectionner la clé /desktop/gnome/peripherals/keyboard/kbd/options
    3/ cliquer droit, et prendre "Désactiver la clé"

    La clé indiquait des options, dont l'affectation de la fameuse touche morte [Compose].

    Gnome semble stocker ça dans ~/.gconf/desktop/gnome/peripherals/keyboard/kbd/%gconf.xml

    Pourquoi Ubuntu ne me permettais pas de révoquer mes choix précédents ? Cela reste encore en question.

    Ça m'apprendra à utiliser des interfaces graphiques...
  • # Situation perverse

    Posté par . Évalué à 1.

    Maintenant, j'aimerais reproduire le présumé bug, mais je n'y arrive pas...

    Le monde est vraiment imparfait... ;-)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.