Forum Linux.général Xen - Difficulté pour faire fonctionner les conteneurs

Posté par (page perso) . Licence CC by-sa
Tags :
1
19
jan.
2016

Bonsoir,

sur une Debian 8, j'ai installé xen-tools et tout ce qu'il faut (en principe) pour faire fonctionner Xen.
xen-linux-system-…

Le grub à été modifié pour lancer le noyau avec le support de Xen.

J'arrive à créer mes conteneurs.
Lorsque je démarre mes conteneurs avec : xl create -c /etc/xen/conteneur.cfg
je peux voir le démarrage, mais au moment du login tout est figé.

Je peux aussi afficher la console avec xl console conteneur
mais c'est figé.

J'ai bien mes conteneurts qui tournent… mais je ne peux rien faire.

J'ai essayé avec Debian en testing, sans plus de résultat.

Est ce que vous arrivez à installer Xen et à y faire fonctionner des conteneurs?
J'ai essayé les différentes config à propos de "xen hang" et autres mots-clefs sans succès.

Je suis prêt à reprendre l'installation depuis le début.

:~# cat /sys/hypervisor/properties/capabilities
xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64
Donc, j'ai bien un Kernel avec Xen. (de toute façon, sans, j'aurai pas pu lancer les conteneurs)

Par quoi devrais-je commencer? Où chercher?

  • # noyau 3.16 ok

    Posté par (page perso) . Évalué à 1.

    j'ai eu le même genre de problèmes la semaine dernière, mais en utilisant un kernel 3.16 c'est passé.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.