Forum Linux.général Xorg mange toute ma mémoire

Posté par (page perso) .
Tags : aucun
1
4
fév.
2009
Xorg est méchant, il consomme lentement mais sûrement toute la ram que j'ai.

C'est à dire qu'après l'avoir démarré, il consomme environ 100mo de ram (compiz, applications ouvertes). Pour consommer 300mo en fin de journée (j'éteins mon ordinateur, pour consommer de l'électricité, j'ai mes serveurs).

Par contre, si je lance un jeu en 3D, il va remplir la mémoire, et une fois celle-ci saturée (au bout de 3 minutes en gros), tout devient lent du fait des accès mémoires pour allouer, dés-allouer.

Et une fois le jeu quitté, il ne dés-alloue pas la ram. Obligé de relancer Xorg…

Ça ressemble donc fortement a un «memory leak». J'ai une carte intel (GMA X3100).
Et ce que je sais, c'est que ça ne le faisais pas il y a quelques mois.

Donc, que faire ?
  • # driver ? distribution ?

    Posté par . Évalué à 2.

    quelle est ta distribution ?
    quel driver utilises-tu pour ta carte graphique ?

    que dit google à ce sujet ?
    • [^] # Re: driver ? distribution ?

      Posté par (page perso) . Évalué à 2.

      C'est ubuntu, et le driver est celui d'intel.

      Google me propose des vieux trucs à ce sujet. Xorg a du bien changer entre-temps.

      Envoyé depuis mon lapin.

  • # ?

    Posté par . Évalué à 2.

    Tu peux peut-être regardé avec xrestop pour voir si ce n'est pas un programme qui remplit X avec ses pixmap, mais ça resemble plutot a un probleme Xorg/compiz, as-tu essayé de désactiver compiz et de relancer pour voir si le probleme est toujours le meme?
    • [^] # Re: ?

      Posté par (page perso) . Évalué à 2.

      Quand je n'ai pas compiz, c'est pareil.

      Par contre, là xrestop m'annonce 80mo de ram occupé, alors que ps m'en annonce 650… il y a bien une petite fuite…

      Envoyé depuis mon lapin.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.