Forum Linux.gentoo Wifi DLink DWL-G520 et AMD64

Posté par (page perso) .
Tags : aucun
0
9
jan.
2006
Bonsoir,

J'ai un problème pour configurer mon réseau Wifi :

Le matériel :
- D-Link DWL G520, Atheros
02:06.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

- le routeur : un Linksys WRT54G
- le PC : Shuttle SN95G5, AMD64 X2

Côté Linux, on a une Gentoo 2005.1 (en i686 parce que ca ne passait pas x86_64, donc j'essaie pour l'instant en 32 bits... )avec madwifi-(tools|driver)-0.1372.20051231 de [1] et un 2.6.15 avec les 2 options qu'il faut (CONFIG_NET_RADIO et CONFIG_NET_WIRELESS). Les modules chargé sont :
- ath_pci
- ath_hal
- wlan_scan_ap
- wlan_ccmp
- wlan_xauth
- wlan_acl

J'ai bien créé le périphérique avec
# wlanconfig ath0 create wlandev wifi0 wlanmode sta


Pour le réseau, j'ai pour l'instant mon routeur qui est fonctionnel quand on est branché par câble, qui broadcast son ESSID (a52g) et qui n'a pas de protection autre (WPA viendra plus tard). Il fait serveur DHCP, côté câble comme Wifi.

Pour ce que j'ai tenté jusque maintenant :

1) Le dhcp:
# dhcpcd ath0

== > rien

2) on essaie donc plus subtilement avec /etc/conf.d/wireless :
essid_ath0="a52g"
config_a52g=( "dhcp" )
dhcpcd_a52g="-t 5"
channel_ath0="11"
prefered_aps="a52g"
unique_ap="yes"

# /etc/init.d/net.ath0 start
* Starting service net.ath0 [ !! ]
* FAILED to start service net.ath0!


Alors voilà, je me demande
- soit ce que je fais de mal (je n'ai pas tenté que ce qui est décrit au dessus (WPA, tout en fixe, version 20050420 de madwifi, ...))
- si la carte est supportée sur un AMD64
- si jamais quelqu'un a déjà réussi à faire fonctionner ce type de config...

Merci,

[1]
http://dev.gentoo.org/~brix/files/overlay
  • # L'association au routeur ?

    Posté par (page perso) . Évalué à 2.

    Avant de pouvoir faire une demande d'adresse IP tu dois t'associier au router.

    Maintenant, pour te connecter, commence par essayer de le faire en ligne de commande. En tant que root tu fais la suite de commandes suivantes pour t'associer à l'Access Point:

    iwconfig ath0 essid NOM_ESSID
    iwconfig ath0 mode managed

    Selon la carte wifi on peu abréger cette suite en une seule commande:

    iwconfig ath0 essid NOM_ESSID mode managed


    Maintenant, tu peux t'attribuer une addresse IP par dhcp:

    dhcpcd ath0
  • # cela doit pouvoir marcher

    Posté par . Évalué à 3.

    J'ai la même config que toi (même carte réseau, même routeur et AMD64) et chez moi ça marche (sous ubuntu 64 bits).

    Le seul module que je me préoccupais de charger est ath_pci. La configuration sous Debian à l'air différente que sous gentoo. Chez moi mon fichier /etc/network/interfaces est
    [...]
    iface ath0 inet dhcp
    wireless_keymode open
    wireless_mode managed
    wireless_essid cassiopee
    wireless_rate auto
    wireless_key1 ...
    wireless_key2 ...
    wireless_key3 ...
    wireless_key4 ...
    wireless_defaultkey 4
    Peut-être que cela peut te donner des idées.

    Le WAP est aussi supporté (faudra que je pense à le mettre en place mais je suis fainéant)
    • [^] # Re: cela doit pouvoir marcher

      Posté par (page perso) . Évalué à 1.

      je pense qu'effectivement le problème doit venir du "wireless_mode managed"; je n'y avais pas encore touché

      Par contre, le "keymode open", c'est pour le WEP ?
      • [^] # Re: cela doit pouvoir marcher

        Posté par . Évalué à 2.

        Et bien j'avoue que je ne me souviens plus. Cela fait un petit temps que j'ai configuré cette connexion. Si quelqu'un pouvait me rappeler à quoi ça sert, je serais aussi intéressé
        • [^] # Re: cela doit pouvoir marcher

          Posté par (page perso) . Évalué à 1.

          wireless_keymode : c'est bien pour le WEP; après la différence avec "restricted"...

          Sinon, ça a bien l'air d'être le "mode managed" qui manquait.
          Ca m'a aussi permis de constater que j'avais un peu mis le bronx au niveau de la configuration du routeur. J'ai mis seulement le WEP pour l'instant, et ça passe comme une lettre à la poste (tout du moins avec le CD live de ubuntu).

          Ne reste plus maintenant qu'à faire la même chose avec une Gentoo amd64...

          Mais je sais au moins que c'est faisable et compatible.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.