• # Raspbian = deBIAN sur RASPberry

    Posté par . Évalué à 3.

    Rasbian on a du mal à configurer le Wifi en mode graphique. Il y a-t-il une méthode en mode texte

    donc je dirais qu'il suffit de faire comme pour debian

    • [^] # Re: Raspbian = deBIAN sur RASPberry

      Posté par . Évalué à 0. Dernière modification le 11/02/17 à 17:17.

      Je rejoins la question de @papap.
      Avant pixel j'étais obligé de passer par l'interface graphique pour fixer l'IP de mes RPI. Depuis Pixel je suis bloqué (ma solution c'est d'installer un raspbian datant d'avant pixel, fixer l'IP via GUI puis mettre a jours et espérer que je ne devrai jamais changer la config réseau).

      J'ai déjà testé plusieurs tuto qui ont irrémédiablement échoués (config réseau break) donc si quelqu'un à une solution qui a fait ses preuves (en IPv4 ET IPv6), je suis preneur aussi.

      Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

      • [^] # Re: Raspbian = deBIAN sur RASPberry

        Posté par . Évalué à 3.

        @eaufroide : avec wifi ou sans wifi ?

        SANS wifi, en supposant que la carte reseau soit eth0
        et que ton reseau soit 192.168.x.0/24

        en dhcp :
        =========================
        /etc/network/interfaces : 
        auto eth0
        iface eth0 inet dhcp
        =========================
        
        avec IP fixe
        =========================
        /etc/network/interfaces :
        auto eth0
        iface eth0 inet static
        address 192.168.x.y
        netmask 255.255.255.0
        gateway 192.168.x.z
        
        /etc/resolv.conf
        nameserver 8.8.8.8
        =========================
        • [^] # Re: Raspbian = deBIAN sur RASPberry

          Posté par . Évalué à 0. Dernière modification le 11/02/17 à 17:49.

          Je viens d'essayer sur un RPI qui avait déjà une IP fixé par la GUI que j'essaye justement de changer et elle continue de s'attribuer l'IP précédemment fixé.
          Dans /etc/network/interfaces avant que je ne teste ta solution j'avais

          iface eth0 inet manual
          

          Et aucune information concernant l'ip, la passerelle ni le netmask. (je ne comprends donc pas comment la GUI fait pour fixer l'IP)

          Je n'ai pas encore testé ta solution sur une installation fraîche (il faut que je benchmark f2fs et php7 avec ce RPI pour mes tuto avant de le formater)

          Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

          • [^] # Re: Raspbian = deBIAN sur RASPberry

            Posté par . Évalué à 3.

            Et aucune information concernant l'ip, la passerelle ni le netmask. (je ne comprends donc pas comment la GUI fait pour fixer l'IP)

            l'interface grpahique doit utiliser l'outil 'network-manager'

            si tu veux utiliser le fichier /etc/network/interfaces, il faut supprimer le paquet network-manager

            • [^] # Re: Raspbian = deBIAN sur RASPberry

              Posté par . Évalué à 0. Dernière modification le 11/02/17 à 18:29.

              Package "network-manager" is not installed, so not removed
              

              J'ai bien désinstallé un paquet "net-tools" mais cela ne change rien.

              PS: ça n'existe pas une petite CLI pour gérer les IP? ^ ^

              Merci de toujours apporter ta pierre à l'édifice NeoX :)

              Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

              • [^] # Re: Raspbian = deBIAN sur RASPberry

                Posté par . Évalué à 3.

                PS: ça n'existe pas une petite CLI pour gérer les IP? ^ ^

                ben l'editeur de texte et les deux fichiers
                /etc/network/interfaces
                /etc/resolvf.conf

                devrait se suffire à eux meme.

                mais visiblement il y a un service supplementaire sur rasbian pour gerer les IPs
                faut aller lire les documentations

              • [^] # Re: Raspbian = deBIAN sur RASPberry

                Posté par . Évalué à 2.

                Moi pour la config je fais clic-droit sur le symbole réseau en haut à droite -> wireless and wired settings -> et j'ai une IHM pour fixer l'IP.

                Et effectivement l'IP fixe WLAN que je mets dedans n'est pas dans /etc/network/interfaces (ni dans interfaces.d).

                L'ip eth0 y est, mais je ne sais pas si elle est utilisée (ou si le gestionnaire de réseau la bypasse comme pour wlan0).

                Je suis aussi intéressé pour déclencher en ligne de commande le mode attente WPS de mon routeur pour la config du WLAN :p

                • [^] # Re: Raspbian = deBIAN sur RASPberry

                  Posté par . Évalué à 0.

                  Moi pour la config je fais clic-droit sur le symbole réseau en haut à droite -> wireless and wired settings -> et j'ai une IHM pour fixer l'IP.

                  Cet applet semble avoir disparut avec pixel. Même sur la version de raspbian que j'ai (une version antérieur a pixel que j'ai update après install) je ne vois plus l'applet.

                  Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

                  • [^] # Re: Raspbian = deBIAN sur RASPberry

                    Posté par . Évalué à 2.

                    (une version antérieur a pixel que j'ai update après install) je ne vois plus l'applet.

                    parce que tu as desinstallé le network-manager, ou net-tools
                    et donc le nm-applet generalement utilisé

                    • [^] # Re: Raspbian = deBIAN sur RASPberry

                      Posté par . Évalué à 0.

                      Non je n'ai désinstallé net-tools qu'après ton message et l'applet n'était déjà plus présent avant (si non j'aurai déjà fais mes benchmarks :P)

                      Donation Bitcoin : 1N8QGrhJGWdZNQNSspm3rSGjtXaXv9Ngat

                • [^] # Re: Raspbian = deBIAN sur RASPberry

                  Posté par (page perso) . Évalué à 2.

                  Moi pour la config je fais clic-droit sur le symbole réseau en haut à droite -> wireless and wired settings -> et j'ai une IHM pour fixer l'IP.
                  J'ai bien l'IHM:il me demande un code;je le rentre,et ça ne marche pas. L'IHM est peu bavarde,contrairement à ce qu'on peu voir ailleurs sous Linux ou autre:je choisi le SSID (l'émetteur wifi)et il n'y a aucun autre para mètre demandé que le code wifi. D'ailleurs,ce n'est pas clair que c'est bien ça qu'il demande. Autre chose, en Freewifi ou Freeorange ça marche.

                  • [^] # Re: Raspbian = deBIAN sur RASPberry

                    Posté par . Évalué à 3.

                    Autre chose, en Freewifi ou Freeorange ça marche.

                    donc si ca marche avec les WIFI sans code
                    c'est que tu te vautres dans le code de ton wifi

                    ouvre un editeur de texte et verifie si tu es en clavier azerty ou qwerty

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.