Forum Linux.mandriva lenteur avec mandrake 10

Posté par .
Tags : aucun
0
14
sept.
2004
bonjour

j'ai installé récemment mandrake 10 sur mon pc (sous windows j'ai mis le cd puis cliqué sur installer, tout simplement... et j'ai pris les options d'installations basiques et automatiques)
l'installation semble avoir marchée mais ça rame énormément (comparé aux mêmes opérations sous winxp) que ce soit pour ouvrir une application, une page internet, passer d'une page à l'autre...
j'ai donc parcouru les forums et j'ai trouvé la solution suivante : désactiver ipv6 en allant dans : /etc/modprobe.conf et ajouter la ligne : alias net-pf-10 off

donc j'ai fait ça :

[germaine@ germaine]$ su -
Password:
[root@ root]# vi /etc/modprobe.conf

puis j'ai ajouter la ligne en question ici, à la fin :

alias ieee1394-controller ohci1394
alias sound-slot-0 snd-intel8x0
alias eth0 e100
install scsi_hostadapter /sbin/modprobe usb-storage; /bin/true
install snd-intel8x0 /sbin/modprobe --first-time --ignore-install snd-intel8x0 && { /sbin/modprobe snd-pcm-oss; /bin/true; } install usb-interface /sbin/modprobe usb-uhci; /sbin/modprobe ehci-hcd; /bin/true remove snd-intel8x0 { /sbin/modprobe -r snd-pcm-oss; } ; /sbin/modprobe -r --first-time --ignore-remove snd-intel8x0 ~
~
~
~
~
~
~
~
~
~
~
~
~
"/etc/modprobe.conf" [lecture-seule] 7L, 470C 1,1 Tout

(en mode édition)
puis j'ai redémarré le pc
depuis, ça n' as rien changé, sauf que quand je veux retourner dans : /etc/modprobe.conf je tombe sur ça :

E325: ATTENTION
Trouvé un fichier d'échange nommé "/etc/.modprobe.conf.swp"
propriété de: root daté: Mon Sep 13 12:46:12 2004
nom de fichier: /etc/modprobe.conf
modifié: OUI
nom d'utilisateur: root nom d'hôte: .
processus n°: 2640
Lors de l'ouverture du fichier "/etc/modprobe.conf"
daté: Mon Sep 13 21:46:10 2004
PLUS RÉCENT que le fichier d'échange !

(1) Un autre programme est peut-être en train d'éditer ce fichier.
Si c'est le cas, faites attention à ne pas vous retrouver avec deux version différentes du même fichier en faisant des modifications. Quittez, ou continuez prudemment.

(2) Une session d'édition pour ce fichier a planté.
Si c'est le cas, utilisez ":recover" ou "vim -r /etc/modprobe.conf" pour récupérer les changements (voir ":help recovery").
Si vous l'avez déjà fait, effacez le fichier d'échange "/etc/.modprobe.conf.
swp"
pour éviter ce message.
Le fichier d'échange "/etc/.modprobe.conf.swp" existe déjà !
[O]uvrir en lecture seule, (E)diter quand même, (R)écupérer, (Q)uitter, Le (s)up primer:


et quand je vais voir la ligne que j’avais ajoutée a disparue !!!

je suis totalement débutant dans linux donc la je sais plus trop quoi faire !
si quelqu’un a la solution, qu’il n’hésite pas
merci
  • # HUm

    Posté par (page perso) . Évalué à 1.

    J'ai lu en diagonale et il est tard, donc pour m'occuper simplement du problème vi, s'il te dis ce message d'erreur, c'est que tu as quitté vi comme un crado, alors que pour prendre en compte ta modification il faut sauver et sortir proprement en faisant <:> <entrée>
    • [^] # Re: HUm

      Posté par . Évalué à 2.

      je pense aussi, et le fichier n'a donc surement pas été modifié, donc normal que rien ne change

      sinon pour enregistrer et quitter vi c'est :wq[Entrée] qu'il faut faire (après avoir fait [Echap] pour sortir du mode édition)
      • [^] # Re: HUm

        Posté par (page perso) . Évalué à 1.

        oui merde mes "touches" ont été mangées par templeet...
        Jles mettrai entre [] la prochaine fois... :)
    • [^] # Re: HUm

      Posté par . Évalué à 1.

      oups !
  • # bizzare

    Posté par (page perso) . Évalué à 2.

    sous mandrake je ne me souviens plus, mais vérifie quand même si tu n'as pas un fichier /etc/modprobe.d/aliases
    C'est dans ce fichier qu'il faut faire la modif, car /etc/modprobe.conf est régénéré automatiquement à partir des fichiers de /etc/modprobe.d/
    Il faut commenter la ligne
    #alias net-pf-10 ipv6
    et ajouter la ligne
    alias net-pf-10 off

    Mais je ne vois pas pourquoi ça ralentirait la machine, à part peut-être pour les transferts réseau.
    C'est lent comment ? Comme s'il y avait un timeout réseau (tu cliques, ça vient au bout de 30s), ou bien lent vis à vis de la fluidité ?

    Sinon à tout hasard, et pour que ça soit écrit quelque part, j'ai été confronté récemment à un pb de ralentissement énorme (la machine mettait 20m à booter) sur mdk10. En fait c'était à cause d'un chipset serial-ATA mal supporté. En désactivant ce chipset dans le bios, tout allait mieux.
    Parfois aussi, l'option "legacy USB" dans le bios fout la merde. Mais là ça bloque complètement le boot.
    • [^] # Re: bizzare

      Posté par . Évalué à 1.

      c'est ça je clique et il faut 30s pour que ça s'ouvre, que ce soit sur internet ou pour lancer un programme

      je ne trouve pas /etc/modprobe.d/aliases non plus

      je vais tout de même jeté un oeil dans le bios
      merci pour les infos
      • [^] # Re: bizzare

        Posté par (page perso) . Évalué à 2.

        Verifie que tes disques sont en UDMA :

        #hdparm -d /dev/hda
      • [^] # Re: bizzare

        Posté par (page perso) . Évalué à 2.

        Vérifie dans le fichier /etc/hosts que tu as bien :
        1) une ligne 127.0.0.1 localhost
        2) une autre ligne avec ton_adresse_IP ton_hostname

        Si tu n'as pas d'adresse IP, tu devrais avoir plutôt une ligne
        127.0.0.1 localhost ton_hostname


        Ca ressemble à un probleme de résolution de nom DNS
        Ca veut dire probablement que ta machine ne trouve pas l'adresse IP qui correspond à ton hostname. Ca ralentit aussi en local, parce que le serveur d'affichage (X11) a besoin de savoir où afficher les fenêtres. (on peut les faire afficher sur une machine distante par le réseau)
        • [^] # Re: bizzare

          Posté par . Évalué à 1.

          bon ben je vais essayé de m'atteler à tout ça. je crois qu'en fait j'ai grand besoin de faire quelque lectures sur linux avant ...

          je te donnerais des nouvelles dès que j'aurais un peu avancé !
          • [^] # Re: bizzare

            Posté par . Évalué à 1.

            J'ai le même problème de lenteur avec ma Mandrake. J'ai lu plus haut que ce pouvait être un pb de réseau.
            Sur mon poste, lors de ma séquence de boot, il y a une ligne Eth0 sur laquelle l'odinateur bloque (longtemps lorsque je ne suis pas relié à la connection, très court quand je suis relié). Mais au final, j'ai toujours un échec, puis le chargement continue normalement. Donc deux question.

            D'une part, pourquoi ais-je toujours un échec alors la connection fonctionne sans problème ?
            D'autre part, cela peut-il être en relation avec la lenteur de chargement des applications ?

            Petite précision : je suis connecté par modem-câble, donc en LAN.

            Merci bcp.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.