Forum Linux.mandriva pd d acceleration 3D avec ma Radeon9700Pro sous LE2005

Posté par .
Tags : aucun
0
11
sept.
2005
Bonjour cher amis fans de la marche de l'empereur Tux. Testant linux de temps à autre pour voir l'évolution de Mandriva avant d'y passer dessus. je voudrais jouer en 3D. j ai donc telechargé le "ati-driver-installer-8.16.20-i386.run" que j'ai lancer en aillant fait precedemment "su". jai par la suite lancé fglrxconfig pour finir la configuration de la bete et j'ai rebooté.

j ai lancé glxgears qui renvoie
280 frames in 5.0 seconds = 56.000 FPS
840 frames in 5.0 seconds = 168.000 FPS
700 frames in 5.0 seconds = 140.000 FPS
840 frames in 5.0 seconds = 168.000 FPS
700 frames in 5.0 seconds = 140.000 FPS
840 frames in 5.0 seconds = 168.000 FPS

j'ai ensuite lancé
fgl_glxgears et j'ai la réponse :
X Error of failed request: BadMatch (invalid parameter attributes)
Major opcode of failed request: 142 (GLX)
Minor opcode of failed request: 5 (X_GLXMakeCurrent)
Serial number of failed request: 32
Current serial number in output stream: 32

Par ailleurs j'ai testé aussi en installant Point2play et Cedega pour faire tourner les jeux Win32 et il me dit que mon acceleration 3d fonctionne pas.

Ma question est simple:
Comment l'activer cette acceleration?
  • # beh...

    Posté par (page perso) . Évalué à 2.

    "cat /var/log/Xorg.0.log | grep EE"
    a poster ici meme merci...
    • [^] # Résultats commande

      Posté par . Évalué à 1.

      cat /var/log/Xorg.0.log | grep EE
      (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
      (II) Loading extension MIT-SCREEN-SAVER
      (EE) fglrx(0): DRIScreenInit failed!

      volia
  • # C'est simple:

    Posté par (page perso) . Évalué à 2.

    L'intallateur ATI est une bouse... télécharge la version rpm
    1. passe root
    su -
    2. intalle les source du kernel
    urpmi kernel-source-2.6
    3. Passe en console
    init 3
    4. Installe le rpm:
    rpm -Uvh --force ton_driver_ati.rpm
    5. lance l'outil de config (j'espère que tu as gardé la doc de ton moniteur pour les fréquences d'affichage)
    fglrxconfig
    Plus d'infos ici http://lea-linux.org/hardware/hard_image/atifglrxrpm.html(...)
    6. Repasse en mode graphique
    exit
    relogue toi avec ton compte utilisateur
    relance ta session graphique
    startx

    C'est fini ! J'avais tenté 3 fois l'install avec leur installateur pourri, ça a jamais marché, avec la méthode traditionnelle, ça marche tout seul !
    • [^] # Re: C'est simple:

      Posté par . Évalué à 1.

      ou je peux trouver les fucking libstdc++.so.5 libstdc++.so.5(CXXABI_1.2) et
      libstdc++.so.5(GLIBCPP_3.2),?? requis pour le RPM

      Je ne pensais pas que l'installation des pilotes etait si compliquée ! :-)

      A quand un open Direct X ? ca faciliterairt pas mal le bouzin comme on dit chez nous.

      Merci en tout cas pour votre aide
      • [^] # Suite de l 'aventure

        Posté par . Évalué à 1.

        Ta méthode ne marchant pas je tenta de suivre le tuto de lea linux.

        Tout ce passe bien jusqu 'a l'étape du fglrx.ko qui est manquant. je suit le tuto et je fait :

        [root@localhost build_mod]# sh make.sh
        ATI module generator V 2.0
        ==========================
        initializing...
        Error:
        kernel includes at /usr/src/linux/include do not match current kernel.
        they are versioned as ""
        instead of "2.6.11-6mdk".
        you might need to adjust your symlinks:
        - /usr/include
        - /usr/src/linux

        /usr/include j ai rien trouvé
        /usr/src/linux raccourci qui renvoie vers file:/usr/src/linux-2.6.11-12mdk.
        Je renomme le dossier??
        • [^] # Re: Suite de l 'aventure

          Posté par (page perso) . Évalué à 2.

          il faut que tu aies la bonne version de kernel avec le bon kernel-source...
          ne renomme pas le dossier !
          mets à jour tes média:
          urpmi.update -a
          installe le dernier kernel:
          urpmi kernel-2.6
          installe les source de ce kernel (kernel-2.6.11.12 en ce moment, disponible dans les updates):
          urpmi kernel-source-2.6

          Maintenant que ton kernel et ses sources ont la même version, il faut redémarrer, pour tourner sur le nouveau kernel... Ensuite suis la procédure que je t'ai indiqué...
      • [^] # Re: C'est simple:

        Posté par (page perso) . Évalué à 2.

        J'avais oublié cette dépendance sur libstdc++...
        urpmi libstdc++
      • [^] # Re: C'est simple:

        Posté par (page perso) . Évalué à 2.

        au fait, pour savoir dans quel package se trouve le fichier toto c'est :
        urpmf toto
        après, installe le package correspondant avec urpmi...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.