Forum Linux.redhat Linux sur Acer Swift 3

Posté par . Licence CC by-sa
Tags : aucun
0
10
nov.
2016

Salut à tous,

Je viens de faire l’acquisition d’un Acer Swift 3 (http://www.ldlc.com/fiche/PB00217680.html). Bien évidemment, je voulais me faire rembourser Windows et installer Linux dessus, mais là patatras…. Impossible de faire quoique ce soit !

Aucune distrib ne veut se lancer. J’ai désactivé le Secure Boot. En fait, j’arrive jusqu'à Grub, mais j’ai un très rapide message « error file /boot/ not found ». Et une fois que je tape entrée pour valider « Try Fedora … » et bien il y a un écran noir et rien ne se passe.

Idem pour Lubuntu et Ubuntu…

Des idées ? Matériel incompatible ? J’ai encore 10 jours si jamais je veux le rendre, alors merci de vos réponses rapides par avance :)

  • # tout n'est pas perdu

    Posté par . Évalué à 2.

    En fait, j’arrive jusqu'à Grub, mais j’ai un très rapide message « error file /boot/ not found »

    si tu arrives au grub, c'est deja un bon debut c'est generalement le plus dur avec l'EFI, le secure boot, etc.

    comment prepares-tu ton media d'installation ubuntu ?
    ton media est-il sur un port USB3 ?
    je sais que parfois l'USB 3 est capricieux pour lancer linux il faut alors le desactiver dans le BIOS,
    tu passeras alors en USB2 ce qui largement suffisant pour un boot sur USB et une installation.

    • [^] # Re: tout n'est pas perdu

      Posté par . Évalué à 1.

      Merci pour ta réponse. Effectivement c’est aussi ce que je me suis dit vu que j’arrive au Grub…
      Alors, j’ai essayé deux méthodes pour préparer ma clé USB bootable : Fedora Media Writer et un classique dd. Je précise que les clés fonctionnent sur mon PC actuel (un Clevo, et oui la comptabilité tout de suite va mieux)

      Sinon, j'ai aussi essayé de lancer sur les deux ports que j’ai : un USB3 et un USB2. Je réessayerai si j'arrive à trouver dans le BIOS une option pour désactiver l’USB3.

      Une grande avancée : hier j’ai réussi à avoir une archiso qui a démarré. Mais ce qui est dingue, c’est qu’elle ne démarre pas du tout à chaque fois.. Archiso a fonctionné 2 fois sur environ 8 essais. Pour Fedora en revanche (la distrib que je veut installer), ben c’est toujours silence radio. J’ai un écran noir toujours après le démarrage…

      • [^] # Re: tout n'est pas perdu

        Posté par . Évalué à 3.

        archiso qui a démarré. Mais ce qui est dingue, c’est qu’elle ne démarre pas du tout à chaque fois.. Archiso a fonctionné 2 fois sur environ 8 essais.

        quand elle a demarré, c'etait un demarrage à froid (apres avoir completement eteint le PC) ?
        ou un reboot ?

        • [^] # Re: tout n'est pas perdu

          Posté par . Évalué à 1.

          Salut,

          Ben en fait, je ne peux jamais faire de reboot puisque soit j'arrive sur un écran noir, ou alors j’arrive sur l’install de windows que je ne poursuis pas puisque je veux pouvoir me le faire rembourser.

  • # un lien détaillé

    Posté par (page perso) . Évalué à 2.

    https://community.acer.com/t5/S-and-R-Series-Laptops/Ubuntu-on-Swift-3-SF314-51-74FW-black-screen-after-menu-on-Live/m-p/464481/highlight/true

    If you choose open source because you don't have to pay, but depend on it anyway, you're part of the problem.evloper) February 17, 2014

    • [^] # Re: un lien détaillé

      Posté par . Évalué à 1.

      Merci pour le lien, même si y a pas encore de véritables solutions, je vais jeter un coup d’œil.

  • # Linux Mint 18

    Posté par . Évalué à 1.

    Bonjour,

    La solution est d'ajouter "acpi=off" dans les options grub pour booter sur la clé usb.

    Ensuite le fait de ne plus avoir d'acpi fait que le touchpad ne fonctionne pas … Bref, il y a plein de chose a faire ensuite pour arriver a quelque chose de moyennement stable.

    J'ai le meme portable, acheté semaine dernière. Clairement, le modele est trop récent. Il faut participer et attendre des correctifs kernel et bios aussi je pense.

    Sur le forum acer, je vais détailler le process pour Linux Mint 18.

    • [^] # Re: Linux Mint 18

      Posté par . Évalué à 1.

      Salut,

      Merci de ta réponse.
      J’avoue que j’ai beau être un utilisateur quotidien de Linux depuis 6 ans, je n’ai jamais rapporté des bugs au noyau. Tu pourrais me donner quelques pistes ? À ton avis, combien de temps cela peut prendre pour qu’on ait enfin une distrib fonctionnelle sur ce PC ?

  • # Fedora sur cette machine

    Posté par . Évalué à 1.

    Je ne suis jamais arrivé à installer Fedora 24 (la version la plus récente) sur un Acer Swift 3 : kernel panic après le test de la clé, blocages de l'installeur, etc.
    Puis j'ai essayé d'installer la version 23 de Fedora, et ça passe. Sauf que le wifi et l'HDMI ne fonctionne pas. La connexion ethernet, avec un adaptateur USB-RJ45, fonctionne heureusement :-)

    La mise à jour de Fedora 23 apporte le noyau 4.7.10-100, et bloque juste après le grub.
    La mise à niveau vers Fedora 24, avec le noyau 4.8.6-201, bloque au même endroit.

    J'ai donc pour l'instant une fedora 23, avec le noyau 4.2.3, sans wifi ni sortie HDMI.

    J'ai pu constater lors d'une tentative d'installation que le wifi et l'HDMI fonctionne avec fedora 24.

    NB : j'utilise un boot Legacy. Et les noyaux "rescue" ne fonctionnent pas mieux.

    • [^] # Re: Fedora sur cette machine

      Posté par . Évalué à 1. Dernière modification le 12/11/16 à 10:27.

      Salut,

      Merci pour ton retour. Pourrais-tu me dire avec quel mode tu as réussi à démarrer sur Fedora 23 ? UEFI avec/sans Secure Boot ? Legacy ?

      • [^] # Re: Fedora sur cette machine

        Posté par . Évalué à 1.

        Comme je l'ai écrit, j'ai mis le Bios en Legacy.

        J'ai aussi essayé les autres modes (UEFI avec et sans Secure), mais sans succès.

        • [^] # Re: Fedora sur cette machine

          Posté par . Évalué à 1.

          My fault, j’avais pas lu jusqu'au bout… Merci

          Selon toi, est-ce que je peux garder le PC ? Le support de Linux ira en s’améliorant ou ça va jamais évoluer et restera un peu chaotique ?

          • [^] # Re: Fedora sur cette machine

            Posté par . Évalué à 1.

            Je me garderais bien de faire un pronostic sur le futur :-)

            Comme le dit garmout, cette machine est très récente et conséquemment mal supportée.
            Le fait que l'HDMI et le wifi sont pris en charge par fedora 24 est plutôt de bon augure, mais (pour l'instant ?) les noyaux de fedora 24 ne fonctionnent pas.

            Il faudrait essayer de lancer une fedora 25 live (en beta pour l'instant) pour voir si ça améliore les choses. On saura alors si à terme une fedora sera opérationnelle sur cette machine.

            • [^] # Re: Fedora sur cette machine

              Posté par . Évalué à 1.

              Re,

              En fait, la première iso que j’ai voulu tester, c’était justement celle de Fedora 25 Beta… qui n’a pas fonctionné. Mais je n'ai pas testé avec acpi=off, je vais réessayer

  • # Quelques nouvelles

    Posté par . Évalué à 1.

    Salut,

    Quelques news : suite à la suggestion de garmout sur le forum d’Acer, Fedora 25 Beta démarre en mettant le mode acpi=off dans le BIOS. Le touchpad n’est de ce fait pas fonctionnel, je vais tenter de trouver une solution.

    Je suis toujours motivé pour aider à la résolution de ces bugs en fournissant aux développeurs du noyau des journaux systemd et all what they need… N’hésitez pas à me dire quels logs seraient selon vous les plus pertinents pour les aider !

    Merci

    • [^] # Re: Quelques nouvelles

      Posté par . Évalué à 1.

      Pour info, j'ai essayé en 64 bits fedora 23 et fedora 24, avec les options du noyau "acpi=off" ou "pci=noacpi" ; mais soit l'install ne passe pas, soit le touchpad ne fonctionne pas.

      Je reste donc sur fedora 24 en 32 bits, avec laquelle la machine est 100% fonctionnelle. Les 8 Go de RAM sont bien reconnus car le noyau vient avec l'extension PAE par défaut.

  • # i386

    Posté par . Évalué à 1.

    La solution : version 32bit/i386 + kernel 4.8

    Pour Ubuntu 16.10, ca marche direct en i386 car noyau 4.8.

    Pour Linux Mint 18 et autres distribution avec noyau 4.4, install et premier boot avec acpi=off puis mise a jour du noyau en 4.8 + firmware.

    • [^] # Re: i386 - fedora

      Posté par . Évalué à 1.

      Merci pour le tuyau !

      Je confirme : fedora 24 en 32 bits est complètement opérationnelle.

      • [^] # Re: i386 - fedora

        Posté par . Évalué à 1.

        Salut

        Du coup, comment peut-on rapporter ce bug pour le 64 bits ? Sur bugzilla.kernel.org ? Dans quelle section ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.